Page 24 of 35 First ... 14222324252634 ... Last
  1. #231
    Trenloe,

    Thanks for everything you do. I love this extension! However, I had to unload it today. I tried the latest version and I a still getting very weird things happening with the grid when I zoom. The grid, the tokens, and the map pins, all continue to zoom and go out of place while the map says in one location.

    Is this something I'm doing that I can fix or a problem with the latest 3.3.0 update?

  2. #232
    Trenloe's Avatar
    Join Date
    May 2011
    Location
    Newcastle, UK (for a bit)
    Posts
    24,450
    Quote Originally Posted by Chadarius View Post
    Trenloe,

    Thanks for everything you do. I love this extension! However, I had to unload it today. I tried the latest version and I a still getting very weird things happening with the grid when I zoom. The grid, the tokens, and the map pins, all continue to zoom and go out of place while the map says in one location.

    Is this something I'm doing that I can fix or a problem with the latest 3.3.0 update?
    I'm not sure what is going on here. Please provide screenshot to show what's happening. Thanks. Also, please provide a screenshot of the chat window after campaign load - so I can see the versions of the rulsets and extensions loaded.
    FG Con 16 Fantasy Grounds Online RPG Convention - Friday April 24th to Sunday April 26th, 2020
    Register at www.fg-con.com for all the latest info.

    Private Messages: My inbox is forever filling up with PMs. Please don't send me PMs unless they are actually private/personal messages. General FG questions should be asked in the forums - don't be afraid, the FG community don't bite and you're giving everyone the chance to respond and learn!

  3. #233
    We experienced the same issue as Chadarius in our game last weekend. It's hard to explain, but fortunately I record our games so I'm able to show you exactly what happens. The weirdness occurs when zooming in/out & panning the map. The first 10 seconds shows the chat window on campaign load, then after it shows the grid/map stuff.

    https://www.youtube.com/watch?v=SqcYxNMXb04

  4. #234
    Trenloe's Avatar
    Join Date
    May 2011
    Location
    Newcastle, UK (for a bit)
    Posts
    24,450
    Quote Originally Posted by Rades View Post
    We experienced the same issue as Chadarius in our game last weekend. It's hard to explain, but fortunately I record our games so I'm able to show you exactly what happens. The weirdness occurs when zooming in/out & panning the map. The first 10 seconds shows the chat window on campaign load, then after it shows the grid/map stuff.

    https://www.youtube.com/watch?v=SqcYxNMXb04
    Thanks for providing the video - that helps a lot.

    EDIT: Sorry, I didn't realise that this was a player view, not the GM.

    Can you ask the GM to check what size that image file is? I think this occurs if one (or both) of the image dimensions are less than 500 pixels.
    Last edited by Trenloe; May 31st, 2017 at 16:33.
    FG Con 16 Fantasy Grounds Online RPG Convention - Friday April 24th to Sunday April 26th, 2020
    Register at www.fg-con.com for all the latest info.

    Private Messages: My inbox is forever filling up with PMs. Please don't send me PMs unless they are actually private/personal messages. General FG questions should be asked in the forums - don't be afraid, the FG community don't bite and you're giving everyone the chance to respond and learn!

  5. #235
    Trenloe's Avatar
    Join Date
    May 2011
    Location
    Newcastle, UK (for a bit)
    Posts
    24,450
    Quote Originally Posted by Rades View Post
    We experienced the same issue as Chadarius in our game last weekend. It's hard to explain, but fortunately I record our games so I'm able to show you exactly what happens. The weirdness occurs when zooming in/out & panning the map. The first 10 seconds shows the chat window on campaign load, then after it shows the grid/map stuff.

    https://www.youtube.com/watch?v=SqcYxNMXb04
    I found what's causing the issue. The base FG settings for the image control will create the play and features layer at a minimum of 500x500, even if the image file is smaller than this - thus these layers will be 500x500 in size for small maps, which results in them slipping/being offset from the underlying map image.

    Fix to come...
    FG Con 16 Fantasy Grounds Online RPG Convention - Friday April 24th to Sunday April 26th, 2020
    Register at www.fg-con.com for all the latest info.

    Private Messages: My inbox is forever filling up with PMs. Please don't send me PMs unless they are actually private/personal messages. General FG questions should be asked in the forums - don't be afraid, the FG community don't bite and you're giving everyone the chance to respond and learn!

  6. #236
    Trenloe's Avatar
    Join Date
    May 2011
    Location
    Newcastle, UK (for a bit)
    Posts
    24,450
    v2.0.5e bugfix release.

    Fixes grid slip/alignment issues for maps below 500x500 pixels in size. Video of issue here: https://www.fantasygrounds.com/forum...l=1#post340210 Thanks Rades!

    The issue is due to the base Fantasy Grounds image control having it's minimum drawing size set at 500x500 pixels. The layer extension uses these drawings for the feature and play layers (middle and top, respectively). If the base map image is less than 500x500 pixels, FG will make the middle and top layers 500x500 - which results in grid and token slip/misalignment when panning/zooming. This can't be changed programmatically with the setDrawingSize command as FG won't go below this 500x500 minimum. So, the only solution is to reduce this minimum drawing size in the FG XML specification.

    The bugfix in v2.0.5e reduces the minimum to 200x200 - so don't use maps any smaller than this. The downside is that if you create a new blank map through the FG interface (new map), then it will be 200x200 pixels in size - and the expand image right-click functionality doesn't really work with the layer extension. So, I'd recommend you don't use the base blank FG new image functionality with this extension. Have a nice blank image (say 1000x1000) that you can use as a base map if you want to have something similar to the blank FG map.

    Note: Installing this extension will not immediately fix any previously opened images - as FG has already set the drawing size to 500x500 in the campaign.

    The quick way to fix this is to go to <FG app data>\campaigns\<your campaign name>\drawings and delete all of the drawing_xxxxxxx.png files that are 500x500 pixcels in size. This would remove any drawings you've made on the images using the freehand drawing tool. It won't impact the mask, as this is stored elsewhere.
    Last edited by Trenloe; May 31st, 2017 at 19:41.
    FG Con 16 Fantasy Grounds Online RPG Convention - Friday April 24th to Sunday April 26th, 2020
    Register at www.fg-con.com for all the latest info.

    Private Messages: My inbox is forever filling up with PMs. Please don't send me PMs unless they are actually private/personal messages. General FG questions should be asked in the forums - don't be afraid, the FG community don't bite and you're giving everyone the chance to respond and learn!

  7. #237
    Oops, forgot to mention it was player view, haha. But glad you realized! Thanks for the quick fix, Trenloe!

    I'll test this when I get home from a DM perspective. The only thing I'm worried about is that I did have this happen to me (as a GM) once before as well, but it was with an image definitely larger than 500x500 (ironically I thought the problem might have been an image TOO large in terms of dimensions). But it only happened to me once, and I didn't have video evidence, so I didn't mention it earlier or post here about it at the time.

    Mind you, I got around the problem then by completely deleting the map out of the Fantasy Grounds images folder, then putting it in again with a different name, and that seemed to fix it. So maybe it was still a problem with the drawing_xxxxxxx.png files? In any case, will report back if this happens again.
    Last edited by Rades; May 31st, 2017 at 18:52.

  8. #238
    Trenloe's Avatar
    Join Date
    May 2011
    Location
    Newcastle, UK (for a bit)
    Posts
    24,450
    Quote Originally Posted by Rades View Post
    So maybe it was still a problem with the drawing_xxxxxxx.png files?
    I think it probably is related to these. If it happens again for a large image please ZIP up the whole directory for the campaign in question and PM me a link to download. I'll then look at the image, the FG database and the drawing files and see if I can work out what's going on.
    FG Con 16 Fantasy Grounds Online RPG Convention - Friday April 24th to Sunday April 26th, 2020
    Register at www.fg-con.com for all the latest info.

    Private Messages: My inbox is forever filling up with PMs. Please don't send me PMs unless they are actually private/personal messages. General FG questions should be asked in the forums - don't be afraid, the FG community don't bite and you're giving everyone the chance to respond and learn!

  9. #239
    Hello, not 100% sure it comes from this extension, but I still have my players experimenting this zoom strange behavior described here. Also have couple of players that have randomly the mask not working correctly, they don't see when I discover part of the fog, only deleting the full mask works.

    After couple of tries if finally worked well last night, but rather randomly...no cache reset..
    Maps are all officials PotA maps...many players also have error warning messages when I first launch the map. With no impact though..

  10. #240
    LordEntrails's Avatar
    Join Date
    May 2015
    Location
    GMT -7
    Posts
    8,645
    Blog Entries
    9
    Quote Originally Posted by Glad View Post
    Hello, not 100% sure it comes from this extension, but I still have my players experimenting this zoom strange behavior described here. Also have couple of players that have randomly the mask not working correctly, they don't see when I discover part of the fog, only deleting the full mask works.

    After couple of tries if finally worked well last night, but rather randomly...no cache reset..
    Maps are all officials PotA maps...many players also have error warning messages when I first launch the map. With no impact though..
    Have them send the warning messages and let us know what they say, those will be important to figuring out what might be the issue.

    Current Projects: Ultimate Undermountain (NYDUM)
    Community Contributions: Gemstones, 5E Quick Ref Decal, Adventure Module Creation, Dungeon Trinkets
    DMsGuild Content: Balance Disturbed (Adventure), Dungeon Room Descriptions
    FG Product Reviews: Virtual Scribe Reviews

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in