1. #1

    need 4E Parser help

    I just got FG after 1/3 of my group was forced to move away. I got set up and am trying to use the 4E parser. I got started with Martial Power, as it is the one I use the most and it worked fantastically. However, I tried the PHB next and I am having some trouble with it.

    No trouble scraping. I was even able to review the .txts. however, when it comes to parsing, I keep getting an error. I tried scraping again, but I got the same error. I've never practiced xml much and need some help figuring this out.

    ERROR:System.Xml.XmlException: The '\' character, hexadecimal value 0x5C, cannot be included in a name. Line 12774, position 397.
    <secondarytarget type="string">Text removed for the benefit of WotC</secondarytarget>
    <secondaryattack type="string">Strength vs. Will</secondaryattack>
    <secondaryhit type="string">Text removed for the benefit of WotC</secondaryhit>

    </powerStunningSmite>
    *** <powerFateOfTheVoidWarlockPactBoon1Text removed for the benefit of WotC\rText removed for the benefit of WotC>
    <name type="string">Fate of the Void Warlock Pact Boon 1 Text removed for the benefit of WotC\r Text removed for the benefit of WotC</name>
    <level type="number">0</level>
    <tier type="string">Heroic</tier>
    <type type="string">Power</type>
    <flavor type="formattedtext"><p><i></i></p></flavor>
    I thought it was talking about the "\r", but upon reviewing the scraped data, the "\r" appears throught the entire thing, even in parts with appeared on the xml correctly. I'm trying to find out if it is a problem with the pact boons, maybe?

    I have a DDI account
    the information was scraped in Compendium mode.
    4E Parser version 4.0.103.0
    FG2 Version 2.6.5

    If I just knew what I needed to change, I could probably figure out the rest from there. Or in case it happens on another book.

    Thanks in advance.
    Last edited by Teonis; September 23rd, 2010 at 05:07.

  2. #2

    Join Date
    Mar 2006
    Location
    California
    Posts
    6,463
    Code:
     <powerFateOfTheVoidWarlockPactBoon1Text removed for the benefit of WotC\rText removed for the benefit of WotC>
    See that red slash above? That's your problem XML can't have a \ in the middle of a tag like that it is a special character used to close one sided elements. Basically the WotC data is messed up.

    You need to go into your txt file and fix it then reparse. Here is what others have done: http://www.fantasygrounds.com/forums...79&postcount=8

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in