View Full Version : Exporting Module with multiple species or talent categories/groups

September 1st, 2023, 05:24
I'm having some difficulty exporting a module with multiple species and talent categories/groups (I'm not sure what the terminology is supposed to be, but in the STA module items without a group are "uncategorized"). I created a campaign, and added some talents and species under a category, and some in another. But only one category of species/talents exports, even if I have the "all" checkbox selected, or even if I drag everything manually to the export window. It does this even when I have a species from one category linking to a talent in the other. I'm not sure if this is an STA issue or a general Core issue, but searching google and the wiki hasn't helped.

Edit: I'll share the specific use I have: When I purchased the Picard Season 1 Crew Pack, I noticed that Seven had an additional Liberated Borg trait that hadn't been part of the Delta Quadrant book. So I wanted to add it under a 'Picard S1' category, and then export the Delta Quadrant Lib. Borg species and Talents in addition to the Picard talent as a "Liberated Borg" module. But the Picard talent doesn't show up, and testing with made up stuff also seems to indicate only one group/category can export at one time.

Edit 2: It's not that it doesn't export entirely, because
<category name="UNOFFICIAL Picard S1 Characters" /> or
<category name="Group 1" />shows up in the xml, but it is a self-closing tag with no content.

September 1st, 2023, 05:34
I'm not sure the process you are going with creating the categories, but from the masterindex (window when you click on the sidebar button) you would click on the category selection on the top of the frame and then expand the list. From there you would click on the add button and then ensure it's in edit mode by clicking on the '/' edit button. Change the name to what you would like to see and then from there there are two options. If you haven't made the record, click on the category and then add a new record, or click and drag the record to that category to add to it.

When you export you don't have to choose every option just the record type you wish to export and as long as the record is attached to a category, it will export with that category name when you load the exported module. If you are still having some issues with the process above, I may need more visuals on your process and see where it's not completing. I have tested with the above and a test module was able to export test records and the categories I attached them to.

September 1st, 2023, 06:06
Well, I just tried it with some test species/talents in a new campaign, and it worked. I'm not sure why it didn't work with my existing campaigns. As far as I know, everything is the same, and both use data version 20230601, release 2 (although it did appear in data version 20220901 release 1, I just apparently loaded the campaign and never the module to a new campaign).