View Full Version : Call of Cthulhu 7e - skill issues

March 5th, 2023, 20:09
I tried adding a custom skill to a pc character sheet, and now, not only didn't the customer skill work, but...

1) I don't have any values in the extreme and hard boxes on characters sheets in any CoC campaign (not just the one I tried adding the skill to).
2) When I open any character from the campaign that I tried to add the skill to, it throws a script error.

I'll attach screen shots.

March 5th, 2023, 22:48
How did you add this skill StickClip?

March 6th, 2023, 01:04
Hey damned,

From what I remember, here's the steps I took that messed up my skills...
1) Opened up Characters tab
2) Opened up a character
3) Clicked on Skills
4) Clicked on edit skills
5) Clicked on the green +
6) unlocked the 1920s padlock
7) Hit green +
8) Typed in new skill
9) I may have tried dragging the new skill to the character sheet

All the skills for this character went blank. Now they show up but throw that script error when I open any characters in that one campaign. All characters, in all campaigns, are missing the hard/extreme scores now.

I do have a backup of my whole fgdata from a few days ago.

I'll attach a printscreen of where I added that skill (obviously incorrectly). Let me know if you need any files or anything.


March 6th, 2023, 01:07
here's a printscreen of the skill I added..

March 6th, 2023, 03:48
Can you share your db.xml - I cannot replicate

March 6th, 2023, 04:17
sure, here you go...
db0.xml is from the campaign where I added the skill
db1.xml is from another campaign that is missing the hard/extreme skill values

not sure those attaches worked - how to I send them to you?

March 6th, 2023, 04:21
Can you also screenshot the chat window when the campaign first loads?

March 6th, 2023, 04:58
no prob

March 7th, 2023, 01:53
Someone else reporting something similar here: https://www.fantasygrounds.com/forums/showthread.php?69887-Official-Call-of-Cthulhu-7th-Edition-Bug-Report-Thead
Not found teh cause yet.

March 7th, 2023, 02:09
Ok can you both check all your Eras - but probably just the Active era (default is 1920) and see if you have any blank entries [1]?

If you do either delete them, or click the link Icon [2] and add at least a Name and reload the table and retest?


March 7th, 2023, 05:19
Thanks for the help here.
So I deleted that blank skill in the 1920s era, and the script error went away..woohoo!
I'm still seeing blank extreme/hard skill values for everything except combat skills for all campaigns (swear they used to be there).
Also, I probably need to get the steps to correctly add skills. Can players add them too, or just the gm?

March 7th, 2023, 06:57
Yes Hard/Extreme should be there - it looks like something has broken with them on the last update.

I dont recall sorry re Players and Keeper... let me test over the next couple of days and write it up for you.

March 7th, 2023, 14:45
Ahhh I thought I'd broken them with my skill issue, so glad it's not just me.
thanks for the help

March 7th, 2023, 15:35
I think Ive found the issue/fix. Pushed to SmiteWorks - with some luck it will be available in the next 24 hours.

March 7th, 2023, 23:49
it's fixed - you guys are fast- thanks

March 7th, 2023, 23:57
Thanks for the confirmation.