PDA

View Full Version : What do Deprecated Errors mean?



ryanabca
April 7th, 2022, 03:50
I keep on getting these messages when I use certain extensions ...

ActorManager.getActor - DEPRECATED - 2021-01-01 -
Contact forge /extension author

I noticed it when I was trying to use the Automatic Return Damage extension.

I have downloaded all of the latest extension version off DM Guild that I own and I am sure that some won't work anymore.

Any suggestions?

bmos
April 7th, 2022, 03:52
I keep on getting these messages when I use certain extensions ...

ActorManager.getActor - DEPRECATED - 2021-01-01 -
Contact forge /extension author

I noticed it when I was trying to use the Automatic Return Damage extension.

I have downloaded all of the latest extension version off DM Guild that I own and I am sure that some won't work anymore.

Any suggestions?The error just means that the author of that extension has not updated it properly since Feb 2021.
Fortunately for now these errors are just informational, but in the near/mid future any extensions currently triggering these errors will stop working.

Trenloe
April 7th, 2022, 06:20
Welcome to the FG forums @ryanabca!


Any suggestions?
Disable your extensions one by one, when the error message goes away then the last extension you disabled is partly responsible - get in touch with that extension developer to see about an update.

Mavrik6666
April 7th, 2022, 16:29
I posted on a thread, as I was getting the same error - and seemed to go when I removed the 'Ammunition Manager ' extension

But an odd on occured - I got it again, when I joined a game where the Dm had that extension loaded, but no one else got the error!