View Full Version : Error when trying to add a new item

December 16th, 2021, 22:01
I've been trying to add an item in the forge and keep getting this message:

{"message":"CSRF token is invalid or expired"}

December 16th, 2021, 22:11
Not sure if it's related, but I'm also seeing this error message whenever I click "Manage Craft", or hit refresh while on the Manage Craft page:


December 16th, 2021, 22:12
That error usually appears when you have been inactive for too long and your session has expired. Which should be more than 15 minutes.

December 16th, 2021, 22:12
I just rebooted my machine, logged out of the FG site and back in, still happening.

December 16th, 2021, 22:15
That other error is something unrelated. For the initial issue, it is also possible that it is due to blocking cookies or a corrupted cookie perhaps, maybe try clearing your cache?

December 16th, 2021, 22:19
For what it's worth, I've done a bunch of managing my existing items today with no errors. It's only trying to add a new one that is failing.

December 16th, 2021, 22:24
Cleared cookies in all three FG domains and tried again. Same result.

December 16th, 2021, 22:34
And it is just when adding a new item? I'll look into it. Could you post an image of the item screen when the error pops up?

December 16th, 2021, 22:38
One other thing that is weird is that I can't click the "Save Item" button at the bottom of the Add Item screen. I have to tab onto it and then hit space.
I am attaching two screenshots. The first one is the data for the item I'm trying to add, and the second is the error screen.


EDIT: And the HTML for the error page if that matters:


December 16th, 2021, 22:52
That is a strange bug, if you increase the long description to over 100 characters it should work again, as that error pops up for just a moment before causing that weird redirect, which I'll see if I can fix.

December 16th, 2021, 23:33
Okay, all those bugs should be fixed now! Please let me know if you have any further issues.

December 17th, 2021, 08:59
Have you tried a different browser? Sounds like a browser or security thing.