View Full Version : Forge Item: Vampire 5e Expanded SPCs and Equipment

November 28th, 2021, 04:10
I made some detailed SPCs from all released books that include Discipline powers. It also includes some guidelines for creating Vampire SPCs by age category (Childe, Neonate, Ancilla, Elders).
You can get it on the Forge: https://forge.fantasygrounds.com/shop/items/380/view

5 detailed SPCs from the core book as well as 12 mortals in the Weak/Average/Gifted/Deadly categories.
6 Abbreviated Animal SPCs
26 Abbreviated Mortal SPCs
34 Abbreviated Supernatural SPCs including Ghouls, Ghouled Animals, Ghosts, Szlachta, and Zombies
14 Abbreviated Sabbat SPCs with Discipline powers

Also includes more armor and weapons and concealment levels.

5 types of armor
26 Firearms and Melee weapons

December 30th, 2021, 23:15
here is some feedback after reviewing the module:

Missing a space on Range for Pistol, Medium 25meters.
Same for sub-machine gun, Small.
Rifle, single shot should have capital S and S to be consistent with the others.
Sub-machine gun should have capital M and G to be consistent with ID and as it is usually also abbreviated as SMG.
"Tactical SWAT" should be "Tactical SWAT Armor" instead.
Range is missing on thrown objects e.g. knife

Where did you take the range from, AFAIK there is no range mechanics in v5? They do not correspond to v20 values unlike the concealment.

There are errors when opening SPC and it tries to display the Abbreviated SPC token and discipline token on SPC
Same on SPCs.
It looks like the tokens are missing from the module while being referenced to being in the module.

December 31st, 2021, 15:42
Thank you for the feedback. I've updated the mod file with your suggested changes.

The ranges were taken from individual weapons in the class. I didn't average all of them, so some could be different based on individual weapons.

I'm not sure what's going on with the tokens, I used the default letter tokens included with the ruleset, no tokens are exported just links to the default tokens. I re-applied them. Let me know if that's still not working.

January 1st, 2022, 12:17
Thank you, apparently the update has not been pushed yet on the forge as I did not see the changes. I'll try again later.

January 1st, 2022, 15:18
Yeah, still says, "Status: You currently have a build queued for processing.", probably delayed due to the holiday weekend.

January 1st, 2022, 15:56
Thank you for confirming.

January 4th, 2022, 16:11
Looks like something is not working properly on the forge.
While the forge mentions the product having been update 2 days ago, when I have tried to update it, nothing was changed.
I have also tried by deleting the vault object with the UUID 337b1fb6-5001-11ec-8c52-0050562be458 and update again, no success.

January 4th, 2022, 16:16
I just changed the channel to live for the updated file, so it should be good to go now.

January 4th, 2022, 18:08
Thank you, indeed it has updated correctly now.
The issue remains with tokens, the rest is fine.