PDA

View Full Version : MoreCore - first use - fails



phloog
May 1st, 2021, 05:29
When I attempt to make a MoreCore campaign, and use two downloaded modules, the modules work but I have NO buttons on the sidebar other than the standard ones at the top (Party tracker, mods, FX, etc.)

The log shows this:

[4/30/2021 11:25:03 PM] MEASURE: MODULE LOAD - 1.2627538 - Dungeon World - GM
[4/30/2021 11:25:03 PM] MEASURE: MODULE LOAD - 0.2533219 - Dungeon World - Player
[4/30/2021 11:25:03 PM] [WARNING] template: Could not find template (button_library_sidebar) in class (shortcutbar)
[4/30/2021 11:25:03 PM] [ERROR] Handler error: [string "scripts/manager_desktop.lua"]:437: attempt to index local 'c' (a nil value)

Is my MoreCore install corrupt...can I somehow redownload it without messing up the parts of FGU that ARE working?

EDIT: OLD PAK apparently...I thought Check for Updates updated everything..??? Apparently not.

Thanks,
JT

superteddy57
May 1st, 2021, 05:39
MOD - Moved to MoreCore forum as this appears to be a ruleset error and not a FGU issue.

johnecc
May 1st, 2021, 09:33
Phloog, when you run an update, it only does those components in the FGU program, and any purchased products from the store.

Any 3rd party modules/extensions, such as MoreCore, need to be manually updated when the author releases an update. It is up to you to keep an eye on the forum thread for the ones you use.

On a positive note, Smiteworks have the intention (after v4.1 and the lighting update) of creating a system, called the Forge, where community developers will be able to publish their extensions/modules, and the system will automatically update them as well. But there iscurrently no timeframe for this.