View Full Version : Going from 1.61f to 1.62 MoreCore

April 29th, 2021, 03:49
DISCLAIMER: This could all be problems from some customizations I did that need to be updated due to CAS-roller changes (I noticed the expendable thing for one) but I wanted to check.

I updated MoreCore in FGU (in FGC was still running the older MC 1.61f) and found I could no longer drag my module's recreated "rolls" to my character sheet. I drag to it and nothing gets added. I can right click add new entries but not drag to it.

I presume this is only a me-thing, but wanted to be sure since I don't often get chance to read many of the threads. Right now, I need to get off to work on the aftermath of a successful (due to LUCKY updates hours before the test) test with a major bank but we found when a round robin routing was added with second major bank, the gateway to the first did bad things with queue processing. Evil nasty things for which Zoot will punish it after I pinpoint exact cause.

I suspect it was my updating of the CLIList thing to support an extra field to indicate position in sort order (anal and liked having stats in SIWDCH and d4,d6,d8,d10, d12 (vs d10,d12,d4,d6,d8) etc. But to do that I had to override a file copying some of it to make mods. Suspect that needs updating finally after MANY MC updates where it didn't matter.

Also, I have added 2 rollers, oddly only one (swthac0) of which appears in those LONG list things given in the instructions (icons or something?) and in the if/else set icon thing (in all cases, reusing icons from MC) but yet clicking on the thing, both work equally well. I tried adding a new one for turning undead and just added it to the if/else and not the other like my (swdamage) but nope - doesn't seem to call it. For this I will go back and go through all the steps for what I missed. But wondered WHY my swthac0 AND swdamage both work and only thac0 followed all the indicated updates.

---> Update, the undead roller is indeed found without following the full instructions, I had a typo in the extension.xml path

April 29th, 2021, 06:15
I'm in a game at the time, but it hit me as I was comparing things - perhaps it is because it was exported with older 1.61, but if that was all - then it would be an issue for more ppl so maybe still just my stuff - but I went over record_cas.lua, doesn't look like that one (and it is added there) but still looking

EDIT: Nope... nm - I tried to create a roll in the campaign itself and then dragged that, so that knocks out theory of earlier ones only being prevented. Couldn't drag this one. Wish there was a log error/warning but no clues yet.

EDIT2: Nope-squared ... so I am out of ideas for tonight. I took the MoreCore1.61f from my Classic install and moved it to replace my 1.62 in Unity and nope, same thing cannot drag existing stuff from my module to the character sheet (which I could do in Classic with 1.61f (never tried 1.62 in Classic - now need to see diff between FG versions in case my Unity is ahead/behind my Classic)

If anyone has clues or places to look - would appreciate.

April 29th, 2021, 13:39
Hi Varsuuk

I am running the same build of 1.62 and I can drag Rolls from the Library onto my Character Sheet.

May 1st, 2021, 04:14
Yup, and I tried downgrading to 1.61f and it also didn't work so I need to look at other things. But I don't need to drag anything for the code I am working on atm, so will look at this soon but not yet

As always, thanks for the followup :)

May 1st, 2021, 09:34

Before I head to bed, I decided to try one thing.

I took my extension from the Unity extensions directory and after moving the existing older (running in FGC) version of my extension to a temporary directory, I put the new Unit one there.

I created a new campaign and chose the MC1.62 along with the extension that wasn't taking drops in Unity.
I didn't open any modules so I opened Rolls UI and added a dummy roll. I then proceeded to drag it to an empty character sheet with no issue. This doesn't work if I do it under FG Unity.

I wonder what I did that causes this under Unity. Next tomorrow will take the extension and move it to my other Windows PC to see if it has something to do with either MAC running Unity or simply that install or if it happens on my WinBox as well.

Will post update tomorrow.

May 2nd, 2021, 00:58
Well... the "good" news is it is not a WINDOWS/MAC thing in Unity.

I ran it on my Windows box and it will not drag drop the Rolls. Non-rolls are fine (Class/Race etc)
I would think I somehow deleted a line, edited something accidentally or on purpose that changed BUT ... taking this same extension (ruleset on MoreCore) to my FGC build works fine.

So, my clues are:
1. Cannot drag and drop, it is not 1.61 v 1.62 issue Ince I verified using 1.61 that still happens.
2. Same extention/MoreCore in FGC (version: v2021 04-20 CoreRPG) on my Parallels VM on my Mac (Just tested my ext/MC on PC Unity, will moved those same 2 directories to my Win FGC to see if it STILL works there to make sure it's not something on my VM Windows FG version that allows it - I did all my dev work until recently in FGC on the VM)

I guess my next step after the test I mention in #2 is to find where in the MoreCore code it handles Drag and Drop and see what can cause it not to complete.


1) Win/FGC test results:

Tested with currently installed FGC on my Win box: v3.3.12A CoreRPG (old obviously) and it dragNdrops fine
(going to update FGC then retest with newest)

Finally test (other than the fonts and colors/texure) of my sidebar going plain grey vs torn-edge blue, it works correctly. I am able to drag and drop with FGC running MC 1.62 and Core 2021-04-28.

So WHY not in FGU?
I guess time to look for where DragDrop happens...

May 2nd, 2021, 01:43
The created <cas> between working FGC and not working FGU is identical in db.xml for the campaign (other than <description was empty and on FGU it was <p /> and on FGC it was <p></p> I changed it to the FGC value JUST in case (no change).

Haven't seen the code for handling the drop other than seeing in clilist <acceptfrom>cas<...> entry.
Still looking but dinner soon :(

Damn, I am clueless, not seeing an onDrop() for these things so it must be "automatic" due to that "acceptfrom> then maybe merging incoming to the control. If THAT is so, 2 things: I should find everything I TRIED to drag in the current XML just not visible and 2) the issue is one of updating?

Will look cos at a loss...

Nope... all my ideas are teh suk.

May 2nd, 2021, 04:05
See lines 229-234 (there are several other sets of these) in /campaign/record_char_more.xml


May 2nd, 2021, 04:15
Yeah, that’s whT I meant by the “magic” api handling vs “onDrop()” code. The items are still CAS that I’m dropping and never changed any accept from so no clue.

Eating dinner now but Potter noticed something on the latest I sent him - it works on the OTHER morecore tab. MoreData? If I recall. The top windows their still accept roll drags so I will look at this after I eat to see how differs for a clue.