View Full Version : Low-end graphics card, ugly dice...

June 25th, 2007, 08:03
Hi guys,
I just got a new laptop running Vista. It's a fairly high spec machine except for the onboard graphics card. FGII works pretty well on it but the dice are quite difficult to read - I think the reflections/environment map or whatever is not being rendered properly so they appear almost unlit. Is there some sort of setting in FGII (or in my graphics settings) that I can flip to make the dice readable again (like ambient-only lighting or something?) Thanks!

June 25th, 2007, 12:09
One of the devs might have an idea here, but AFAIK, there's no option that we've been told about. As a workaround, have you tried changing your dice color? You might be able to find a setting that's easier to read.

June 25th, 2007, 12:31
Still wondering if there's a solution for this but that was a pretty good tip. Thanks! I made them black with white text and they're almost readable - text is a very dark grey (like 80%-85%). Not great but probably workable.

BTW, reflections seem to render okay in the included MS games (like Chess Titans).

June 25th, 2007, 20:21
It must be a pretty high powered laptop to run a non basic verion of Vista. Unfortunately Vista's very graphics heavy enviroment and the graphics card requirements will stop many from being able to upgrading to it without buying a new card. I think it is possible you problem is because of the lack of video card horsepower. Laptop video cards usually stink - to put it bluntly - power consumption is far more important for most manufactorers.

As a work around for your dice try changing you destop to a non glass one before running FG to relieve stress on your video card. IE, Right Click on the Destop -> Personalize -> Window Color and Appearance -> Open classic appearance properties for more color options -> select Windows Vista Basic - if that is what you have selected then select Windows Classic. Hit OK and then try running FG and see if it makes a difference.

If that doesn't help see if you can find some better drivers for your card.

June 25th, 2007, 20:22
Is that the same thing as turning of the Aero interface? Thats what eats up a lot of graphics memory for all applications.

June 25th, 2007, 20:26
Yeah, if you go to classic it cuts off the glass.

June 25th, 2007, 20:32
Thanks for the advice...will try it. Maybe that'll improve my performance in general.

Yeah, the machine is fine...dual core, 1gb, etc. but the graphics is an Intel hunka junk. I was just looking for a cheap laptop for work, not so much gaming, and I had a hard time finding one with an ATI or NVidia chip onboard. The performance rating thingie that ships with Vista ranks everything but graphics performance at 5...graphics gets a 3. That said, I like Vista quite a bit so far. And I simply LOVE Office 2007. But, then, I'm no MS hater.

Edit: just turning off transparency increases performance quite a bit (it's pretty noticeable) but even classic doesn't seem to fix the dice rendering problem. I think it's that the chip doesn't support environment maps or reflection maps or whatever is trying to happen here. The only settings panel I can find is for OpenGL. Thanks for the suggestion though! BTW, classic seems really ugly to me now :) I may take the performance hit just for the prettiness.

June 25th, 2007, 20:59
The rolling dice are probably just about the only reason FG really needs DirectX, everything else is pretty vanilla. FG works fine on my P4 1.8 laptop but I've only got XP Pro on that and I use a G-Force card instead of the build in graphics card. That computer would never handle Vista.

You might double check you have the latest DirectX. The other issue is the card may not be fully DirectX compliant (which is common in laptops).

Classic does look really dated, now doesn't it? :p

June 25th, 2007, 21:57
The other issue is the card may not be fully DirectX compliant (which is common in laptops).

I'm guessing that this is the problem. Changing the color has made it bearable - though still ugly. Everything else seems to work fine, though, so I'm happy enough. Still, if there were a way to turn off environment maps/reflections/whatever it is I would be much happier :)

Classic does look really dated, now doesn't it? :p

You're not kidding. I've gotten so used to the new look that I don't like using my XP-based desktop anymore (and it has a KILLER graphics card). I turned off transparancy briefly but decided I'd rather suffer a little slowness.