PDA

View Full Version : Delta Green Extension Combat Tracker Error 'ActorManager2'



Pendrig
February 18th, 2021, 21:36
Hi,

I get the following error using the combat tracker with the DeltaGreen.ext v0.0.8 in Fantasy Grounds Classic:

Script Error: [string "ct/scripts/ct_entry.lua"]:113: attempt to index global 'ActorManager2' (a nil value)

Could someone pretty please fix the extension :)

Thanks!

PS: Somehow I am not able to post in the 6th Edition Thread.

Mach5RR
February 19th, 2021, 07:44
It's fixed ... now. Just use the same link as before and it should be good. I'm probably going to go back to it at some point, as there are things I know how to do now, that I didn't before.

Pendrig
February 19th, 2021, 17:37
Many thanks!

Pendrig
February 19th, 2021, 18:00
Sorry to bother again. When I try to inflict damage in the combat tracker I get another error related to ActorManager2:

Script Error: [string "scripts/manager_action_damage.lua"]:87: attempt to index global 'ActorManager2' (a nil value)

Mach5RR
February 20th, 2021, 19:55
Sorry to bother again. When I try to inflict damage in the combat tracker I get another error related to ActorManager2:

Script Error: [string "scripts/manager_action_damage.lua"]:87: attempt to index global 'ActorManager2' (a nil value)

OK, I've fixed that as well. I hadn't fixed it because I assumed it was only dealing with lethal damage, which I still haven't figured out how to make work. I've now pulled all references to ActorManager2 from the DG extension.