PDA

View Full Version : InitiativeManager Gone?



JohnKarpenter
February 10th, 2021, 08:26
Hello,

I'm trying to add a new edge that affects initiative card draws. Simply, a level headed edge that draws three extra cards.

My call to InitiativeManager is throwing the following error:

Code:
script execution error: [string "scripts/teledrial_tweaks.lua"]:36: attempt to index global 'InitiativeManager' (a nil value)
This indicates InitiativeManager doesn't exist. I tested with the War of the Dead slow hindrance extension. I know that extension works (or used to work) for others. It gives the exact same error on the same call (InitiativeManager.registerAbilityHandler).

I have only those two extensions installed. I'm running FGU classic 4.0.6, SWADE 5.2.10, core 3.3.12A.

Was InitiativeManager removed from SWADE? Was it renamed? Is there a replacement?


Thanks!

Ikael
February 10th, 2021, 11:26
Hello,

I'm trying to add a new edge that affects initiative card draws. Simply, a level headed edge that draws three extra cards.

My call to InitiativeManager is throwing the following error:

Code:
script execution error: [string "scripts/teledrial_tweaks.lua"]:36: attempt to index global 'InitiativeManager' (a nil value)
This indicates InitiativeManager doesn't exist. I tested with the War of the Dead slow hindrance extension. I know that extension works (or used to work) for others. It gives the exact same error on the same call (InitiativeManager.registerAbilityHandler).

I have only those two extensions installed. I'm running FGU classic 4.0.6, SWADE 5.2.10, core 3.3.12A.

Was InitiativeManager removed from SWADE? Was it renamed? Is there a replacement?


Thanks!

InitiativeManager was renamed to ActionCardManager (many versions ago). Otherwise the API works the same but has more capabilities now

damned
April 7th, 2021, 02:26
Another spammer