View Full Version : Arcane Disruption Help

February 1st, 2021, 01:48
So I know how to increase/decrease skills as well as call and ignore effects, however I cant seem to get the protection/armor value to impact arcane rolls. For the setting we are playing in it would be nice if I could just affix the effect to the armor and be done with it. Any suggestions on how I could do this? Or would it require a new extension to do so? Thanks in advance.

Mike Serfass
February 1st, 2021, 03:52
Do you mean an armor bonus like the Protection power has which decreases all damage? [Armor +2]
Or do you mean the toughness effect like Protection? [Toughness +2]
Or do you mean like Arcane Protection? [@Arcane -2, @Arcane Damage -2]
Make sure you put those in the armor's notes (the Notes tab). It won't work if you put it on the Main tab in the text box under Availability.
It seems like that's where it goes, and notes is for flavor. But effects must be in notes. It can be anywhere in notes, literally, and it will work.
Weapons have modifications where you can put effects, btw. I don't know why armor doesn't have modifications. Armor also doesn't get keywords, and I think it should. Weapons will also use effects in the unmarked text box under Keywords.

February 1st, 2021, 04:33
Thanks they do work in the tab underneath but for my sanity now that i know they can work there as well imma move them over. But i have another issue arising.... i have three set up that i can call, Interference Plate [Arcane -4], Interference Chain [Arcane -3], Interference Leather [Arcane -2]. and i can have them on the armor to successfully lower the rolls for appropriate armor mod. However if i change any to say Interference, Plate [Arcane -4], it stops and doesnt call it. my goal was to copy the illumination penalties and have 3 levels of the same, so i could build the appropriate edges, it just fails though. even with the working effects the edge wont ignore it if i use the Ingore #.

Why does a comma stop it from working?

Mike Serfass
February 1st, 2021, 05:35
First, you need the at symbol @ in front of arcane [@Arcane -4]. Without the @, it will lower the caster's spellcasting roll, rather than the incoming arcane roll. @ indicates incoming.
I tried with and without a comma. I even tried with multiple commas in different places. It applied the effect each time. Maybe it's the missing @. Make sure you equipped the armor. (I've done that more than once.)
Now effects are working for armor in the text area below availability. That used to not work. Thanks for pointing that out.
I don't know what you mean about illumination penalties and edges. There are infravision and low light vision special abilities already, so you could use those for characters rather than making edges.

darksight - [Ignore #Illumination] (I added this to my setting)
infravision - [Halve #Illumination]
low light vision - [Ignore #Dim #Dark]

You could mix these up, like [Halve #Dim] or [Ignore #Dim, Halve #Dark]. Is this what you're after?
If you're trying to combine effects, you'd do [Halve #Illumination, @Arcane Defense +2, @Arcane Damage -4], for example.

Does that help?

February 1st, 2021, 05:54
i dont want to lower the enemies. i want to hinder the casters. in the setting worn armor hinders power activations the heavier the armor the greater the penalty. then power edges to negate that effect.
illumination has multiple levels of penalties, -2, -4, -6. illumination, level (dim, dark, pitch). i thought by copying the format in the effects and just changing the labels it would work. i did some what
Interference leather [arcane -2] give the correct negative to leather armor, however if i use a comma,
Interference, leather [arcane -2] it doesnt apply at all.

and then copy either the ignore illumination of steady hands edge and make it ignore the interference penalty

Mike Serfass
February 1st, 2021, 21:30
I understand now. Where specifically are you entering the text "Interference, leather [arcane -2]"?

Try this (you're probably half-way there now):
Add it as a custom effect to the effects list where berserk, illumination, etc live. You can use the comma like illumination does.
Interference, Leather [arcane -2]

On the armor under availability (or in notes) use

You can use the effect or the ignore effect in Combat Tracker also, btw. You can also put the penalty effect on the character sheet, maybe make a hindrance that has all these penalty effects the casting characters must take.

In the edge, put [Ignore #InterferenceLeather] in notes.

Here's a screenshot:

Edit: The CT should have the effect [#InterferenceLeather] or [Ignore #InterferenceLeather].

February 1st, 2021, 21:36
Cool did all, it works. i just have to keep them all separated for now. thanks.

Mike Serfass
February 1st, 2021, 21:51
Note that if you use commas for them all, you can use [#Interference] or [Ignore #Interference] and it will apply to all levels of it.

February 1st, 2021, 22:34
neat, then im all set thank you again