View Full Version : CoC 7E Ruleset references problem

December 15th, 2020, 23:16

I am having a problem trying to read the Call of Cthulhu 7E (Ruleset) reference. As I try to read it the console show me a script execution error and I believe there are some missing pages, like the Investigator Generation that shows empty like in the anexed image. I believe that are other missing information, like the Hit Points rules, I can't find then.

I searched for this problem but didn't find anything. Maybe I am doing something wrong, but I couldn't figure it out.

I am using FGU V4.0.0 STANDARD, Windows 10 64bit and no extensions.


December 16th, 2020, 00:46
Welcome wesleysilvawms

Could you please provide some more detail so I can track this down?

December 16th, 2020, 01:19
Thank you for the fast reply.

I open the campaign and try to read the references, many pages open without any apparent problem and others show me the script execution error and seem to be missing some information.

The error always show when I open the problematic pages, and is always the same error:
Script execution error: [string "ref/scripts/ref_blocklayoutmanager.lua"]:32: attempt to call field 'setAsset' (a nil value)

It happens, at least, in the following pages:
- The Outsider (seems normal)
- Step 1: Generate Characteristics (has a lot of information but seems to be missing the final part, where I believe would be the hit points rules)
- Quick Reference: Investigator Generation (shows empty)
- Imprisoned With The Pharaohs (seems normal)
- From Beyond (seems normal)
- Combat Flow Chart (shows empty)
- Combat Damage Flow Chart (shows empty)

I believe I don't have any extension on, and I have tried creating a new campaign and the same happens.

I don't know if that is the type of detail you need. Is it helpful?


December 16th, 2020, 01:30
can you locate your \vault directory
and rerun the Check for Updates

Im not getting any of those errors.
Am testing some other things.

December 16th, 2020, 01:41
I tried and it didn't work. It returns the same error.

December 16th, 2020, 01:45
this is what happens on my computer with a fresh install
ill look into it further...



December 16th, 2020, 02:15
I tried to uninstall but it was stuck on 12% so I manually deleted the Fantasy Grounds installation and appdata folders and reinstalled everything and it's now working like yours.

Sorry to bother and thank you very much for the help.

December 16th, 2020, 04:22
Ia! Ia! Great news! Thanks for the update.