PDA

View Full Version : Campaigns keep getting corrupted.



Alarian
May 10th, 2007, 18:23
I have no idea why, but my campaigns keep getting corrupted. Everything seems to be fine when I am GM'ing or prepping things, I will exit out of FG2 and periodically (it's happened three times now since FG2 was released) when I go back to load up the campaign, I will get the following message:

AppName: fantasygrounds.exe AppVer: 0.0.0.0 ModName: fantasygrounds.exe
ModVer: 0.0.0.0 Offset: 0009900a

FG then crashes. The only way to 'fix' this for me has been to create a new campaign. I'm not doing anything fancy, I'm using the default d20 ruleset and other than additional tokens and portraits I only have 15-20 macro's defined. It's starting to get really frustrating having to redefine all my macros every few days. Anyone else having problems? Oh, and I'm running the latest version.

If it helps, here is the addtional imformation that was generated by the crash.

<?xml version="1.0" encoding="UTF-16"?>
<DATABASE>
<EXE NAME="FantasyGrounds.exe" FILTER="GRABMI_FILTER_PRIVACY">
<MATCHING_FILE NAME="d20unpak.exe" SIZE="106496" CHECKSUM="0xA684953C" MODULE_TYPE="WIN32" PE_CHECKSUM="0x1B30A" LINKER_VERSION="0x0" LINK_DATE="04/26/2007 09:59:23" UPTO_LINK_DATE="04/26/2007 09:59:23" />
<MATCHING_FILE NAME="d3dx9_31.dll" SIZE="2414360" CHECKSUM="0x37E68538" BIN_FILE_VERSION="9.15.779.0" BIN_PRODUCT_VERSION="9.15.779.0" PRODUCT_VERSION="9.15.779.0000" FILE_DESCRIPTION="" COMPANY_NAME="Microsoft Corporation" PRODUCT_NAME="Microsoft® DirectX for Windows®" FILE_VERSION="9.15.779.0000" ORIGINAL_FILENAME="D3DX9D.dll" INTERNAL_NAME="D3DX9D.dll" LEGAL_COPYRIGHT="© Microsoft Corporation. All rights reserved." VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x40004" VERFILETYPE="0x2" MODULE_TYPE="WIN32" PE_CHECKSUM="0x253B20" LINKER_VERSION="0x50002" UPTO_BIN_FILE_VERSION="9.15.779.0" UPTO_BIN_PRODUCT_VERSION="9.15.779.0" LINK_DATE="09/28/2006 22:13:05" UPTO_LINK_DATE="09/28/2006 22:13:05" VER_LANGUAGE="English (United States) [0x409]" />
<MATCHING_FILE NAME="FantasyGrounds.exe" SIZE="3506176" CHECKSUM="0x6625A5C6" MODULE_TYPE="WIN32" PE_CHECKSUM="0x36733E" LINKER_VERSION="0x0" LINK_DATE="05/09/2007 14:44:55" UPTO_LINK_DATE="05/09/2007 14:44:55" />
<MATCHING_FILE NAME="FantasyGroundsUpdater.exe" SIZE="155648" CHECKSUM="0xB956B9CE" MODULE_TYPE="WIN32" PE_CHECKSUM="0x322CF" LINKER_VERSION="0x0" LINK_DATE="04/04/2007 18:34:08" UPTO_LINK_DATE="04/04/2007 18:34:08" />
<MATCHING_FILE NAME="Uninstall.exe" SIZE="170688" CHECKSUM="0x5F3A4768" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" LINK_DATE="03/31/2007 15:09:55" UPTO_LINK_DATE="03/31/2007 15:09:55" />
<MATCHING_FILE NAME="UpdaterEngine.exe" SIZE="1277952" CHECKSUM="0x1119773C" MODULE_TYPE="WIN32" PE_CHECKSUM="0x13D46D" LINKER_VERSION="0x0" LINK_DATE="04/04/2007 18:40:17" UPTO_LINK_DATE="04/04/2007 18:40:17" />
</EXE>
<EXE NAME="kernel32.dll" FILTER="GRABMI_FILTER_THISFILEONLY">
<MATCHING_FILE NAME="kernel32.dll" SIZE="984064" CHECKSUM="0xF12E1D4A" BIN_FILE_VERSION="5.1.2600.2945" BIN_PRODUCT_VERSION="5.1.2600.2945" PRODUCT_VERSION="5.1.2600.2945" FILE_DESCRIPTION="Windows NT BASE API Client DLL" COMPANY_NAME="Microsoft Corporation" PRODUCT_NAME="Microsoft® Windows® Operating System" FILE_VERSION="5.1.2600.2945 (xpsp_sp2_gdr.060704-2349)" ORIGINAL_FILENAME="kernel32" INTERNAL_NAME="kernel32" LEGAL_COPYRIGHT="© Microsoft Corporation. All rights reserved." VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x40004" VERFILETYPE="0x2" MODULE_TYPE="WIN32" PE_CHECKSUM="0xF724D" LINKER_VERSION="0x50001" UPTO_BIN_FILE_VERSION="5.1.2600.2945" UPTO_BIN_PRODUCT_VERSION="5.1.2600.2945" LINK_DATE="07/05/2006 10:55:00" UPTO_LINK_DATE="07/05/2006 10:55:00" VER_LANGUAGE="English (United States) [0x409]" />
</EXE>
</DATABASE>

Griogre
May 10th, 2007, 18:28
I suggest you zip and e-mail the corrupted campaign to Smiteworks customer support.

Sigurd
May 10th, 2007, 18:45
Yes, If you have copies of multiple corruptions don't be afraid to send different sets. It gives them more for sleuthing.


Sigurd

I hope you\they solve this.

Goblin-King
May 11th, 2007, 07:40
There is also an open reported issue regarding modulestate.xml causing problems. If renaming that file to something else helps, please send the broken file to us at [email protected] We'd love to get this one fixed.

solitair
May 17th, 2007, 05:42
I am also encountering this problem. I'm fairly new at this (my group just purchased the software today). I'm not doing anything with modules or rulesets. All I've added were 5 maps, 10 tokens, and placed tokens on 1 map, and closed the program. When I went back in, the campaign was corrupted. Please assist as this makes preping a campaign nearly hopeless/pointless.

David

Tokuriku
May 17th, 2007, 09:12
First of all, did you update?

Griogre
May 17th, 2007, 18:09
I sent a campaign in that seemed strange with one storybook entry where the entire entry was underlined despite there being no underline tag. This was with v2.0.11.

Goblin-King
May 21st, 2007, 08:02
If you encounter campaign corruption issues, the best way for us to get to the bottom of things is if you zip up the campaign folder (under the application data folder, go to "campaigns" and zip up the folder named after your campaign) and send it to us at [email protected]

Tenser
May 22nd, 2007, 18:37
I 'discovered' a problem when adding maps to my campaign. If I add a map to the campaign folder that is a .jpg with a size larger than 1000 pixels in any direction, it works fine until I quit and restart the program, then I get a corruption error and cannot reload the campaign until I remove the map.

If the map is in a .png format I have no problems regardless of the resolution. I'm not sure if you're experiencing a similar problem or not, but you did mention adding maps to your campaign so maybe this will help.

commisaro
May 22nd, 2007, 18:46
I have this same problem but I figured out how to make the campaigns usable again. Just move the db.xml file onto the desktop so it's no longer in the campaign folder. Then, start up the campgin... FG will say that it can't find to campaign or something and so none of the data will be there. Then, close FG, and move the original db.xml file back into the campaign folder, replacing the new one FG has just created. After that, the campaign should work properly... until it gets corrupted again :P. I have no idea why this happens or why these steps work, but they do :P.

richvalle
May 22nd, 2007, 20:06
I've found that deleting or renaming the CampaignRegistry.lua file and fixes the issue.

rv

richvalle
May 27th, 2007, 17:52
Well, now I'm stuck. Campaign is crashing and reanaming any of the files doen't help. I tried the trick of starting up a new campaign and moving the db.xml into it but then it crashes too.

:(

rv

mindmaker1975
May 30th, 2007, 03:48
There is also an open reported issue regarding modulestate.xml causing problems. If renaming that file to something else helps, please send the broken file to us at [email protected] We'd love to get this one fixed.


I went in and renamed the above mentioned file to "rename.xml" and then the program worked fine from what I can tell...which file do you want sent? I am assuming the broken modulestate.xml file so I am sending that. If want something else let me know.