View Full Version : Strange little thing I noticed (Bug?)

May 10th, 2007, 14:38
Noticed something weird last night. Potential bug?

Like many of us, I am sure, I have occasionally used the wrong identity for some text I am putting up on the screen, especially for things like emotes. Like for instance, NPC1 identity is active, and I type in text "goes to sleep." It pops up as "NPC1 goes to sleep." Realizing I had meant it to come out as "NPC2 goes to sleep," I'd hit the up-arrow, activate the NPC2 identity, and hit enter, and get the desired "NPC2 goes to sleep."

Here's the thing. Last night, I did very much what I described above. I used NPC1's indentity for NPC2's action. But when I up-arrowed, the NPC1 identity was appended to the text. For example, "NPC1 goes to sleep" was the text I wanted to correct. I hit up-arrow, activate the NPC2 identity, and hit enter. The result: "NPC2 NPC1 goes to sleep."

Is this a bug, or do I just need to watch what I'm doing? :-)

Another strange thing happened. One of my players crashed out last night a few minutes before I was ready to wrap things up for the night. When she tried to sign back in, she wasn't able to. She said that the updater claimed there was an update available, but when she tried to update, it came up with some sort of package error. Didn't think too much about it, but told her I was wrapping things up anyway, and we'd figure it out later. When I went to close down the program, I got one of those Microsoft errors (Send/Don't Send). Reloaded the program, and sure enough, it was requesting an update. When I hit Update, I got the same error message that my player did. Tried it a couple times, same result. This morning, I checked out the program, and it was not requesting an update. Two things to add about this: One, everyone was running the latest version, 2.0.11, and two, I had a Windows update that needed doing, which meant the computer rebooted. I don't know if that's related, but figured I'd mention it.

May 10th, 2007, 18:21
I had a similar thing happen to me with a player crashing out and then saying the update button was lit when he restarted FG. He automatically hit it (even though we were in the middle of a game). I think he said he got an error also. He did eventually get back in the game, but I think he had to reboot first. Once the game was over I remember checking for an update and there wasn't one.

May 10th, 2007, 19:03
I saw the same thing with the update button. I noticed that, at the same time that was happening, this site was down. So I'm guessing that the update button may light up if it can't connect to the main database.

May 10th, 2007, 19:11
Yeah my update button did light up last night while the site was down. I had not yet gotten v2.0.11. I knew it was available because I had seen Goblin-King's announcement on the message board earlier and when I was working on a campaign after I had gotten home, the update light came on and then the update failed. I went to the web site and noticed it was down.

May 11th, 2007, 07:44
The update issue was probably due to the issue we had with the site.

The chat line change is indeed interesting. The GM identity thing works in script, and that is actually working as intended, but I will give that a think to see if there's something that can be done.

The crash most probably wasn't related to the other problems, but I would love to hear more specific information about it if you encounter it again.