View Full Version : A Problem with the Demo Version

May 7th, 2007, 01:53
Hey, I'm new here.

I'm interested in purchasing FG to be able to run campaigns with my brother (currently overseas in Bosnia) and our friends, so I downloaded the demo version to check it out. I haven't tried to connect to (or host) a game yet, but when I click 'create and view local characters', and select d20 (the only option), it comes up with an error message titled 'could not initialize DirectX' and with the message 'CreateDevice Failed!'

For reference, I'm using (according to my device manager) the NVidia Vanta/ Vanta LT, driver version (which it tells me is the most current driver when I try to update).

So, is there something else it might be, or is it just that my box sucks too much?

Any help on this would be much appreciated. Thanks!

The High Druid
May 7th, 2007, 02:01
Well since you've checked your drivers, the next step I guess would be to go to windows update and make sure you have the most recent version of DirectX installed.

May 7th, 2007, 02:59
So, I ran the Windows updater, but the same thing still happens. The same error message popped up when I tried to host a game just for kicks.

Any other ideas? I'm out of them at this point.

The High Druid
May 7th, 2007, 03:14
Okay perhaps I wasn't entirely clear. If I recall (been a while since I did this) just running the updater doesn't install or update Direct X - you have to actually go the the optional downloads and check DirectX to get it. Umm might be easier if you just straight to the directx page (http://www.microsoft.com/downloads/details.aspx?FamilyId=2DA43D38-DB71-4C1B-BC6A-9B6652CD92A3&displaylang=en) and get it that way.

Just as a thought you're not trying to run the program whilst having another DirectX using application open? I've had similar messages in the past when I've accidently tried to lauch two instances of World of Warcraft, since the one instance appears to grab hold of DirectX so the second instance can't use it.

May 7th, 2007, 04:36
According to a quick check with dxdiag, I'm running DirectX version 9.0c. I'll see if there's anything later than that.

edit: It seems that the only two versions later than that are Vista exclusive. Great.

May 7th, 2007, 05:04
You just need DirectX 9.0c. However it sounds like your video card can't really fully use it and that is why FG is failing. You need to look at the tech specs of that card and see what version of DirectX it is *fully* compliant with.

May 7th, 2007, 05:16
Then comes the question what graphics board you have.
There are some that don't support full DirectX9 which FG demands.

May 7th, 2007, 06:39
Then comes the question what graphics board you have.
There are some that don't support full DirectX9 which FG demands.

And how would I go about checking that?

And to update, after a bit of trolling around I now have version of the Vanta LT Windows XP/2000 driver. When I tried to install anything past that ( and above), the installer tells me that it can't find a driver compatible with my hardware, which I'm assuming means they stopped supporting it at that point.

For reference, I downloaded the driver here (http://www.nvidia.com/object/winxp_2k_66.93.html), which says that it has 'Microsoft® DirectX® 9.0c and OpenGL® 1.5 support'.

So, it seems like I have the latest version of DirectX, and a driver for my video card that supports it. Yet I still get the same error when I start FG.

What am I missing?

May 7th, 2007, 08:12
Go to : Rightclick My Computer, go to options, go to the hardware, then to Device manager and finally expand the "Graphics Board" / "Graphics Adapter" in the resulting folder-tree.

If you want more information on the device, rightclick that one to and go to Properties.

FG wants a fully DirectX9 compatible graphics board with at the least 32 Mb of Ram. There is a list of devices that do not work in the FAQ.

May 7th, 2007, 17:28
The only thing in my device manager that resembles 'graphics adapter' is the 'display adapter', which is what I've been using. There's nothing actually called 'graphics adapters'. I'm assuming for now that they mean the same thing.

I think what I need to do is finally go buy a new video card. It's not on the list of cards that don't work in the FAQ, but I don't think it has 32MB of RAM to work with (the 'display' tab in dxdiag says that the 'Approx. Total Memory' is 8.0 MB, which is a lot lower than I thought it would be).

Thanks to everyone who helped!

May 7th, 2007, 17:54
Yeah, sorry about the confusion. I am running a Swedish system at the moment and didn't remember what it was called on a English one.

May 7th, 2007, 21:10
No problem at all.