PDA

View Full Version : Mad Nomad's Character Sheet Tweaks



MadNomadGM
August 31st, 2020, 01:12
Mad Nomad's Character Sheet Tweaks

Price: $5.00
Description: A large number of changes and additions to the character sheet for 5e that should streamline your play and add some new capabilities.


New UI and layout
Current HP
Auto XP
Locked fields on some fields to prevent player mistakes
Brand new Player journal tab
Level up notifiers
Quick access buttons
Skills for thieves tools, game sets, etc


Watch the video for details.
Get it on DMs Guild HERE (https://www.dmsguild.com/product/326461/Fantasy-Grounds-Mad-Nomads-Character-Sheet-Tweaks?affiliate_id=2733600)

Wizards Ghost
September 1st, 2020, 22:54
Used this tonight, and it was very much liked by my players. But it has one Problem: i cant add or open Adventure entries in the log Tab, please have a look at this, thx.

MadNomadGM
September 2nd, 2020, 00:25
Used this tonight, and it was very much liked by my players. But it has one Problem: i cant add or open Adventure entries in the log Tab, please have a look at this, thx.

Yup its definitely on my radar. Next patch will address this. Tonight or tomorrow. It's actually caused by the Combat Stats extension though, not the character sheet tweaks.

ScriedRaven
September 8th, 2020, 00:47
For anyone who wants to use this extension and Constitutional Ammendments (https://www.fantasygrounds.com/forums/showthread.php?58607-5E-Constitutional-Amendments) here's an extension that allows the two to work together. UPDATE: Changed current HP box to that of Constitutional Ammendments, so it can now shift between Current HP and Wounds.

Addition: Extension to use this together with Current HP FGU (https://www.fantasygrounds.com/forums/showthread.php?57134-Current-HP-Extension-for-5E-Ruleset-FGU-Version), or Current HP (https://www.fantasygrounds.com/forums/showthread.php?44140-Current-HP-Extension-for-5E-Ruleset-FGC)

SmackDaddy
September 9th, 2020, 19:47
Not sure what I have going on here but since adding this extension, I noticed a couple things and pretty sure I have some conflict somewhere with another ext/mod....and if this is posted under the wrong extension, then my apologies....

Issues:
1. No matter what I set my inspiration to, it's showing three slots (happened with most recent update)
2. Two chat bubble "Speak as" options available - one partially hidden behind the "Inspiration" title
3. XP on main character sheet doesn't show what's needed for next level but if you check their level, it's listed there.

39215
39216

MadNomadGM
September 9th, 2020, 19:54
You are right. I am aware of those issues and conflicts. I have a new release that will be launching very soon that adresses those issues. Sorry for any i nconveniences.

eriktedesco
September 11th, 2020, 20:34
For anyone who wants to use this extension and Constitutional Ammendments (https://www.fantasygrounds.com/forums/showthread.php?58607-5E-Constitutional-Amendments) here's an extension that allows the two to work together. You will need to change the load order of Constitutional Ammendments to 1001, but everything else is already set up

how do I do that? I'm no programmer. With the new update, is this version of const. Ammen. still necessary?

ScriedRaven
September 11th, 2020, 21:01
how do I do that? I'm no programmer. With the new update, is this version of const. Ammen. still necessary?

With the last update they still basically work together, although there are some oddities I haven't had the time to look into yet. On the plus side, the load order doesn't matter anymore

eriktedesco
September 12th, 2020, 14:56
The Adjust field of Constitutional Ammendments is not showing up. Is that how your modified version is supposte to work, ScriedRaven?

ScriedRaven
September 12th, 2020, 18:49
It should be showing up even if you don't have my merger loading. Do you have the most recent version of Mad Nomad's Tweaks? Because older versions would completely block it off

eriktedesco
September 12th, 2020, 18:53
I'll check it but I downloaded it yesterday.

eriktedesco
September 12th, 2020, 21:22
Ok, last version of MadNomad Char. Sheet Tweaks and ScriedRaven version of Const. Ammen.: no Adjust cell in the char. sheet.

When I try to load MeAndUnique version, sound and adjust cells are overlapping.

Last update of FGU, no modules and extensions loaded (except for those mentioned)

Any idea?

ScriedRaven
September 12th, 2020, 21:35
Wait, sound? There shouldn't be a sound box. Here's what it looks like for me39305

eriktedesco
September 12th, 2020, 21:36
Sorry, autocorrector...not sound but wound..

eriktedesco
September 12th, 2020, 21:40
I don't have this version of Constitutional Ammendments. Where do I find it? Thanks a lot ScriedRaven! ��

ScriedRaven
September 12th, 2020, 21:41
It's linked in my first comment

eriktedesco
September 12th, 2020, 21:42
Ok, sorry it's your version....but I'm not seeing the adjust field. Weird...

eriktedesco
September 13th, 2020, 09:48
ScriedRaven, problem solved!!!
You have to activate both MeAndUnique and your extensions.

That much was not clear to me! Anyway, now everything is working!

eriktedesco
September 13th, 2020, 13:08
Hi ScriedRaven and MadNomad, I noticed one problem with Char. sheet Tweaks and Const. Ammend.

Each time I increase a pg level, an error pops up and, while the MAX field is properly updated, the same cannot be said for the HP field.

AT present the only workaround is to turn off Const. Ammend., perform the level increase and turn on the extension again.

Is there a way to solve this issue?

ScriedRaven
September 13th, 2020, 16:57
What's the error mesage you're getting? I'm not getting any error messages on my end.

eriktedesco
September 13th, 2020, 17:14
What's the error mesage you're getting? I'm not getting any error messages on my end.

Here is a picture of the error popping out.

FGU latest update, Char. Sheet Tweak + Costitutional Ammendments + Constitution Ammendments MadNomad activated, no other modules or extensions activated (fresh campaign)

I just added the class (barbarian) to a empty character sheet but the sames error appear at each level increase, independently from class.

Hope this will help...

3932739327

ScriedRaven
September 13th, 2020, 18:19
From what I can tell that is an old version of my extension, that doesn't work with the latest Tweaks. The new version I get the same error when adding a class for the first time, but it doesn't show up after that

eriktedesco
September 13th, 2020, 18:32
Nice to know that it's an extension version issue.
Char. Sheet Tweak and Constitutional Ammendments are both the latest version.

Where do I find the latest version of your extension? Is there a way to know the version of your extension?

Thanks again!!!

eriktedesco
September 13th, 2020, 18:40
ScriedRaven...you are using an older version of Const. Ammend. (1.2.1).

I'm using the 1.3.1. Could that be the issue?

ScriedRaven
September 13th, 2020, 19:23
I just update my post that in response to the original one.

The difference is that I use classic, not unity, as half the time I launch Unity I get some error or another. I had tested with the updated version of Constitutional Ammendments, I just use a slightly modified version, and didn't bother to modify the update.

eriktedesco
September 13th, 2020, 19:30
Ok! I take it that, at the moment, char. Sheet tweaks and const. Ammen. Are not compatible.

I hope they will be, sooner or later.

Thanks!

Rbbrbootz
April 9th, 2021, 20:36
I have an issue that, for some reason, CA.ext is not showing up as an option on my load screen. I started a post here (https://www.fantasygrounds.com/forums/showthread.php?67672-Extensions-not-loading/) and was told to talk to the authors. Have you seen/heard anything about this issue?

MadNomadGM
April 9th, 2021, 22:51
I have an issue that, for some reason, CA.ext is not showing up as an option on my load screen. I started a post here (https://www.fantasygrounds.com/forums/showthread.php?67672-Extensions-not-loading/) and was told to talk to the authors. Have you seen/heard anything about this issue?

Is the extension compatible with the ruleset you are using? Thats the only thing I can think of.

Rbbrbootz
April 9th, 2021, 23:31
Is the extension compatible with the ruleset you are using? Thats the only thing I can think of.
Sorry, wrong thread. As to your answer...it's 5E - CA. I'm making the assumption that it is 5e compatible, but I can see how that could be a mixup. Thanks