PDA

View Full Version : FG Unity and Extensions Not Loading?



TheFabulousIronChef
August 29th, 2020, 20:50
I am completely new to FG and am contemplating a move from Roll20. I mostly play GURPS 4e, although I also play D&D 5e on occasion. So far all I have done is download FG Unity and the GURPS ruleset and associated extensions and monkey around a bit. Issue #1 is the log below. Is the GURPS_4E_TableRolls incompatible with FG Unity, or is there an error in that document? Same question for GURPS_Valahn.

Also, unrelated, if anyone has recommendations for a quick reference guide/how to, that would be great, for things like importing maps, creating tokens, etc. So far importing characters from GCS has been a breeze.

Thanks.

[8/29/2020 11:29:03 AM] FGU: v4.0.0 ULTIMATE (2020-08-26)
[8/29/2020 11:29:03 AM] OS: Mac OS X 10.15.6
[8/29/2020 11:29:03 AM] GRAPHICS: AMD Radeon Pro 555X : 4096
[8/29/2020 11:29:03 AM] USER: TheFabulousIronChef
[8/29/2020 11:29:03 AM] Launcher scene starting.
[8/29/2020 11:29:03 AM] [<color="red">ERROR</color>] Extension Info Load (GURPS_4E_TableRolls): An XML comment cannot contain '--', and '-' cannot be the last character. Line 749, position 6.
[8/29/2020 11:29:03 AM] [<color="red">ERROR</color>] Extension Info Load (GURPS_Valahn): An XML comment cannot contain '--', and '-' cannot be the last character. Line 2, position 3.

ronnke
August 30th, 2020, 06:16
It would appear there are XML formatting issues within the extension files. I don't have have those particular extensions (I believe they were for a much older version of the ruleset). If you are able to link them, I should be able to fix them so they work with FGU.

TheFabulousIronChef
August 31st, 2020, 16:45
Hi, ronnke. Thanks for responding. I think I may have, in fact, downloaded the wrong extensions. I went to this page (https://www.fantasygrounds.com/library/GURPS_4E.xcp) to download them. Perhaps those are the old ones?

TheFabulousIronChef
August 31st, 2020, 17:28
I think I no longer have this issue; I downloaded the most up to date extensions and made sure to enable GURPS Core extension (I hadn't clicked that) and things seem to be working so far.

ronnke
August 31st, 2020, 23:29
I think I no longer have this issue; I downloaded the most up to date extensions and made sure to enable GURPS Core extension (I hadn't clicked that) and things seem to be working so far.

Cool. The GURPS Core extension is still not 100% for FGU, nothing game breaking, just some fonts and such. :)

TheFabulousIronChef
September 1st, 2020, 01:02
Is there a way to create 3d6 tables instead of 1d16+2? Tried to create a table, got this result. Can't figure out how to change 1d16+2 to 3d6.

38947

I originally wrote the above but then found this video which talks about it here (https://youtu.be/U_PjDtAZsEU?t=426). Wasn't super intuitive but got it now.

Fezzik Buttercup
September 23rd, 2020, 16:26
Hey Fabulous

Where did you find the "right" one. The one you mentioned is the only one I have found so far.

The extensions seem to be all over the place :), or I just haven't found the central GURPS repository for them other than Ronnke's

TheFabulousIronChef
September 24th, 2020, 05:53
Hey Fabulous

Where did you find the "right" one. The one you mentioned is the only one I have found so far.

The extensions seem to be all over the place :), or I just haven't found the central GURPS repository for them other than Ronnke's

I havenít found any extensions that work particularly well, but the rule set (https://www.fantasygrounds.com/forums/showthread.php?36043-GURPS-4E-Core-Ruleset) has been working well for me.

Fezzik Buttercup
September 24th, 2020, 17:17
Ignore me; this was posted on the wrong thread :)