View Full Version : Players losing the quick keys

April 27th, 2007, 04:45
After adding/setting up a quick key when they would then click on it the box would go blank...or 0 out. Happend quite a few times to multi-players.


April 27th, 2007, 08:10
Any information on what was there would be helpful in tracking this down. Shortcut hotkeys (ones that open sheets) get cleared if the target they point to has been deleted or is otherwise invalid.

April 27th, 2007, 11:48
No, these were modifirers. Saves or bonuses to attacks. I can find out some examples of exactly what was there and how it was made.


April 27th, 2007, 13:44
Per one of the players:

"I lost my save rolls a couple of times. I made the key by dragging the reflex etc. save to a key. I think that I tried to click on it (which I do a lot) as opposed to hitting the key. There is a tiny pause and then the key shows '0' and nothing happens.

I'd guess that it is the clicking getting interpreted as a drag. There is a slowness in FGII that may have something to do with that interpretation."

April 29th, 2007, 20:49
That may or may not be the problem. I had a similar issue trying to set up a plain chat text hotkey*.

I would type in the line of text in the chat window, and without hitting enter, drag the text down to the hotkey. The text would appear on the hotkey. I could then relabel it just fine if I chose to, but the results would be the same even if I didn't. When I then clicked on the hotkey to use it, nothing would appear in the chatbox, and the label on the hotkey would change to simply read "0".

I don't think I've tried using the keyboard to activate the hotkey, but I'm currently using my desktop machine for something else, so I'll have to take a look at that later.

* (forgot to add this) We use Teamspeak for our game sessions, but I like to put very frequently used phrases on hotkeys. In particular, I try to have one hotkey that says, "You all die. Reroll new characters." ;)

April 29th, 2007, 20:55
That sounds close to what my players were seeing.


July 10th, 2007, 05:35
With me and my players, this seems to happen when more than one person is rolling dice at a time. "Everyone roll spot checks" - Whoever gets it off first is fine, everyone else gets a "0" in their hotkey slot.

Interesting about using the F key to avoid this - I'll let you know if it works for us.

July 10th, 2007, 14:08
Hmm, I'm pretty sure I've had players lose their hotkey even when they are rolling an attack or damage number. I.e. when they should be the only one rolling a number.


July 10th, 2007, 15:25
This is happening a lot during my GMing sessions. It seems to be connected to slow down when a lot of data is being transferred to or from the server.

July 10th, 2007, 19:39
Someone in a game I play in also says it happens when dice are being thrown and you click the mouse on a hot key. To me It does seem to be when the dice are rolling for someone and someone clicks on their hot keys.

I don't know if it is really the dice or just the chat updating or as John_Geeshu says just data transfering. However like richvalle I know players have lost to hit hot keys. But they could have been setting up their mod box before it was their turn - and the other player was still rolling.

Our experience is that it is only clicking the mouse that zeros the hotkey. Using Fuction Keys nevers seems to have this problem. I personally use Function Keys 90% of the time and have never had a problem with them. I now use them 99% of the time because of this bug.

July 10th, 2007, 20:02
Well, there can also be issues if there are dice rolling in the chat box at the moment that you pick up dice yourself, i.e., the dice contained in the dragdata end up being short a die or end up including one of the dice that was already being rolled. I see this happen sometimes in my "The Box" addon when I try to roll dice through The Box multiple times in rapid succession (which is easier to do using the box due to the way it works).

Maybe this is related somehow, as in you end up with a dragdata object that gets dumped onto the hotkey whenever there are dice rolling already, and that clears the hotkey?