PDA

View Full Version : Can I use the system to create my own game?



Wise Orc Tavern
July 17th, 2020, 01:40
Hi

Let's say I want to use the storytelling system as base for my own system. Will I be able to do that if I buy the Vampire Ruleset?
I've been wanting to create something not related to Vampire or the World of Darkness at all, but I want to use the same system. I don't need everything to be automated for this, but I do need the character sheets, combat tracker and the basic mechanics.
So how hard would it be to tailor it for my mutants campaign as example. What should I be looking into to do that?

Thanks.

damned
July 17th, 2020, 15:33
The ruleset is encrypted so you wont have access to the codebase.

superteddy57
July 18th, 2020, 08:03
As damned has pointed out that this ruleset's codebase is encrypted and is not able to be seen. However, you can check out CoreRPG, 3.5E, and 5E and branch off of those rulesets. There is also MoreCore you can create an extension for your system as well. So there are options, this one unfortunately is not available.

Wise Orc Tavern
July 18th, 2020, 11:21
Ok, I will see if I can find another way. Shame though, because of how simple it is, I grew up playing all kinds of games using Storytelling. Mutants, Science Fiction, Dragon Ball, Matrix, everything we liked we would play it within the system.

Thanks.

Naurthoron
July 18th, 2020, 13:23
You could still use and adapt the older code base for oWOD rulesets like VtM.

Wise Orc Tavern
July 18th, 2020, 13:28
I am not sure I follow. I don't see a WOD system available. As far as I understand I would need the core ruleset and work from there, right?
The only Storytelling System I see is the Vampire 5e. I could use The Vampire UI as long as I could change the disciplines names, backgrounds names and so on. But as I understood that's not also a possibility.

Naurthoron
July 18th, 2020, 13:36
Look aound on the forum, there was a MoreCore character sheet by viresanimi and the dice rolls are available.
There is also the Wiki proposing community developped rulesets https://www.fantasygrounds.com/wiki/index.php/Extensions#Vampire:_The_Masquerade_.28V20.29.
There are also spinoffs of the ruleset available on the forum.
They work under FG, not FGU, so if working with FGU you will need to use them as base an adapt them.
I am sure many people will be happy to have an adaptation to FGU.

damned
July 18th, 2020, 15:42
You can play and customise character sheets for WoD games on MoreCore.

Fear Grounds
July 20th, 2020, 02:02
I am not sure I follow. I don't see a WOD system available. As far as I understand I would need the core ruleset and work from there, right?
The only Storytelling System I see is the Vampire 5e. I could use The Vampire UI as long as I could change the disciplines names, backgrounds names and so on. But as I understood that's not also a possibility.

You can absolutely add your own Disciplines, Powers, Backgrounds, and whatnot. The big thing is that this rule set uses the new V5 dice system. If your game will be using a different dice system, then I would recommend using MoreCore instead.

ramonpazos
September 29th, 2020, 17:23
Hi,

Question, I download the WoD but is not being pulled when I load FG, It only brings the VtDA.ext but not the WorldOfDarkness-hunter.ext. Do you know what im doing wrong?

Fear Grounds
September 29th, 2020, 17:40
Did you place the extension in the appropriate fantasy grounds extension folder? There are separate folders for classic and unity.

esmdev
September 29th, 2020, 17:43
As damned has pointed out that this ruleset's codebase is encrypted and is not able to be seen. However, you can check out CoreRPG, 3.5E, and 5E and branch off of those rulesets. There is also MoreCore you can create an extension for your system as well. So there are options, this one unfortunately is not available.

Out of curiosity, who decides if a ruleset should be encrypted, the publisher, SmiteWorks, the developer?

Moon Wizard
September 29th, 2020, 17:52
It's usually a combination of publisher, developer, and SmiteWorks; and can change over time depending on their comfort level.

Regards,
JPG

ramonpazos
September 29th, 2020, 17:57
I dont have Unity only Classic

C:\Users\PC\AppData\Roaming\Fantasy Grounds\extensions

Moon Wizard
September 29th, 2020, 18:07
Which ruleset are you using or did you install? (It will be a .pak file)

Regards,
JPG

ramonpazos
September 29th, 2020, 18:24
Which ruleset are you using or did you install? (It will be a .pak file)

Regards,
JPG

the VtM.pak and WorldOfDarkness-hunter.ext and WorldOfDarkness-vampire.ext

Fear Grounds
September 29th, 2020, 18:34
the VtM.pak and WorldOfDarkness-hunter.ext and WorldOfDarkness-vampire.ext

The VtM.pak is used to run the Dark Ages extension.

WorldOfDarkness-Hunters.ext needs the WOD ruleset (pak) to run

Naurthoron
September 29th, 2020, 18:37
You're mixing different games / versions:

This forum is for Vampire the Masquerade V5

VtM.pak is for Vampire the masquerade (legacy system) and will likely not work properly on FGU, but will on FGC (not supported by its community creator anymore).

WorldOfDarkness-hunter.ext is for Hunter The Vigil from the "New" World of Darkness, aka Chronicles of Darkness line. As well, it will likely not work properly on FGU, but will on FGC (not supported by its community creator anymore).
WorldOfDarkness-vampire.ext is for Vampire The Requiem from the "New" World of Darkness, aka Chronicles of Darkness line. As well, it will likely not work properly on FGU, but will on FGC (not supported by its community creator anymore).

Each extension from Chronicles of Darkness must be loaded with WorldofDarkness.pak ruleset and does not need to be used with VtM.pak.
Only the Vampire the Dark ages extension requires the VtM.pak, this is why you only see VtDA when using the VtM.pak ruleset.