View Full Version : Updater not updating anything (split by Goblin-King)

April 23rd, 2007, 11:26
I have downloaded the installer - run it and get zip apart from an Updater. Running the updater gives me an optimistic "Done !" message in a splash screen but no FGII.

Pretty difficult to convert rulesets with absolutely no copy of FGII at all to work with.

April 23rd, 2007, 12:34
Stuart, I split this into a separate thread.

When the updater says "Getting package listing / Done!", the problem usually lies in the license recognition process. There were some issues related to this around right after the patch, but they are now resolved.

Tracking these down usually requires some detective work on our part. We are at the moment investigating the issue.

Did you run the installer on a computer with a working FG1 installation?

April 23rd, 2007, 12:43
Yes - FG 1.05 works fine and I have been using this machine to run the beta (deleted prior to install of FGII).

April 23rd, 2007, 20:53
I've been waiting all day for a final fix, but I just redownloaded and reinstalled, and I STILL have the "Getting package listing / Done!" error. I've tried on two computers, one Vista and the other XP.

I'm a brand new user, so I don't have an existing install of 1.05f (other than the demo). I bought three licenses today, in anticipation of how great v2 was going to be, and I haven't gotten even a peek of it!

I hope there's a fix soon! From browsing the threads, it seems like installing 1.05f first and then installing v2 fixes it for a lot of people. Any chance you could put the full version install for 1.05f back up, so I can try that?

Thank you,


April 23rd, 2007, 20:59
I had FG1.05 on two machine, desktop and laptop. I also had the beta on both machines. FGII has installed onto my desktop but will not install on my laptop which is wireless and had my original FG copied to it from the desktop. My laptop is the beast that I use as a player (rather than DM) and as a developer. If I cannot get FGII to install on my laptop then Thore is gonna have to find someone else to work on the rulesets.

I'm sorry to sound apocryphal and somewhat angry but ... it took me over a month to get the beta to work on either machine and when I did it was just through persistance. I really need to get FGII onto my laptop in the next couple of weeks if I am to do anything for Digital Adventures at all. I am happy to buy a brand new application but this has gotta happen in the next fortnight.

Please tell me how I proceed. Can I purchase an installable version on a cd ?

April 23rd, 2007, 21:19
Similar problem.

I purchased a license about twenty minutes ago, having waited for the release of Fantasy Grounds II to do so. I downloaded the installer and get the following messages in the Updater.

"getting package listing"

I then click the Done buttom at the bottom and the update screen goes away and nothing happens.

April 23rd, 2007, 22:22
Please try again now.

If the problem persists, there's a problem with the license key and you should contact [email protected] Please include the email address you used when purchasing FG so we can trace the key.

As a self diagnostic measure, please check your registry for the license key string and make sure it is the correct license. You can find it from HKCU\Software\Fantasy Grounds\2.0 with key name LicenseKey.

April 23rd, 2007, 22:22
I was getting this last night, and did the following:
1. Uninstalled FG1 and FG2 (REMEMBER TO BACK UP!!!!)
2. Manually removed the FG entries from the registry, and deleted ALL the FG folders (the uninstaller removed the FG folders in Program Files, but not the ones Vista put in the user folders in AppData).
3. Reinstalled FG1, entered the license key, and then patched to 1.05
4. Installed FG2, and then MANUALLY ran the update app.

That got it working. I'm running Vista Enterprise x64 (legal, not hacked), and did have the beta installed installed prior. After this process, the update ran fine, as did FG2 and the updater from the link inside. Apparently something was hanging around in my system that was interfering, and some housecleaning fixed it up.

Hope that helps!

April 23rd, 2007, 22:42
The latest update to the install worked!

Thanks Dupre!

April 23rd, 2007, 22:45
Installer still not installing, sorry. Have emailed support ... the licence key code I generate allowed me to download the beta and download FGII to my desktop so ... ?

April 24th, 2007, 05:00
Mine is now working as of Dupre's post. Thank you.

April 24th, 2007, 15:34
I'm still not able to update to 2.0 still could their be a setting in my computer thats stopping me from updating

April 24th, 2007, 17:45
I'm still not able to update to 2.0 still could their be a setting in my computer thats stopping me from updating
It's possible a firewall is blocking the updater from contacting the server; something to check, anyway.

April 24th, 2007, 19:09
I'd like to publicly thank Ville and Tero for helping me get FGII to install; it was simple in the end and an issue with the license key.

I can now get started on the ruleset conversion backload.

Many, many thanks guys.

April 24th, 2007, 20:35
It's possible a firewall is blocking the updater from contacting the server; something to check, anyway.

i disabled my firewall and tried and still the same results

"getting package listing"
then nothing

April 24th, 2007, 20:49
i just figured it out i cant believe something so simple was the problem
thx for the help

April 27th, 2007, 03:20
So what was it?

April 27th, 2007, 13:16
A member of our group has this problem too - It took you 14 minutes to figure out, but she has been toying with it for days.

Share? :)

April 29th, 2007, 16:49
Please share?

It's something else I can try while waiting for a reply to my email to support.

April 30th, 2007, 10:09
Sorry had been gone for awhile when I installed 1.5 I typed in my installation 1.5 key with OUT dashes 1.5 didnt care and for me 2.0 wants the dashes