View Full Version : The Witcher TRPG ruleset

July 1st, 2019, 10:01
Hi everyone,
I would like to announce the beta release of our fan-made Witcher TRPG ruleset, made with the blessing of the editor Talsorian.

We are a team of three fellow french developpers and we have been working on this new ruleset for a few months now.
At this point we would need the public to take a look at it and give us some feedback to make it even better.
Please add an issue on github for every imperfection / or idea of improvement you encounter.

This Beta 0.2 release features :
- A partially automated character sheet (skill roll, attack, defense, spells, wounds threshold,...)
- A NPC sheet
- Modifiers
- Combat tracker with initiative handling, hp and stamina.
- A complete rework of the theme to recall the most recent video game and get you into the mood.

Please give use some feedback preferably by putting an issue on github.

you can download this release on https://github.com/Althea21/witcher_fg_ruleset/releases

here you will also find a bestiary, a calendar and a spells module.

Happy gaming.

July 1st, 2019, 10:05
Well done guys!

July 1st, 2019, 11:25
Thanks, the Talsorian team has been awesome to allow us to distribute the ruleset free of charge. With some artwork, spells and a bestiary. I hope it will be put to good use.

July 3rd, 2019, 21:02
Nice work! My players are going to love having a dedicated ruleset.

November 13th, 2019, 10:21
Hello there,
For those who are interested, we published a new version of the ruleset this week.
Changelog and download available here : https://github.com/Althea21/witcher_fg_ruleset/releases

Don't hesitate to send us your feedback using the issue section of github.

January 1st, 2020, 21:24
I'm getting the following errors when loading into FGU:

[1/1/2020 3:14:33 PM] [NOTICE] Launcher scene starting.
[1/1/2020 3:14:48 PM] [NOTICE] Requesting cloud server.
[1/1/2020 3:14:52 PM] [NOTICE] Connected to game server.
[1/1/2020 3:14:52 PM] [NOTICE] Launcher scene exiting.
[1/1/2020 3:14:52 PM] [NOTICE] Tabletop scene starting.
[1/1/2020 3:15:12 PM] [WARNING] framedef: Could not find image file. (WitcherTRPG) (graphics/graphics_frames.xml) ()
[1/1/2020 3:15:12 PM] [WARNING] framedef: Could not find image file. (WitcherTRPG) (graphics/graphics_frames.xml) ()
[1/1/2020 3:15:12 PM] [WARNING] framedef: Could not find image file. (WitcherTRPG) (graphics/graphics_frames.xml) ()
[1/1/2020 3:15:13 PM] [WARNING] framedef: Could not find image file. (WitcherTRPG) (graphics/graphics_frames.xml) ()
[1/1/2020 3:15:18 PM] [WARNING] icon: Could not find image file. (WitcherTRPG) (graphics/graphics_icons.xml) ()
[1/1/2020 3:15:19 PM] [WARNING] icon: Could not find image file. (WitcherTRPG) (graphics/graphics_icons.xml) (graphics/icons/arrow_sm_down.png)
[1/1/2020 3:15:21 PM] [WARNING] icon: Could not find image file. (WitcherTRPG) (graphics/graphics_icons.xml) ()
[1/1/2020 3:15:24 PM] [<color="red">ERROR</color>] Error loading ruleset XML file (WitcherTRPG) (strings/strings_campaign2.xml): '', hexadecimal value 0x1E, is an invalid character. Line 309, position 156.
[1/1/2020 3:15:25 PM] [NOTICE] Tabletop scene exiting.
[1/1/2020 3:15:25 PM] [<color="red">ERROR</color>] Object (customdie) deleted without cleaning up attached Lua object.
[1/1/2020 3:15:25 PM] [<color="red">ERROR</color>] Object (customdie) deleted without cleaning up attached Lua object.
[1/1/2020 3:15:25 PM] [<color="red">ERROR</color>] Object (customdie) deleted without cleaning up attached Lua object.
[1/1/2020 3:15:25 PM] [<color="red">ERROR</color>] Object (customdie) deleted without cleaning up attached Lua object.
[1/1/2020 3:15:25 PM] [<color="red">ERROR</color>] Object (customdie) deleted without cleaning up attached Lua object.
[1/1/2020 3:15:25 PM] [<color="red">ERROR</color>] Object (customdie) deleted without cleaning up attached Lua object.
[1/1/2020 3:15:25 PM] [<color="red">ERROR</color>] Object (customdie) deleted without cleaning up attached Lua object.
[1/1/2020 3:15:25 PM] [<color="red">ERROR</color>] Object (customdie) deleted without cleaning up attached Lua object.
[1/1/2020 3:15:25 PM] [<color="red">ERROR</color>] Object (customdie) deleted without cleaning up attached Lua object.
[1/1/2020 3:15:25 PM] [<color="red">ERROR</color>] Object (customdie) deleted without cleaning up attached Lua object.
[1/1/2020 3:15:25 PM] [NOTICE] Launcher scene starting.
[1/1/2020 3:15:25 PM] [<color="red">ERROR</color>] Lost connection to game server instance. Please return to launcher, and start game again.

I went ahead and fixed this myself. There were several issues that needed resolved. There was a missing graphic and there were some errors in a couple of the XML files. The combat tab is still throwing an error that I'll troubleshoot later but at least the ruleset is loading now. Once I get it error free I'll share.

Moon Wizard
January 2nd, 2020, 00:36
For FGU-specific issues; please post in the FGU playtest forum as well.

Here is a version with all the files updated to remove errors/warnings on launch; and a list of files changed.

Since I'm travelling, I'll let the someone else handle getting this on the GitHub. Here is a list of the changed files:


January 3rd, 2020, 13:48
It has already been fixed in a separate github branch actually. It should be merged in the next release.


FGU is not supported yet though

January 4th, 2020, 16:37
Sorry, Moon Wizard. I saw all your responses to my string of posts. I was on a roll going through and testing all the rulesets. I'll redirect to the FGU subforum from here on out. It just seemed cluttered and rather than start a new thread I thought posting here would be better since this was a specific ruleset issue for the dev to look at and not a generic Unity issue.


March 9th, 2020, 22:49
A new version is now available with complete combat automation (magic not handled yet, it's still wip).

Changelog and download available here : https://github.com/Althea21/witcher_fg_ruleset/releases

March 26th, 2020, 13:19

I see you use GitHub for this, are you open to pull requests? I pulled this down last night and the theme hurts my eyes, plus doesn't layer properly on larger screen sizes.

Carry on the good work though, as I want to play The Witcher I don't mind giving some of my time on it.


March 26th, 2020, 15:42
Hi MadBeardMan

Yes ! Any help is welcome and you can make pull requests, we'll check them as soon as we can.

Thanks and stay safe

March 27th, 2020, 15:04
I actually tried to modify the theme on my own, for the same reason as MadBeardMan.

Unfortunately I'm completed new to FG / creating rulesets and so I am getting an error about d6 dice. :D

Really happy about this being available, as my planned local Witcher game is on hold due to the pandemic, but I would like to run it online.

If you could offer the theme as light colors I think that's all I would need to be able to use it. Great work!


May 5th, 2020, 09:48
Hello, i would like to change the character sheet language to french, How can I do it please ? Thanks a lot
I know how to modify MOD files in other rulesets, but I didn't find in this one where the values for skills names were

May 21st, 2020, 07:08
So... anybody here still interested in a lighter theme? I did a small conversion (it is a wop, but covers almost everything and is useable) to be lighter on the eyes. It uses a lighter background, the main windows are of a coffee-like color.

May 21st, 2020, 08:37
@brazouk, I replied to your issue on git about that, tell me if your need further help

@new_vision : I'm interested to see what you did :) I can also put a link to download it (crediting you of course) if you want alongside the main download

May 21st, 2020, 10:21
@new_vision : I'm interested to see what you did :) I can also put a link to download it (crediting you of course) if you want alongside the main download

Cool. I put it here and if you like it, you can put it into the main download on Github if you like.

May 21st, 2020, 10:34
Thank you :)
Tell me how do you want me to credit you (name, link to a personnal page, ...) and I'll add a link to your extension asap

May 21st, 2020, 10:38
Name is enough, it is mentioned in the chat window of FG anyway. Hope you like it. Works best with "scaleui" set to 100. But that was the case for the original as well.

May 21st, 2020, 10:44
Ok I'll do it soon. Thank you for sharing your work.
I personally prefer very dark background, as I spend most of my waking hours behind a screen, my eyes get teary real quick with light backgrounds but I understand some people may have other preferences so I'm glad you did this !

June 20th, 2020, 08:26
Was just checking the page to see if anyone one attempted a Witcher's ruleset for FG. Looking forward to trying this out. :-)

July 5th, 2020, 06:17
Any plans on icoporating the Witchers Journals Bestiary?

July 5th, 2020, 08:38
Was just checking the page to see if anyone one attempted a Witcher's ruleset for FG. Looking forward to trying this out. :-)

Hope you'll enjoy it. Let me know if you encounter any bug

July 5th, 2020, 08:40
Any plans on icoporating the Witchers Journals Bestiary?

I'll do it if Talsorian allow me to.

But next update will be focused more on Effects and Magic.

July 5th, 2020, 09:18
Thanks for the quick response mate, excited to see whats next!!

July 6th, 2020, 17:28
I am starting to ask all community developers to consider making an explicit licensing statement on their work. It helps future community developers honor your wishes in regards to your work. Their is a discussion and some suggested licensing statements here; On Licensing & Distributing Community Content (https://www.fantasygrounds.com/forums/showthread.php?53781-On-Licensing-Distribution-of-Community-Content). Thanks for your contribution and for considering adding a licensing statement to your original post :)

I also know you have talked with Talsorian and if they have allowed you to use any of the IP, please make sure you don't release anything of theirs without their permission. Thanks!

July 31st, 2020, 12:18
I snagged the GenCon Witcher Bundle from dtrpg and downloaded the 4.0 version of the FG Ruleset and noticed a bug with the Tokens button. Having other library items disabled doesn't help. It looks like too many things are trying to show up in one row and tokens is getting merged with previous button. I still can select tokens an the button/item is getting merged with but not easily as. See the attached image.

Also, not sure if anyone missed this but Greg Bruni did a token set of Witcher monsters recently. See the link for more details.


July 31st, 2020, 12:20
Duplicate post ignore.

July 31st, 2020, 12:28
Yer I snagged those tokens also.

July 31st, 2020, 13:27
Hi Jay,
With 1920x1080 resolution and scaleui 100 I don't have this problem (see image)

Do you have different settings ?

August 1st, 2020, 12:33
Hey sylv038,

my laptop has as a 1280x800 resolution, that is the highest it can go to. I am using FG Classic.

August 1st, 2020, 20:41
Hi, I just got a group together to run the Witcher, testing out some of the combat automation, and am pulling an error that stops the damage being applied to an enemy on the combat tracker, who should I message this to?

August 3rd, 2020, 13:43
Hi everybody,

Jay, you can try to hide temporary some features you don't use in the library such as vehicles for exemple.
What's strange is when I change my own resolution to match yours, the sidebar is changing to display icons on 2 columns (see image 38301).

Hurske, I got your issue report on Github, bug is fixed and a new release should be available soon.


August 3rd, 2020, 21:17
I'm not sure why the sidebar isn't showing the 2 columns. All my other rule sets do 2 columns. I have to switch off just about all the features for tokens to show up right. It does show up if I am using just the create PC features. I also don't have an Audio button like you do in your screenshot. Are you running a extra extension that is adding one?

Did notice these other bugs over the weekend.

Noticed these bugs on the Character Sheet:

1.) If you roll damage for a punch or kick a Script Error occurs.
2.) A Damage roll for a punch or kick shows the Type of attack is unknown. That the Non-lethal Effect can't be shown.
3.) If you accidently add dice or a number to the damage for a punch or kick you can't clear the damage so it resets back to the starting default.
4.) Getting an error when I roll damage for the Withers's Silver Sword but no problem with rolling damage for the Steel Sword. See the attached export of the character. I was entering in the pregens from Easy Mode over the weekend.

August 4th, 2020, 09:28
About the Audio icon yes, it's an extension indeed (I'm currently trying AudioOverseer for my next session)
Thanks for reporting the other bugs, I'm fixing this asap :)

August 4th, 2020, 21:12
I Checked to see what happens if I enable the Audio Overseer extension and it causes the buttons to go onto 2 columns and display normally. Same thing occurs if I enable another extension that will add 1 or more extra buttons, like the Player Agency extension. I did a unzip of Player's one and it looks like that it is defying the location for one of the default ones.

Also, the buttons hasn't any for Spells. So you can't bring up spells that way. The lack of a spells button may be causing something I suspect I noticed that Player Agency actual sets a location for the button.

August 4th, 2020, 23:47
Trenloe wrote an extension that will force the ruleset to display in a single column only. Try find that and see if it helps.

August 5th, 2020, 09:52
Hi guys !

New version available : https://github.com/Althea21/witcher_fg_ruleset/releases
(read the changelog before updating)

August 7th, 2020, 02:31

October 12th, 2020, 14:16
Just wanted to say this has been a wonderful tool for our quarantine games, cheers!

The combat automation is absolutely awesome. Saves a ton of time. We even got more confortable around combat now compared to when we started our campaign with face-to-face home sessions. Used to have 1 combat every 2-3 games since we would reeeeally avoid it because of all the math involved. Now every session everyone is eager to fight off monsters! Thank you, guys.

October 12th, 2020, 14:28
Thank you very much for your feedback, I'm very glad you like it :o !

November 9th, 2020, 16:11
Hi guys, first of all, thanks for your work, it's really helpfull !
I am wondering, the skills in tne PC sheet are in duplicate. Did I do something wrong, or is there any bug ?

November 10th, 2020, 07:24
Hi and thank you for your feedback.

What version do you use ?
I recommend using the last version (downloadable here https://github.com/Althea21/witcher_fg_ruleset/releases), and reading the changelog from your version to the one you are updating. If your problem persists, send me your campaign as a zip file and I'll have a look a it (you can log an issue on github and attach your file if you want)

November 10th, 2020, 08:45
Hi, thanks for your quick answer ;)
I am playing on the last one, beta 0.5.0 that you uploaded on the 5th of august.
I will try to send you the bug as you said on github.


February 16th, 2021, 13:50
Hey Guys, first of all thank you for your work is being tremendously helpful!
I took the liberty of creating automated tables for the lifepath choosing during PC creation.

You only have to roll the tables with the [ROLL] tag and it calls all the other ones you may need.

I exported a module and am sharing with you in case you all find it helpful.



February 22nd, 2021, 19:22
Hi, the module do not work anymore, when I open a list box I have lot of errors

February 28th, 2021, 16:15
Same Here. A couple of weeks ago I was able to use it just fine, but now, almost everything that is a dropdown list is broken. too sad.

February 28th, 2021, 16:31
Hi All, it's probably because of the CoreRPG changes that were made, I had to update all of my rulesets

Can someone PM me in a few days if the original creator hasn't fixed it up, I'll make the fixes and send a push request to them.


March 5th, 2021, 05:33
This looks fantastic and I can't wait to try it out. I'm still getting a few errors when I start up which is probably from the new CoreRPG update. I'm looking forward to seeing what else is done with this and possibly even getting an official ruleset to sell on the store because I would also support the hell out of that too.

March 11th, 2021, 21:48
Does anyone know if there's some progress on this? I'm getting an error when it comes to the PC sheets and the profession drop down menu.

April 9th, 2021, 17:14

First of all, I would like to thank to the creator of the ruleset for the great work he did. I would like to ask if there will be an update to fix it after the core rpg update?

thank you

April 11th, 2021, 04:31
This looks super promising, but I am also curious if there are is an update is in the works to address the errors from the coreRPG update.

April 19th, 2021, 14:08
Hi All,

I was hoping to look into this last week but didn't find the time, I'll be looking into it tonight. As I didn't create this ruleset I won't be able to update the first post, however I will send them a push request and add the updated extension in my own post.

EDIT: There's a hotfix in the repo, so looks like it's all been done, see more here:



April 20th, 2021, 20:27
I tried to report this on Github but I got annoyed with the stupid dice puzzle verification puzzle to sign up because I'm on my phone but it seems like it might not be compatible with the Unity version of Fantasy Grounds. When I load up a new campaign with no extensions I get a few error messages.

[ERROR] framedef: Could not find image file (graphics/frames/blank.png) for frame (shortcuts).
[WitcherTRPG] [graphics/graphics_frames.xml]
[ERROR] framedef: Could not find image file (graphics/frames/blank.png) for frame (windowtitle).
[WitcherTRPG] [graphics/graphics_frames.xml]
[ERROR] framedef: Could not find image file (graphics/frames/blank.png) for frame (tabs).
[WitcherTRPG] [graphics/graphics_frames.xml]
[ERROR] framedef: Could not find image file (graphics/frames/blank.png) for frame (imagebox_header).
[WitcherTRPG] [graphics/graphics_frames.xml]
[ERROR] icon: Could not find image file (graphics/frames/blank.png) for icon (tabtop).
[WitcherTRPG] [graphics/graphics_icons.xml]
[ERROR] icon: Could not find image file (graphics/frames/blank.png) for icon (ct_passive).
[WitcherTRPG] [graphics/graphics_icons.xml]

June 6th, 2021, 04:45
This is amazing work! Thank you to all those who have put time it. If this is still actively being worked on, will there be refocused efforts for Unity due to the announcement of FGC support ending? It would also be great to take advantage of LOS, lighting, etc.!

June 18th, 2021, 17:43
Many thanks for all the work that has been put in, I was just wondering is this for unity or classic FG, also is there plans to maybe release this as a full ruleset in the future