PDA

View Full Version : FG Knowledge Base - Firewalls



Pages : 1 [2]

damned
May 2nd, 2017, 01:17
Trace 1 is very interesting.
What is the IP address on both the Mac and the Windows?

fightingcrow60
May 4th, 2017, 03:15
Windows: 10.211.55.3
Mac: 192.168.1.67

Because I run FG on the virtual Windows desktop, the "Load Campaign" screen displays the internal and external IP addresses from the Windows side. But my router's IP is 192.168.1.254, which looks more related to the Mac side.

I tried changing the Windows IP to fit with the Mac IP naming scheme, but this just made my computer run really slow and FG still could not pass the connection test (so I swapped it back to the original Windows IP settings).

Windows Firewall is configured to allow FG through on both public and private networks. I always run FG as a system administrator, not sure if that is relevant.

On my router page, I configured port forwarding on both the Windows and Mac IP addresses, but neither worked during test connection.

It is becoming quite the ordeal, lol

ddavison
May 4th, 2017, 03:19
Use the 10.211.55.3 # in the router port forward entry.

fightingcrow60
May 4th, 2017, 03:22
tried that, but did not work (see PORT attachment in my previous post)

ddavison
May 4th, 2017, 03:41
This might have been answered previously, but have you tried the Mac OSX Installation instead of running under Parallels?

damned
May 4th, 2017, 11:56
hi fightingcrow60 you might need to do this as well - https://download.parallels.com/desktop/v6/docs/en/Parallels_Desktop_Users_Guide/31974.htm

fightingcrow60
May 4th, 2017, 23:01
Figured it out!! Changed my virtual machine networking preferences from "Shared" to "WiFi". This allows my virtual machine to talk directly to my router (which enabled it to pick up the correct IP addresses). The set the port forwarding on my router so that the virtual machine IP is open on port 1802.

Huzzah! +1 INT for everyone :)

damned
May 5th, 2017, 07:47
Well done fightingcrow60.

crb31
June 13th, 2017, 03:32
I was connecting and then I'm not. I am not at all computer savy so will need some extra help or a good link to what I need to do.
The only thing I've done is log into my router and enable the port forwarding to 1802.

Trenloe
June 13th, 2017, 03:40
I was connecting and then I'm not. I am not at all computer savy so will need some extra help or a good link to what I need to do.
The only thing I've done is log into my router and enable the port forwarding to 1802.
Have you double checked the GM computer IP address and used this to you enable TCP port 1802 to forward to your GM computer? The IP address can change, so please check what it is now and that this matches the port forwarding on your router.

crb31
June 18th, 2017, 16:35
Have you double checked the GM computer IP address and used this to you enable TCP port 1802 to forward to your GM computer? The IP address can change, so please check what it is now and that this matches the port forwarding on your router.
Would you mind pointing me in the right direction for instructions on this? I was able to connect just fine so something in my settings or router must have changed. Thanks

midas
June 18th, 2017, 23:05
For specific instructions, please provide the make and model of your router.

From a basic standpoint, this is what you'd need to know:

- When you configured port forwarding in your router you'd have needed to tell it *where* to forward the port 1802 traffic to. This would have been the IP address of your computer (probably something like 192.168.0.100 for example).
- Since then your computer could have obtained a different IP address.
- To check your computer's current IP address there are different ways depending on what operating system you're using. In Windows 10 for example you could click on your network icon in the system tray (down by your clock), click on Network & Internet Settings, click on Ethernet and then click on your Network. This should show your IP address. For more explicit instructions we'd need to know what operating system you're running.
- Once you've determined what IP address your computer has now, go back into your router and look at the port forwarding settings. Ensure your port forwarding rule is pointing to the computer's current IP.

Trenloe
June 19th, 2017, 18:17
For instructions on port forwarding for your router: find your router make/model and look for that here: https://portforward.com/router.htm

crb31
June 21st, 2017, 15:00
I think I figured it out. Thanks. I may need some help giving my PC a static IP - but that is for the future.

DoubleDanGaming
July 1st, 2017, 08:52
Okay, so I finally figured out the whole story when it comes to setting up FG to always have 'Success!' when running the Connection Test on macOS. I have this documented so that others don't need to go through the same frustration I did.

1. First thing we need is to find out what your computer's IP address is; this is basically the 'location' of your computer in your network. We do this in macOS by clicking on the Wi-Fi icon in the task bar

http://i.cubeupload.com/hMnVH7.png

and selecting 'Open Network Preferences'.

http://i.cubeupload.com/k7rgsy.png

2. You'll wind up with this screen:

http://i.cubeupload.com/uKUsjR.png

Whatever method you're using to connect to the internet, Wi-Fi or Ethernet (or electric camel, I dunno), you will need to know your current IP address. That is found here:

http://i.cubeupload.com/qxXOw9.png

This will be in the format of a quadrapartite number, separated by periods, such as xxx.xx.x.x. THIS NUMBER IS VERY IMPORTANT! WRITE IT DOWN!

3. Okay, now we need to assign what is called a 'Static IP' to your computer. The short of it is that, whenever you have a device that connects to your network, it has to find an opening to squeeze into, so it'll do a quick scan of what 'locations' are available. The 'location' of any connected device is determined by the last number in the IP address, which corresponds to the last 'x' in the example I just provided - for sake of absolute clarity, it is the 'x' in bold here: xxx.xx.x.x.

Now, the reason we want a 'static' (or 'fixed') IP address is that connected devices like to switch addresses for various reasons, like if a device isn't always connected to the network. A good example of this would be your smartphone; you connect it to your network to minimize your data plan usage, but once you're out of range of your network, it connects to a satellite, leaving a 'hole' in your network, which the next device that connects to your home network will fill. This is what's called a 'dynamic' IP address. It changes as needed, and for Fantasy Grounds, this is the main problem people have!

4. More than likely, your Mac will be set up 'Using DHCP', like this:

http://i.cubeupload.com/0oUfnV.png

But that's not what we need; this means that your Mac can (and likely will) change its IP address when it 'needs to', which will cause problems with FG connectivity. We need to make sure that the address doesn't change...and we do that by choosing our own address! You need to click on the 'Configure IPv4' box, and change it from 'Using DHCP' to 'Using DHCP with manual address'.

http://i.cubeupload.com/ON5tVw.png

5. Remember that number you wrote down? Well, here's where we'll need it. You will need to fill in your IP address EXACTLY in this box:

http://i.cubeupload.com/Xxgaiu.png

So, if your current IP address is 192.168.0.1, you would fill in 192.168.0.1. This will basically tell your router and modem that your computer is to always be at that address, and not to switch it up. Basically, it's a reserved parking space for your Internet access. Click 'Apply', and you're done setting up the static IP!

Caveat:. There are circumstances when you might not want to keep your current IP address, in which case, you can choose any number from 2-200 for the last number. For example, you might change your new address to 192.168.0.127.

6. Now that that's done, we can move onto Port Forwarding. What we're doing here is opening up a very specific hole in our computer's firewall/router that will allow FG to communicate effectively - kind of a carpool lane type of thing. We'll need to go to the AirPort Utility, which is inside macOS' 'Utilities' folder, which you can reach by hitting ⌘⇧-U on the desktop. Open this app:

http://i.cubeupload.com/dBjhi5.png

7. You'll be shown a window with your router (in my case, 'Daniel's AirPort Time Capsule') and the Internet depicted by icons. Click on your router:

http://i.cubeupload.com/7p9N4O.png

and click the 'Edit' button on the window that pops up. Click on the 'Network' tab, as shown below:

http://i.cubeupload.com/ohKasQ.png

DoubleDanGaming
July 1st, 2017, 09:05
8. You'll reach this screen. This is where the payoff is.. Under the section labeled 'Port Settings', you'll see a '+' symbol next to a '-' symbol. Click the '+'.

http://i.cubeupload.com/Ui0qXK.png

This will bring up the following screen:

http://i.cubeupload.com/ckZGi5.png

The red box is where you need to type in the IP address of your computer. You can enter whatever you like into the 'Description' box, but as shown above, the 'ports' boxes need to have '1802' entered - this is the port that FG will make use of to communicate. Once that is done, click 'Save', and when that window closes, click the 'Update' button highlighted here:

http://i.cubeupload.com/8BDGZG.png

Once your router restarts and you can confirm that you have Internet access, open FG and test your now-successful connection!

Hopefully this helps prevent the frustration I went through!

Dan

Nylanfs
July 2nd, 2017, 02:48
Sweet, good job on the clear and concise writeup! Also welcome to the forums and FG community in case somebody hasn't already welcomed you!

Baufrin
July 19th, 2017, 06:16
This thread needs some clean up. I would suggest possibly a new thread with the opening post being a check list of trouble shooting steps and solutions.

Aracon
November 13th, 2017, 18:20
Would anyone be available around 8pm central USA time tonight to go over this setup? We got FG running on another player's computer but it won't work on mine doing the exact same steps.

Aracon
November 16th, 2017, 02:14
I am still unable to connect. 127 pages of issues and there still isn't a streamlined way to set this app up?

ddavison
November 16th, 2017, 02:16
Hello Aracon,

This normally means that the port forward settings are not set properly on the router. Can you send a screenshot of the FG connection test screen with the local IP address shown and of your router's port forward config screen? You can email it to [email protected]

-Doug

maratanza
February 21st, 2018, 01:27
Good evening, everyone. I'm afraid i too need assistance getting this port foward thing working. i am new to FG, but i have been reading this thread and thought i had the correct info for my router....i am wrong. i have a netgear routher and i logged into it to open the port 1802, but i dont think im using the correct ip address? i found 192.168.0.100 but had no luck. i tried 192.168.0.49 also. this is my first adventure into port fowarding and firewalls. Thanks for the assistance.

maratanza
February 21st, 2018, 02:11
ive used the internal ip address shown on the FG connection test to open a port on my router. i have reset the router. i went into mcafee to open port 1802. still no luck.

Aracon
February 21st, 2018, 02:31
Get ahold of “Damned” he rocks on fixing stuff.

maratanza
February 21st, 2018, 03:02
Thank you sir. I will do that.

damned
February 21st, 2018, 12:39
maratanza please open a cmd prompt and type: tracert 8.8.8.8 and post the results please

maratanza
February 21st, 2018, 13:01
Good morning from kentucky, and thank you for the assistance


C:\Users\david>tracert 8.8.8.8

Tracing route to google-public-dns-a.google.com [8.8.8.8]
over a maximum of 30 hops:

1 74 ms 3 ms 1 ms 192.168.0.1
2 10 ms 10 ms 10 ms 142.254.146.21
3 11 ms 10 ms 11 ms be59.evvninas02h.midwest.rr.com [74.128.6.101]
4 22 ms 21 ms 22 ms be27.lsvmkyzo01r.midwest.rr.com [65.29.30.38]
5 * 33 ms 30 ms be24.clmkohpe01r.midwest.rr.com [65.189.140.162]
6 37 ms 37 ms 40 ms bu-ether15.chctilwc00w-bcr00.tbone.rr.com [66.109.6.68]
7 41 ms 37 ms 38 ms bu-ether11.chcgildt87w-bcr00.tbone.rr.com [66.109.6.20]
8 35 ms 37 ms 34 ms 0.ae1.pr1.chi10.tbone.rr.com [107.14.17.194]
9 51 ms 38 ms 35 ms ix-ae-27-0.tcore2.CT8-Chicago.as6453.net [64.86.79.97]
10 35 ms 37 ms 34 ms 72.14.219.82
11 * * * Request timed out.
12 37 ms 35 ms 34 ms 216.239.47.219
13 34 ms 38 ms 38 ms google-public-dns-a.google.com [8.8.8.8]

Trace complete

damned
February 21st, 2018, 13:24
log onto your router 192.168.0.1 and create a Port Forward rule for TCP 1802 to forward to your computers LAN IP (possibly 192.168.0.49? based on your earlier post) on TCP 1802
Make sure that in Windows Network and Sharing Center your network shows Private Network

ddavison
February 21st, 2018, 14:20
If you have a screenshot (Alt+Printscreen) of your FG Connection Test screen with your Internal IP address shown and another screenshot of your router's port forward config screen, we can usually spot what you'll need to adjust. You can email those to us at [email protected] or save the images and post them up here as well.

maratanza
February 21st, 2018, 14:44
Thanks for the responses. As soon as I get home this evening i'll do everything you guys are asking. I've never even heard of port forward until a couple days ago. I am definitely a dinosaur.

Trenloe
February 21st, 2018, 14:47
Check your router model and look here for port forwarding instructions: https://portforward.com/router.htm

As mentioned above, you need to forward TCP (protocol) 1802 to your FG computer's IP address.

maratanza
February 22nd, 2018, 02:20
well. i got a success message when running the connection test, but i still get an error message when i try to join a game. may be the game address? thanks for the help.

Trenloe
February 22nd, 2018, 02:23
well. i got a success message when running the connection test, but i still get an error message when i try to join a game. may be the game address? thanks for the help.
Can anyone else connect to your GM? As a player you don’t need port forwarding to connect to the GM. The GM does need to be running heir campaign and waiting for you to connect.

Confirm the address with the GM and that their side is waiting for connections. If it is up and running check that other people can connect to the GM OK.

damned
February 22nd, 2018, 02:31
Yes as the Trenboss points out - players dont need the connection test success. You might notice this option is only on the GM screens - Create New Campaign and Load Campaign.
Your GM needs to get the connection success message...

blackbada
February 28th, 2018, 13:03
Hi everyone! I've been trying to connect to a game hosted by my DM for hours, tried everything to no success.

What I did:
- Installed tryed to connect to a game using my username, an alias or my DM's IP address. I tried it with different network configurations and firewall settings, but received the "Could not connect to the host" error all the times.

What I tried to fix the problem:
1. Tested my connection in the app - success.
2. Forwarded the 1802 TCP port to my PC's IP address.
3. Created exceptions for the FG application, 1802 port in Windows firewall. I even tried allowing all incoming TCP traffic without any program and port limitations.
4. Disabled both Windows firewall and antivirus and made sure I have no other network security software enabled.
5. Tried to connect my ethernet cable directly to the PC without using any routers.

None of the above worked. I don't know what else to try, especially considering that I don't want to host games, I just want to connect to an existing server, so as far as I understand, I don't even need the 1802 port opened.

I would appreciate any advice, thank you!

damned
February 28th, 2018, 13:12
hey blackbada thats no good.
unfortunately if others can connect and you cant it may be a routing issue between your two networks.
find your public ip and have the GM do a tracert w.x.y.z where w.x.y.z is your public IP and you do the same to hers.
there should be some similarities (reversed) in the routing - you should be able to tell if your traffic is getting lost somewhere by comparing it to hers.

ddavison
February 28th, 2018, 13:36
Hello blackbada,

Players don't have to configure their router and rarely have to adjust their firewalls. Can you confirm that the DM has other players connecting from outside their home network and that they have a TEST Successful message when they check on their end? The DM is the person who needs to port forward.

blackbada
February 28th, 2018, 14:07
Sorry but I can not post my tracert results as a text nor as an image due to my forum status limitations.


I can confirm that other players have no troubles joining my DM's games.

blackbada
February 28th, 2018, 14:10
My results (sorry for the Russian, but I think it should be understandable) - attached above

I will post my DM's results ASAP.

I can confirm that other players have no troubles joining my DM's games.

Trenloe
February 28th, 2018, 14:43
I can confirm that other players have no troubles joining my DM's games.
Can you also confirm that the GM is running their campaign, waiting for you to connect, when you are trying to connect? FG has no cloud presence for campaigns, the GM needs to have their instance of FG running waiting for you to connect.

blackbada
February 28th, 2018, 14:52
Yes I confirm that. I was trying to join a server while five other people were playing there.

Trenloe
February 28th, 2018, 15:37
Yes I confirm that. I was trying to join a server while five other people were playing there.
Please post the console.log file from your <FG app data> directory - immediately after you've tried to connect to the GM so we can see the most recent information.

blackbada
February 28th, 2018, 15:53
Not much information there, honestly.

[28.02.2018 11:41:54] Runtime Notice: Initializing DirectX
[28.02.2018 11:41:54] Runtime Notice: Initializing COM
[28.02.2018 11:41:55] Runtime Notice: Fantasy Grounds starting
[28.02.2018 11:42:05] Runtime Notice: Resolving alias
[28.02.2018 11:42:05] Runtime Notice: Alias translate result = 203.205.114.68
[28.02.2018 11:42:05] Runtime Notice: User 'blackbada' attempting connection to '203.205.114.68:1802' using alias 'tiny drow rich unicorn'
[28.02.2018 11:42:26] Network Notice: Client unable to connect to host - Could not connect to the host. Check your network settings and verify the host address, then try again.
[28.02.2018 12:47:27] Runtime Notice: User 'blackbada' attempting connection to '203.205.114.68:1802'
[28.02.2018 12:47:48] Network Notice: Client unable to connect to host - Could not connect to the host. Check your network settings and verify the host address, then try again.
[28.02.2018 13:03:40] Runtime Notice: Fantasy Grounds exiting

That's all there is.

Nylanfs
February 28th, 2018, 17:21
You using the alias the GM gave you or his actual IP address? There are certain IP ranges that get blocked by the smiteworks servers because of constant DDoS attacks (IRC ). I wonder if you are cought up in that, see if you can connect directly to the GM's IP address.

blackbada
February 28th, 2018, 17:27
I tried both methods, the results were the same: 'Could not connect to the host. Check your network settings and verify the host address, then try again.'

Trenloe
February 28th, 2018, 17:27
You using the alias the GM gave you or his actual IP address? There are certain IP ranges that get blocked by the smiteworks servers because of constant DDoS attacks (IRC ). I wonder if you are cought up in that, see if you can connect directly to the GM's IP address.
The console log shows that the Alias is being converted into an IP address OK. So there is no blocking or anything like that going on from the FG website.

Trenloe
February 28th, 2018, 17:34
Not much information there, honestly.

[28.02.2018 11:41:54] Runtime Notice: Initializing DirectX
[28.02.2018 11:41:54] Runtime Notice: Initializing COM
[28.02.2018 11:41:55] Runtime Notice: Fantasy Grounds starting
[28.02.2018 11:42:05] Runtime Notice: Resolving alias
[28.02.2018 11:42:05] Runtime Notice: Alias translate result = 203.205.114.68
[28.02.2018 11:42:05] Runtime Notice: User 'blackbada' attempting connection to '203.205.114.68:1802' using alias 'tiny drow rich unicorn'
[28.02.2018 11:42:26] Network Notice: Client unable to connect to host - Could not connect to the host. Check your network settings and verify the host address, then try again.
[28.02.2018 12:47:27] Runtime Notice: User 'blackbada' attempting connection to '203.205.114.68:1802'
[28.02.2018 12:47:48] Network Notice: Client unable to connect to host - Could not connect to the host. Check your network settings and verify the host address, then try again.
[28.02.2018 13:03:40] Runtime Notice: Fantasy Grounds exiting

That's all there is.
This appears to be working fine. There's a 20 second timeout when trying to connect to the GM's IP address - which shows this is working correctly and not being immediately rejected.

Somewhere the connection is not getting through. This could be locally on the computer, or anywhere in the process between the player FG instance and the GM. But, as other players can connect, this is more than likely local to the player - either computer or local network setup or your ISP.

Make sure your local network connection is showing Private, not Public.

If you have another computer in your house, try installing FG on that and connecting from the current computer with the issue to the new installation. Use the internal IP address to connect to this test computer. This will help to identify if the connection is being blocked on the computer or maybe elsewhere.

GarthGiantbane
April 11th, 2018, 04:56
Hi,

I went through about 15 pages but didn't see anything like this listed - my apologies in advance if I missed it.

I've been running FG for a couple years, got the port forwarding set for my computer (with it's static IP). Now my son is entering the fold and started a standard subscription. He wants to run his own games.

I got back into my firewall and tried adding another IP to the same port but it bounced with an invalid port. I know why now after an hour on the internet - only 1 IP per port forward (virtual server).

Is there a method to get get multiple computers in the same household connected to FG (to DM games)?

Thanks,
Garth Giantbane

LordEntrails
April 11th, 2018, 05:00
Is there a method to get get multiple computers in the same household connected to FG (to DM games)?

Only if your router supports UPnP, which means it does the port forwarding for you. Or you do what I do, and go into my router and change the IP addresses assigned to my computer and my son's (easier to change than the port forward rule on my router).

LordEntrails
April 11th, 2018, 05:01
Oh, the other way is you can add a command line to the FG executable upon launch (-p 1234), but then the players also have to do the same thing. Where 1234 is any open port number.

damned
April 11th, 2018, 05:10
If you are running games at separate times change the port forward each time.
Otherwise do as above by LordEntrails.

ddavison
April 11th, 2018, 14:47
In the short term, it might just have to be a part of your standard routine when hosting a game to go into the router and edit the rule to point back to your IP.

GarthGiantbane
April 11th, 2018, 16:09
Thanks for the replies.

I'll follow that suggestion and either change the static IPs between the two PC's or edit the firewall rule depending on who's playing/hosting for the session. Probably the latter, seems easier for me.

darthravage
April 12th, 2018, 22:03
This is something I do not understand what it is or how to do it. I am not able to run a successful connection test. Would someone be willing to help me??

What do I make the inbound --- to ---?
What should the local port be ---- to ----?

damned
April 12th, 2018, 23:56
The local port is always TCP 1802
The inbound port is always TCP 1802
The source IP address is usually set to ANY, or blank or 0.0.0.0

Uktar
April 16th, 2018, 00:55
having lost an most of a Sunday just to get my friggin' internet to work again after trying to get the Port Forwarding setup so I can actually run this stupid friggin' system, I'm wondering how in the world I can get my friggin' money back. I thought it'd be fun to run my brothers in Rise of the Runelords, and now all I can think is how I've pissed away a couple hundred dollars for an ultimate license and the rise of the runelords fg so that I can waste all my time trying to figure out how to be a network admin. Why or why was I so stupid? Roll20 may be a lot more work as a GM, but all i need is a friggin' web browser. If I wanted to work in IT, I would've gotten a computers degree. Is there a sticky where people who don't want to be tech support can complain about this PITA game system?

ddavison
April 16th, 2018, 01:44
Hello Uktar,

I'm sorry to hear that you had such a frustrating experience. We offer assistance via email at [email protected] for port forwarding or any other questions you have. Please send us the make and model # of your router and send us a screenshot of your Connection Test screen from the DM's computer. It normally just takes a few minutes to set up once you've been told what to put where. After that, it rarely needs to be changed or adjusted and never needs to be set by the players. There are a few cases where it gets more complicated, but we can quickly determine that for you.

We also offer full refunds at any time within 30 days if you decide that is the best route forward for you. We truly hope you will consider giving it another shot with a little bit of help. Let us know at [email protected] either way and we'll take good care of you.

-Doug

Trenloe
April 16th, 2018, 01:49
having lost an most of a Sunday just to get my friggin' internet to work again after trying to get the Port Forwarding setup so I can actually run this stupid friggin' system, I'm wondering how in the world I can get my friggin' money back. I thought it'd be fun to run my brothers in Rise of the Runelords, and now all I can think is how I've pissed away a couple hundred dollars for an ultimate license and the rise of the runelords fg so that I can waste all my time trying to figure out how to be a network admin. Why or why was I so stupid? Roll20 may be a lot more work as a GM, but all i need is a friggin' web browser. If I wanted to work in IT, I would've gotten a computers degree. Is there a sticky where people who don't want to be tech support can complain about this PITA game system?
I'm sorry you've had problems setting up your network and that you're obviously angry.

The reasons why you bought FG are still valid - it will be a great tool to play Rise of the Runelords with your brothers. If you're prepared to take some assistance from the community, I'm sure we can get you up and running.

If you're beyond that, then send an email to [email protected] and I'm sure they'll issue you a refund.

And no, there is not one single thread where people can complain. I don't really see the point in that. You've posted that you have issues getting port forwarding setup, in the right thread for that issue. If you want to officially complain, rather than just publicly get something off your chest, then use the support email I mentioned above.

My recommendation would be to try to get it working with our assistance. If you're willing, try these:
1) From a windows command prompt, type tracert 8.8.8.8 and post the results here. This will tell us your network architecture and if there might be issues with how your ISP has setup your Internet connection.
2) Make sure your network is set to Private not public, in Windows Network and Connections Center.
3) Make sure FantasyGrounds.exe has an exception in your security/anti-virus software.
4) Let us know the make and model of your Internet router, so we can help you setup port forwarding.

EDIT: Doug replied while I was typing...

Gwydion
April 16th, 2018, 02:29
I feel your pain, Uktar. When I first purchased Fantasy Grounds I took my internet down for 2 days trying to port forward! I was too nervous to ask for help on the forums. Once I got that sorted, its been nearly 2 years of the most fun I've ever had. I was so frustrated those first couple days, though, I almost quit on the program. I'm so glad I didn't and I really hope you don't either. I mean it when I say this community is the best I've ever seen for jumping in and helping people. Good luck!

Uktar
April 16th, 2018, 03:19
Thanks for the rapid response

Here's what came up when I ran tracert 8.8.8.8 :

Tracing route to google-public-dns-a.google.com [8.8.8.8]
over a maximum of 30 hops:

1 1 ms 1 ms 1 ms 192.168.1.1
2 13 ms 16 ms 13 ms cpe-174-109-128-1.nc.res.rr.com [174.109.128.1]
3 17 ms 15 ms 18 ms cpe-174-111-106-034.triad.res.rr.com [174.111.106.34]
4 21 ms 16 ms 16 ms cpe-024-025-062-150.ec.res.rr.com [24.25.62.150]
5 23 ms 21 ms 19 ms 24.93.67.202
6 25 ms 29 ms 30 ms bu-ether14.atlngamq46w-bcr00.tbone.rr.com [66.109.6.82]
7 26 ms 29 ms 39 ms bu-ether11.atlngamq47w-bcr01.tbone.rr.com [66.109.6.35]
8 27 ms 21 ms 23 ms 0.ae3.pr1.atl20.tbone.rr.com [107.14.17.190]
9 27 ms 26 ms 23 ms ix-ae-14-0.tcore1.A56-Atlanta.as6453.net [64.86.113.37]
10 24 ms 22 ms 24 ms 64.86.113.106
11 * * * Request timed out.
12 27 ms 23 ms 22 ms

damned
April 16th, 2018, 03:24
Hi Uktar,

This should be quite doable looking at your tracert.
Please find your LAN IP (FG will show you this on the Load Campign screen.
Login to your router and locate the port forwarding.
Delete anything you already setup.

Create a new Port Forward rule.
You want to forward TCP 1802-1802 on your WAN or External interface to the LAN IP address you identified - on TCP port 1802.
If it asks for a source port/IP leave it at any/any.

Feel free to PM me if you want me to jump on and have a look at it with you.

Uktar
April 16th, 2018, 03:25
Hardware & Opsys:
Lenovo Yoga 900-131SK Signature Edition
Windows 10 home, version 1709, OS Build 16299.371
AVG/Avast for firewall and security

Wireless Router: Netgear wnr2000v3
cable modem (spectrum): Netgear CM500

I believe I've managed the following:
Setup Forwardingn (on wifi router)
Application Rule for FG (although only allowed outgoing Port, not incoming) (in AVG Avast firewall)
shut off iPv6 on my laptop's network adapter...

damned
April 16th, 2018, 03:31
Hardware & Opsys:
Lenovo Yoga 900-131SK Signature Edition
Windows 10 home, version 1709, OS Build 16299.371
AVG/Avast for firewall and security

Wireless Router: Netgear wnr2000v3
cable modem (spectrum): Netgear CM500

I believe I've managed the following:
Setup Forwardingn (on wifi router)
Application Rule for FG (although only allowed outgoing Port, not incoming) (in AVG Avast firewall)
shut off iPv6 on my laptop's network adapter...

https://portforward.com/netgear/wnr2000/

If you are the GM the traffic is INCOMING. Yo need to accept connections from our players computers.
IPv6 doesnt need to be changed or disabled.

Can you on the Wireless router check what the external or WAN ip is?
Its possible that your CM500 also needs to do forwarding to the wnr2000

Uktar
April 16th, 2018, 04:24
Setup my static IP.
Created Port Forward rule
still failing connection test.
How do I deal with AVG/Avast firewall, and do I need to worry about my cable modem?

damned
April 16th, 2018, 04:31
Sent you a PM.

damned
April 16th, 2018, 06:29
Setup my static IP.
Created Port Forward rule
still failing connection test.
How do I deal with AVG/Avast firewall, and do I need to worry about my cable modem?

The best way to test if its Avast is to turn Avast off for 10mins.
Most AV apps have an icon in the system tray near the clock that you can right click and say "Turn Off" and it will let you turn off for a finite period of time.

Many cable modems are in bridged mode and everything I could find about this one suggest that its most likely in bridged mode.

If its not then you may have to port forward from Cable modem to wifi router and from wifi router to PC.

You might also look at the Hamachi thread for a nice easy way to bypass your firewall.

Uktar
April 16th, 2018, 15:32
Turn off avast and I can connect.
Turn avast back on, and Failure.
I've set up Exception, and FG.exe is on list of exclusions, but Avast is still stopping it.

damned
April 16th, 2018, 15:38
Good work.
Try delete all the rules in Avast for FG and then when you launch FG see if it prompts you?


Otherwise - need to create a custom rule allowing Incoming TCP 1802 from Anywhere in Avast.

Trenloe
April 16th, 2018, 15:39
I've set up Exception, and FG.exe is on list of exclusions, but Avast is still stopping it.
Is the exception for FG.exe or FantasyGrounds.exe? It should be the latter. And have you set the access restriction to 5 bars (all connections)?

Some info here: https://support.avast.com/en-ww/article/Antivirus-Firewall-Application-Rules

Gwydion
April 16th, 2018, 15:44
One other thing to check Uktar. Do you have your home network set to "private" or "public" (whatever network you are using to connect to FG). I think you need to make sure it is set to private as Avast has a general rule to block all incoming traffic to any network that is designated as public. Just something else to check if setting the exception to 5 bars doesn't work as mentioned above. The discussion of private/public network is at the bottom of the page that Trenloe linked above.

Uktar
April 16th, 2018, 16:00
That was the final piece, Gwydion. Thanks, to all of you for your help.
Now we'll see if I can get my players connected...

Gwydion
April 16th, 2018, 16:25
That was the final piece, Gwydion. Thanks, to all of you for your help.
Now we'll see if I can get my players connected...

Yes! Keep us posted but I am very confident they will be able to if you are getting a successful connection. Now let the games begin! :)

Senyawd
April 23rd, 2018, 20:35
23192 Ok, i am going to need some help here.. was hoping i could figure this out but still get failed test results. I have an Arris TG1652A Modem/Router... I have set up the static IP addresses for both LAN and Wireless and have set up port forwarding... hopefully the screen shot shows. I'm running the latest version of Windows 10. What else should i be looking at?

Dwayne

GarthGiantbane
April 23rd, 2018, 21:23
Check your Windows Defender or equivalent. I just went through this and finally discovered it was set to block the fantasygrounds.exe

Hope this helps.

Gwydion
April 23rd, 2018, 22:53
23192 Ok, i am going to need some help here.. was hoping i could figure this out but still get failed test results. I have an Arris TG1652A Modem/Router... I have set up the static IP addresses for both LAN and Wireless and have set up port forwarding... hopefully the screen shot shows. I'm running the latest version of Windows 10. What else should i be looking at?

Dwayne


Welcome to the forum! Good advice from GarthGiantbane. If you can, it would be helpful to know what antivirus software you use and if you have your modem going into a wireless router or you only have the arris modem/router. I have a similar Arris modem as well and the rule you set looks good to me so hopefully just a firewall setting and you will be in business!

Senyawd
April 23rd, 2018, 23:15
Windows defender along with malware bytes.... also i am just using the Arris modem/router. i do have an extender but i made sure i was not going through that. Where in defender do you see that @garthgiantbane?

Senyawd
April 23rd, 2018, 23:18
i saw a section for allowing apps and fantasy ground is checked for both private and public... is that where you are talking about?

Senyawd
April 23rd, 2018, 23:25
Can you give me an idea on where that setting is? i did see that on the firewall settings, i allow the program for both private and personal networks...Also, i turned off the firewall for defender and the problem still exists.

damned
April 24th, 2018, 00:08
Hi Senyard - please post the first 6 hops of the following command (run in a cmd prompt):
tracert 8.8.8.8

Are you connected via Wifi or LAN cable to the router?
Is your network profile set to Private or Public?
Add fantasygrounds.exe to Windows Defender
https://support.microsoft.com/en-au/help/4028485/windows-10-add-an-exclusion-to-windows-defender-antivirus

Senyawd
April 24th, 2018, 01:25
Picture of Tracert attached.
at the moment wifi, but i have had the issue when connected direct as well.
Public
added to defender... still an issue.
23201

damned
April 24th, 2018, 01:32
PRIVATE!
Change it to private please....

However it looks like you are in Mexico - you are going to need to call your ISP and tell them -

"I play this game that needs to accept incoming TCP 1802 sessions from the internet. Can you set this up for me please."

Your IP is very likely shared amongst many others...

If they cant/wont do this have a look at Hamachi or another of the VPN solutions.

Senyawd
April 24th, 2018, 01:33
Well i have already gone into the router to set this up.. Would there be other settings that need to be done? My original post showed the setting..

I'll change the network to private and see if that helps.

Senyawd
April 24th, 2018, 01:43
that didn't help either... ugh

damned
April 24th, 2018, 01:44
See post #332.

Senyawd
April 24th, 2018, 01:47
Sent a message to my VPN provider. Said they do not do that due to the security issues... oh well.

damned
April 24th, 2018, 02:05
Sent a message to my VPN provider. Said they do not do that due to the security issues... oh well.

See post #332.
Talk to your ISP.
If that is the response from your ISP ask to speak to someone else.
Keep asking until someone does it for you.
There are other posters in here from Mexico whos provider DID do it for them.

Otherwise look at Hamachi or other VPN.

Gwydion
April 24th, 2018, 02:08
Sent a message to my VPN provider. Said they do not do that due to the security issues... oh well.

Wild idea. Do you have a windows pc with windows 10? If so, and you are interested in trying a free VPN solution, if you PM me I can send you an email with instructions on connecting to the one I have set up to see if it will work for you. Would take about 10 min to try. Obviously better if you can just connect on your own but I'm happy to send to you if you are interested. Just PM me. You can see what I'm talking about in my AlgoVPN threads. Damned is the best though and if anyone can help you with your setup, he can! Let me know.

damned
April 24th, 2018, 02:34
The AlgoVPN solution that Gwydion has tested should be a good workaround for your setup Senyawd. You will either need your ISP to make a change or you will need to use a third party service.

Lazlo
December 14th, 2018, 03:39
Hello , I'm not sure if to post here but I'm having a connection problem as well , i read all the post here and tried to fix. my biggest problem is i know just enough computer skills to mess it up good i think. i made an static ip out of the routers scoap, reserved the ip, i can still connect to the net.
I set port forwarding tcp 1802 , tried router ip, comp ip, found wifi card port forwarding I think and added 1802 tcp to that as well with the comp ip. set inbound rules for 1802 on firewall. i've tried different combos but still no go. i know feel its close but i'm out of ideals. maybe i just have the wrong combo.
I play with a group with no problem but i wanted to try running my own deadlands reloaded for them. after buying what i needed i found out i cant GM. any help is well appreciated thank you!:square:

25580
25581

damned
December 14th, 2018, 11:22
Hi Lazlo talk to your ISP about doing the Port forwarding.
You go thru three sets of NAT so unless you are running some overly complex setup at home its happening on the ISPs network.
If they cant help you have a look at ZeroTier and Hamachi - your players will need to use those as well.

ddavison
December 14th, 2018, 13:55
Hello , I'm not sure if to post here but I'm having a connection problem as well , i read all the post here and tried to fix. my biggest problem is i know just enough computer skills to mess it up good i think. i made an static ip out of the routers scoap, reserved the ip, i can still connect to the net.
I set port forwarding tcp 1802 , tried router ip, comp ip, found wifi card port forwarding I think and added 1802 tcp to that as well with the comp ip. set inbound rules for 1802 on firewall. i've tried different combos but still no go. i know feel its close but i'm out of ideals. maybe i just have the wrong combo.
I play with a group with no problem but i wanted to try running my own deadlands reloaded for them. after buying what i needed i found out i cant GM. any help is well appreciated thank you!:square:

25580
25581

Your port forward entry is incorrect. For the Private IP field, you have the router's IP address of 192.168.0.1. This is your router -- also your Default Gateway on the first screenshot. You want to put in the Internal IP address of your computer running FG. This should be 192.168.0.254.

Also try to log directly into your ISP's router/modem and switch it to bridge mode if everything inside your network uses your wi-fi router. Your wi-fi router will become your main access to the Internet for everything on your network. Make sure everything gets an IP address from there or is plugged into there and not directly into the modem your ISP gave you. You may need to call your ISP to see if they can switch it for you. Just tell them that you have your own router. Because of the tracert, you will probably need their help to set things on their end.

jwrightFANTASYG
December 14th, 2018, 16:33
Do you have any firewall software running, like WIndows firewall? If so you will need to put in an exception in the firewall too.

damned
December 14th, 2018, 21:26
Whilst the port forward is incorrect - the router at hop 2 and the one at hop 3 are also doing NAT so unless the OP has access to both of these as well she wont be able to do the forwarding.

Lazlo
December 14th, 2018, 23:09
thanks for the replies and trying to help! I only have the one cable modem/ router the isp supplied me with. i connect through wifi only with laptop, ps4 and 2 phones. i have windows firewall but i input an inbound rule for tcp 1802, i even tried it with fw disabled., i will try the NAT bridged, does my ps4 and phones need static ip as well for that?

damned
December 14th, 2018, 23:38
thanks for the replies and trying to help! I only have the one cable modem/ router the isp supplied me with. i connect through wifi only with laptop, ps4 and 2 phones. i have windows firewall but i input an inbound rule for tcp 1802, i even tried it with fw disabled., i will try the NAT bridged, does my ps4 and phones need static ip as well for that?

Hi Lazlo

The TWO upstream devices from you are doing NAT.
You have to speak with your ISP and see if they can Port Forward for you or you will need to use another solution.
See the Port Forward Alternatives thread.

Lazlo
December 15th, 2018, 00:05
I appreciate y'all s help very much, i will post results with isp when i get them. zero-tier works, trouble is my group is reluctant to dl ) , thats something i have to work on lol =)

Bidmaron
December 15th, 2018, 02:20
Well, you can do PureVPN, which only the DM has to use, but it costs just a little. Their tech support is unparalleled, though (well, next to SW anyway).

LordEntrails
December 15th, 2018, 02:30
I appreciate y'all s help very much, i will post results with isp when i get them. zero-tier works, trouble is my group is reluctant to dl ) , thats something i have to work on lol =)
Tell your ISP that you "play peer to peer gaming". Don't use the term "server" or they may want to switch you to a business account.

JOCool
December 21st, 2018, 19:22
Does anyone know if you set your Modem (Verizon Vios) as just a bridget to a 3rd party router that is much better (ASUS 1900 series) if there is some trick to setting this up? I have added both TCP 1802 and UDP 3074 port forwarding in my router, but think its still not working because of the modem. Problem is, unless I revert back to the sucky Vios modem, its just a bridge and I can't access it anymore as an admin, unless I factory resent it and take it out of bridge mode. There has to be a way to fix this without completely starting over again on the modem. I've tried the port forwarding site, the ASUS customer support, and Verizon and those two are just running me in circles saying its the other group's issue.

As someone new to the software and trying to just set up a Session Zero connection test with some of my party members, I can't even do that yet. The Connection Test in the beginning keeps saying Failure.

midas
December 21st, 2018, 19:39
If your modem is in bridge mode then no port forwarding should be needed on that device, as it isn't the device that's getting the public IP, your ASUS router is. This is the ideal configuration, as you only need to deal with port forwarding on one device (your router).

To ensure it is in fact your router getting the public IP from your ISP, go to a site that shows you what IP address your traffic shows as coming from (canyouseeme.org, ipchicken.com, etc) and see if the IP there matches what your router says is its WAN IP when your modem is in bridge mode. If it matches then your issue is likely one of the following:

- Port forwarding rules on your ASUS router are misconfigured.
- Something on your PC is blocking the traffic from hitting port 1802.
- Your ISP is blocking port 1802.

The only port you should need to forward is 1802; UDP 3074 is not needed.

damned
December 21st, 2018, 23:43
JOCool start with this post: https://www.fantasygrounds.com/forums/showthread.php?47051-Fantasy-Grounds-Connections-Explained
It migt help you work out whetehr or not you need to deal with the other device at all

bambam57
January 5th, 2019, 02:57
Hi everyone, I searched but couldn't find much on wifi extenders.
I can connect fine to my Netgear router, port forwarding already taken care of and running smoothly for a couple months.
Over the holidays I got a wi-fi extender to boost signal and have my computer running off that now. I can no longer connect to FG unless I switch back to the weaker original signal. I assume this has to do with my ip address changing when I switch to the other "network"? It's still the same network as far as I'm aware but with an _EXT at the end.

Any help in this matter would be greatly appreciated.

damned
January 5th, 2019, 03:46
Are you actually using a Wifi extender or effectively using another router?
If you have a different LAN range then you will need to Port Forward Router A to Router B and Router B to your PC.

bambam57
January 5th, 2019, 06:00
Yes I believe how I set it up it might be acting as another router. So in this situation Router A is my Netgear wifi router that was originally working and Router B is my new extender. So I need to make my router port forward to my extender, and then extender to my computer?

damned
January 5th, 2019, 06:02
what is your IP when connected to each network please?
and which one works?
and can you post the results of:

tracert 8.8.8.8

bambam57
January 5th, 2019, 06:06
when FG is working, I am on internal ip 192.168.1.5
when it isnt working i am on internal ip 192.168.1.129

tracert in cmd

Microsoft Windows [Version 10.0.17134.472]
(c) 2018 Microsoft Corporation. All rights reserved.

C:\Users\Brad>tracert 8.8.8.8

Tracing route to google-public-dns-a.google.com [8.8.8.8]
over a maximum of 30 hops:

1 1 ms 1 ms 5 ms 192.168.1.1
2 17 ms 16 ms 41 ms 67.231.222.110
3 15 ms 14 ms 19 ms 104-195-128-2.cpe.teksavvy.com [104.195.128.2]
4 39 ms 13 ms 17 ms ae2-201-agg01-tor2.teksavvy.com [104.195.128.145]
5 24 ms 14 ms 14 ms ae1-0-bdr01-tor.teksavvy.com [206.248.155.13]
6 14 ms 12 ms 13 ms ae8-0-bdr01-tor2.teksavvy.com [206.248.155.9]
7 50 ms 18 ms 16 ms 72.14.211.14
8 16 ms 17 ms 16 ms 108.170.250.241
9 15 ms 19 ms 27 ms 108.170.236.11
10 151 ms 14 ms 16 ms google-public-dns-a.google.com [8.8.8.8]

Trace complete.

C:\Users\Brad>

damned
January 5th, 2019, 06:20
ok it has just extended...
update your port forward to point to 192.168.1.129

bambam57
January 5th, 2019, 06:23
Looked like that worked, its giving me a successful test now. Thank you so much

Nylanfs
January 5th, 2019, 11:31
Unless you are using eero or some other similar mesh network all the extenders that I'm aware of act as another router and it's a network inside your main network.

yannews
January 21st, 2020, 09:37
I don't have the same router that you used in your example, but I configured mine without a problem. Thanks for the help!

damned
January 21st, 2020, 11:54
I don't have the same router that you used in your example, but I configured mine without a problem. Thanks for the help!

Bye bye.

KhybersGhost
January 26th, 2020, 04:10
Just recently changed my home network setup to a Linksys Velop mesh network. Setup went fine and port forwarding looks straight forward, but I can't get it working for FG to save my life. Has anyone else used this or have any ideas? I had no issues setting it up on my previous Netgear router. I am direct connected to one of the nodes via Ethernet cable.

Trenloe
January 26th, 2020, 04:46
Just recently changed my home network setup to a Linksys Velop mesh network. Setup went fine and port forwarding looks straight forward, but I can't get it working for FG to save my life. Has anyone else used this or have any ideas? I had no issues setting it up on my previous Netgear router. I am direct connected to one of the nodes via Ethernet cable.
Check that your new network connection on your computer is set to Private.

damned
January 26th, 2020, 08:42
Did you replace your netgear or did you add to your network?
Post answers to the 7 questions in the network connections explained thread

hawkwind
January 29th, 2020, 07:47
I have a weird Fantasy grounds connection problem. My set up currently a virgin cable router put in to modem mode with a Mesh wifi setup connected to it. This was all working fine till a few weeks ago with no need to port forward. Then i started a few network connection issues where my PC wasn't connecting to the Mesh Wifi which i resolved by pulling out the usb wifi adaptor and putting it back in. Eventually it stopped working at all so i brought a replacement however while waiting for the replacement adaptor to arrive I used the internal Wifi card in my desk top successfully. The new usb adaptor arrived with its double antennae , plug it in , updated the drivers and it connected to the mesh but failed the Fantasy grounds connection test while the internal wifi adaptor works fine. Both external adaptors use the same chip realtek 8812BU while the internal card uses a realtek 8821AE chip. I'm confused as to why my nice wifi adaptor https://www.amazon.co.uk/gp/product/B01IEU7UZ0/ref=ppx_yo_dt_b_asin_title_o00_s00?ie=UTF8&psc=1 doesn't want to play with Fantasy grounds

Trenloe
January 29th, 2020, 09:03
@hawkwind - I imagine you'll have a different IP address assigned to each of the different network adapters.

Login to the admin page of your mesh wifi and see what UPnP or part forwarding is setup for the adapter that's working. Change it to the IP address of the adapter that you want to use, or refresh so that UPnP picks up the IP address you want.

damned
January 29th, 2020, 09:04
...ninja'd
or reboot the modem/router and mesh wifi

ddavison
January 29th, 2020, 12:26
I'm confused as to why my nice wifi adaptor

Please check that the new WiFi connection is marked as Private and not Public. Public connections turn on additional security features that block traffic on ports and UPnP that would otherwise work. Firewall settings may only be set to allow over Private.

Amnesty SayGen
September 12th, 2020, 01:48
Delete