PDA

View Full Version : 40k Multiset Ruleset



Pages : 1 2 [3]

Jackeyblob
September 11th, 2020, 12:43
That's fantastic mate, huge appreciation for the work you put in even after all this time.

Paul Pratt
September 14th, 2020, 06:55
New .pak posted. Corrected bugs reported. Please let me know if you find anything else.

Jackeyblob
September 15th, 2020, 13:57
Everything seems to be fixed for that, True Grit is working fine as are fields so thanks a lot for that. One question I have is regarding the Overlay Size for Creatures. I noticed in the Tutorial Document that your image shows it but I cannot find the tool for changing creature size in the Combat Tracker. I can manually tweak it but I was wondering if this was an intentional removal?

Paul Pratt
September 16th, 2020, 02:15
I need to look back and see if I removed it. I may have. Why? I think it was to make room for NPC's and their weapon lists. Let me look at what I did and I will report back.

--Side note, how are you manually adjusted the creature size?

CiaphasBlackadder
September 16th, 2020, 12:05
Hi sorry if this has already been asked, I have tried searching but not found anything and 50+ pages is a lot to go through. How do I increase a characters max carry with them having a backpack or combat vest?

PS This is fantastic, started running Dark Heresy 2nd Ed at the beginning of lockdown over skype with friends and now about to move our Haarlock Campaign onto Fantasy Grounds and this actually is why I signed up to Fantasy Grounds over some of the other options out there.

Jackeyblob
September 16th, 2020, 16:27
@Paul Pratt

When I say manually adjusted Creature Size, I meant I made the token larger on the map with the Ctrl-Mouse wheel. Sorry for not clarifying that.

@ CiaphasBlackadder

On their Character Sheet, on the Main Page, there's a row of stats for movement and carry with an edit button next to it. You can manually input the correct weight there.

CiaphasBlackadder
September 16th, 2020, 17:05
Thanks @Jackeyblob

Paul Pratt
September 17th, 2020, 06:19
@Jackeyblob - understood. I will look into the reach of the creatures. -And thanks for the help in answering the questions.

@CiaphasBlackadder, thanks for using the ruleset. I do recommend downloading the user manual in the second post of this thread and watching the youtube videos. There is a lot going on with the ruleset. Feel free to ask questions. I check the forum at least once a day when I am working local, when I am on the road - I may get spotty, but as you can see these are great people on the forum.

Valyar
September 20th, 2020, 10:43
On Unity there is console when the program is launched. This is even before I create or load a game. Quite dramatic. :D

[9/20/2020 12:42:18 PM] FGU: v4.0.0 ULTIMATE (2020-09-03)
[9/20/2020 12:42:18 PM] OS: Windows 10 (10.0.0) 64bit
[9/20/2020 12:42:18 PM] GRAPHICS: NVIDIA Quadro M1000M : 2007
[9/20/2020 12:42:18 PM] USER: Valyar
[9/20/2020 12:42:18 PM] Launcher scene starting.
[9/20/2020 12:42:18 PM] [<color="red">ERROR</color>] Extension Info Load (40K Flamer Pointer): An error occurred while parsing EntityName. Line 9, position 47.

Paul Pratt
September 20th, 2020, 16:35
I haven't updated the extension for FGU.

Jackeyblob
September 29th, 2020, 15:03
Hey Paul

Just wanted to point out, after the last FGU update, whenever I Full-Screen an image by pressing the arrow in the top right corner, it just begins to grow endlessly. I've checked a few other game systems and it's not happening there.

Paul Pratt
September 30th, 2020, 03:34
Odd, I haven't replaced any files regarding the images. I will look into this. Any extensions running?

Jackeyblob
September 30th, 2020, 15:56
I had two Extensions (Alternate Text and Imagebox) running, but I took them both off and tried it without. Just the 40K Ruleset appears to be having the issue for me and it's only just started since the last FGU update. This kind of problem I can very much see being a "my end" issue but I thought I'd mention it in case the latest update may have conflicted with something.

Paul Pratt
September 30th, 2020, 16:45
Ok, that one is weird. I will need to do some research on why this is happening. I don't grab or manipulate the image system for this ruleset. I will work on this one.

Jackeyblob
September 30th, 2020, 18:15
Yeah it is, I thought as much when it happened and spent ages trying to fix it on my end as I couldn't see why the Ruleset was causing this. Thanks mate, the effort is greatly appreciated.

Paul Pratt
October 2nd, 2020, 16:33
New .pak file posted. Corrects the issue with the ever growing image panel.

Jackeyblob
October 3rd, 2020, 13:49
Brilliant, much appreciated for the speedy fix.

Norge
October 5th, 2020, 13:16
A few things if you would indulge me;

1. I was using this ruleset and when I clicked in the reference guide this popped up:
[10/5/2020 12:28:03 PM] [<color="red">ERROR</color>] Script execution error: [string "common/scripts/list_text.lua"]:46: attempt to index field '?' (a nil value)
The Guide seems to be compiled however I'm not sure that this is saying...

2. For weapons which have say Tearing, can this be added to the actual item or only to the weapon on the character's sheet?

3. Armour; I'm trying to add armour but I can't seem to get the locations to work, also some of the armour (I'm doing DW specifically) has different values on different locations how should this be implemented?

Finally; i've watched both your vids on YouTube Paul, any chance of anymore? I know it's been a few years since those were uploaded but i found them quite useful

Paul Pratt
October 6th, 2020, 14:11
@Norge,

Tearing is added to individual weapons on the character sheet. When building the weapon library, you enter the weapon traits in the "Special" field as listed in the rule book. In this case Tearing. When a player drops the item into their inventory, they need to set the weapon up in the weapons details tab using the "special" field as a guide of what traits to add to the individual weapon. The many other weapon traits work similar to this.

Armour should be built in the items library and dropped onto the characters inventory. If the armour has varying protection values on different locations then multiple armour items should be made. Their are specific ways the "Protects" field must be written for the automation to work. The combinations are:
(this will add the armour value to all hit locations)
"All"
(these will add the armour value to only that specific hit location)
"Body"
"Arms"
"Head"
"Legs"
(these will add the armour value to the specified hit locations)
"Arms, Body"
"Arms, Body, Legs"

As far as videos I haven't returned to them. If more are needed I could do more. What sort of videos would be helpful?

Paul Pratt
October 7th, 2020, 03:33
@Norge,

Do you have any extensions running? Have you set all the options to DW (or the way you desire the game to play), and then created characters? I haven't been able to recreate the error. If you can screen shot your game table and the error that may help.

Norge
October 7th, 2020, 11:35
40005
Just before this happened I had clicked in the actions box
Edit: Also no extensions and all the settings set to Deathwatch in the options

Yindoom
October 7th, 2020, 17:37
Hiya Paul,

Thank you so much for all your hard work on this extension, Rogue Trader is absolutely one of my favourite rulesets.
Do you currently have plans of updating the extension for Unity?
Cheers

Paul Pratt
October 8th, 2020, 03:24
@Yindoom,

The ruleset works in FGU now.

Blue Haven
October 8th, 2020, 21:31
Hey Paul just a quick question, can i use the latest version on FGC?? Or since the last few updates, this only works for FGU??
Thanks

Paul Pratt
October 9th, 2020, 04:52
It works for both FGC and FGU. If there any errors in FGC just let me know.

Blue Haven
October 10th, 2020, 20:15
Ok friend ;) I will stay in touch :)
Big Hugs and stay safe :)

Morbid-Don
October 14th, 2020, 21:35
Hello Paul,

The Unity version (and I was told by player trhe original version) characters NOTEs tab is broken; (a) player says they cannot open or click on Notes (b) when I as GM enter a note on the sheet (to test) it propagates to every-bodies character sheet...

http://www.wurkhaus.com/images/character-sheet-notes.jpg

Please advise

40228

Paul Pratt
October 15th, 2020, 03:13
Interesting, I haven't seen or heard of this one before. I will check this out and get something posted back up.