View Full Version : License not working?

July 24th, 2015, 23:54
If you have issues with your license, please check these things first and see how to fix it below.

Possible Reason #1: Your license subscription lapsed or failed and was cancelled

If you have a license subscription, it is possible that your subscription has been suspended for an inability to bill it to you for some reason from Paypal. If you log on to Paypal, you should see notes about the errors. Do *not* try to force this through and correct the issue, because your license key and subscription that it was originally set up for has already been deactivated. Instead, I recommend cancelling that recurring payment entirely and then starting a new recurring payment through the Fantasy Grounds store again. If you had any other purchases attached to your account, you will need to re-run a Check for Updates to pull those back down again. If you want to try the same payment method as before, you may need to contact your banking provider or Credit Card company to ensure that they won't deny the charges again.

Possible Reason #2: Steam sent your key to us to Revoke as part of a Refund Request

If this was a mistake, please contact [email protected] You may need to re-purchase the software through Steam or from our site directly. If you purchased any DLC that did not get refunded, then I think you *have* to re-purchase it through Steam in order to re-download it for your account.

We have been very cautious with the identification of these keys, but if a mistake did happen, please contact us at [email protected] and we will work with you to resolve it in a timely manner.

Thanks and Happy Gaming!

September 27th, 2015, 00:56
MY LISCENCE aint working because I followed the damn instructions... I am soooo over this. I went from free to 3.99 subscription no email no key till I got it sorted... now I follow instruction cancel subscription wait 5 mins and upgrade to ultimate. Again no Key NO email and cant do anything with my campaign for my upcoming game grrrrr

September 27th, 2015, 01:43
Hello Meglo,

I just sent the new key. The email went out automatically, but to the address that Paypal sent to us.

December 10th, 2015, 21:16
I have tried to log into my account but I am showing a free program. I then try to enter my code again and am prompted to enter a valid user or password or re-enter a valid user login in settings. I am not sure what is going on. I own an ultimate license and all the available 5E material. I hope that this issue can be quickly dispensed with as I have a game for tomorrow - not to mention the small fortune I have spent. What do I need to do for this to be corrected. I also get an error message can't load rule set file base xml when I try to start the demo. Since I just purchased the DMG and went through the big update fiasco the other night nothing seems to be right. Thank you for the help in advance.

December 10th, 2015, 22:06
Use your forum id and password.

Moon Wizard
December 10th, 2015, 23:56
Make sure to enter all your information in the Settings (both license key and forum login), and then you need to Update before running FG.


December 17th, 2015, 12:24
Hi, at what price would you sell and or rent out the server code to allow an "off web" game to be run on a remote LAN ? Thanks,
Best regards, Andy

December 17th, 2015, 12:35
If I understand what you're asking you can do this already with either a set of full license or an Ultimate license and a bunch of free/demo licenses - but if you didn't want ANY connectivity back to the FG license servers than you'd need a bunch of full licenses

Or have I missed the point?

December 17th, 2015, 12:52
If I understand what you're asking you can do this already with either a set of full license or an Ultimate license and a bunch of free/demo licenses - but if you didn't want ANY connectivity back to the FG license servers than you'd need a bunch of full licenses

Or have I missed the point?

Yep - Full Licenses wont require you to "Check In". Steam has a 4 pack of Licenses for the price of three.

December 17th, 2015, 13:10
Yep - Full Licenses wont require you to "Check In". Steam has a 4 pack of Licenses for the price of three.

Ah, ok - So when I host a game, my hosting PC *IS* the server - I'm not remotely connected to some 'battlenet' style instantiation on a remote server system ?

So with a full license, I can run the program without internet, yes ?
and somebody else with a full license could then connect to me P2P with a twisted ethernet cable ?
Sounds like I'll have to get an extra license and try it...

Thanks !

Best regards,

December 17th, 2015, 13:19
Yes thats correct.
[DONT DO SUB FOR THIS CASE!] Do a $4 sub as your test rather than shelling out $40... just in case... you know... [DONT DO SUB FOR THIS CASE!]
Apologies - dont do the SUB!

December 17th, 2015, 14:08
No I think the sub also requires to check the validity of the sub at first load also.

December 17th, 2015, 14:39
Yes, you should avoid the subs or the Ultimate license since those all require you to check in. You will also want to turn off the alias feature when you go to launch your campaign and instead have your players use your Internal IP address for the connection.

January 16th, 2016, 02:19
I updated after purchasing the new icewind dale material and when it finished my launcher was once again reverted to the free version instead of the ultimate version that I own. I don't know why this is happening. It happened the last time I purchased a product specifically the DMG. It is making me apprehensive about buying things and updating the program if this is going to happen every time I do. I was supposed to play tonight but since I am the DM with the campaign I can't start it up and it is not looking good for playing tonight with this issue. Does anyone know why this is happening and how I can fix it. My key is correctly installed and I have used both update methods and still it shows a free version launcher.

January 16th, 2016, 02:25
this is not normal behaviour - i just sent you a pm.

January 16th, 2016, 04:35
I just sent an email on this. Were you able to get it resolved?

January 16th, 2016, 04:48
I have tried to update the game for the last 3 hours now. I bought the ultimate set for the monthly price. No problems there. Everytime i try to update it i keep getting different error messages. The current one i get now is 'SaveToVault
Unable to extract file (modules/DD5E SRD Bestiary.mod)'.
So what do i do.. just continue to retry or what? without updating my game will continue to read as free. I would really like to begin using this game asap. Any help on this issue would be greatly appreciated. Thank you.


January 16th, 2016, 04:52
Hey John,

Send us an email to [email protected] and we'd be happy to assist you. Let me know what license key you are trying to use and I can verify that you are using the correct one. Also, send a screenshot of your FG Settings window and a copy of the Update.log file from your Data Directory. That should give us enough info to identify any possible issues. Oh, and let us know what OS you are using.



January 16th, 2016, 05:28
everything hates me tonight lolol sorry wasnt really meant for anyone.. just tired of things not working like they should lol

January 16th, 2016, 05:29
No worries. Hopefully we can get it figured out soon.

January 16th, 2016, 05:38
hmmm.... stops right after the DD5E bestiary.mod well that sucks. no biggie... im more interested in the pathfinder anyways since i have all the books.. more into trying to build the modules to play anyways lol

January 16th, 2016, 05:42
ok dumb question... since it seems to be for some reason the DD5E materials thats seems to be acting up, is there a way i can add them manually or not add them at all? or do i have to add them?

January 16th, 2016, 05:49
Unfortunately, the current version doesn't handle partial or selective updates.

Do you have any parental blocks or other filtering in place? I recently saw a case where someone had something like that in place and it was causing a single file to not download because of some part of the contents. I'm not sure what it would be in the Bestiary, but you never know.

January 16th, 2016, 05:51
nope... i got everything turned on...should the updates be live...test.. or dev? n should the license key be on the lite to full license part of at the top where i had it? im also rechecking the license number to make sure its the correct one

January 16th, 2016, 06:03
You can clear your username field and run an Update. Then add your username again and re-run an update, it will try to download and rebuild your other purchases and other secured content.

January 16th, 2016, 06:11
idk what else could be messing it up... all i mainly want to do is make the different campaigns lol.. not very good as a dm lol

January 16th, 2016, 06:13
it seems to die out at the DD5E SRD Module for Bestiary :(

January 16th, 2016, 06:19
says its unable to extract the modules/DD5E SRD Bestiary.mod so idk what to do now

January 16th, 2016, 06:21
hmmm well this sucks and all i want to do is make some pathfinder campaigns lol

January 16th, 2016, 06:36
your license key should be in the License Key field and not in the Lite to Full Key spot.
if you leave the updates to continue running - as in kick it off and go and do something else (its prolly real late where you are - sleep maybe) it will keep retrying the download.

January 16th, 2016, 17:55
ok well since im waiting for the program to reinstall everything im working on creating tokens for pathfinder which is really what im interested in doing.. might be cheaper right now then trying to buy the pathfinder packs n not have the wife kill me lol

January 16th, 2016, 18:13
ok well since im waiting for the program to reinstall everything im working on creating tokens for pathfinder which is really what im interested in doing.. might be cheaper right now then trying to buy the pathfinder packs n not have the wife kill me lol

January 16th, 2016, 19:28
ok now this is funky.. now my launcher is not showing the fantasy Grounds logos.. just showing up as a square that states fantasy grounds.. is this normal?

January 16th, 2016, 19:36

January 16th, 2016, 19:39
well still trying to install n update... as soon as it's done i can try to get a screenshot.. hopefully.. i got windows 7 n my lappie is a p.o.s. lol

January 16th, 2016, 19:40
wow.. now its not even loading hmm....

January 16th, 2016, 20:39
ok first off.. idk whats going on unless i need to redo my pc... and it look like i might have to... the fantasy grounds shortcut icon is just a square with a shortcut icon on it.. same as in the folder. it wont let me even attempt to play it. and now my content file is showing up as a tmt3 file. its like theres a glitch in either the whole system or something. any suggestions before i spend like 3 hours redoing everything on my pc?

January 16th, 2016, 20:56
I updated yesterday to an ultimate license and had made the very mistake of pasting the license code in the lite to full space. I figured it out and it activated on being pasted on the top space where my original license code was located. Easily done but easily fixed.

January 16th, 2016, 21:16
hey dmkevin might want to check out the msg i sent you. might explain somewhat of whats going on

January 16th, 2016, 22:15
ok this is quite frankly.. frustrating. i downloaded the install... again and now the shortcut wont even allow me to even play the demos. what exactly am i doing wrong? i would greatly apprecaite some insight on this please. it is frustrating that i cannot even figure out whats going on short of possibly having to redo my entire pc. Any help would be greatly appreciated. you can reach me here.. or on yahoo messenger at basalan1701 or on google chat as [email protected] i guess thats how it is. thank you.

January 17th, 2016, 00:49
ok.. im back... had to totally redo the pc.. my internet sucks until tuesday and hopefully then i'll have better internet... if someone can send me screenshots of the different spots on the parts of the program i think i can start maybe build or putting together bits n pieces of what i want to do until my internet box comes in..or i kill the pc lol.. any help would be greatly appreciated. u can email me at [email protected] or at [email protected] have a good one

January 17th, 2016, 05:50
i am pleased to announce... we have liftoff!!! finally got it working... unfortunately it was not working due to my crummy internet on my cell phone but will have that fixed come tuesday evening YEAHH!!!!... now on to the fun stuff.. making campaigns...hopefully... trying to figure out how to make them by taking one apart n looking it over... if anyone know of a decent tutorial thats not on youtube that has screenshots i can read until tuesday please send me a hollar.. i will be on for awhile this evening lolol and damned and mr doug ty guys so much forr all ur help on getting it going for me.. u guys rock!!!

March 8th, 2016, 20:45
Here I go again. I tried to start up Fantasy Grounds and once again I am having the client tell me that I don't have a valid key. I can't even get to a load screen. It keeps prompting me to enter a valid key. I really hope you guys can fix this issue for me once and for all. I have my regularly scheduled game Friday and I can't get onto the VTT to prepare.

March 8th, 2016, 20:52
Celegar, please email [email protected] and provide us with the license key you are using.

March 9th, 2016, 02:32
I purchased "Crypt of the Sun Lord" and when I try to load campaign, it is not one of the options. How do I get it to show up so I can prep my game?

March 9th, 2016, 02:58
Adventures are provided as modules and can be used inside of any campaign. Create a new campaign and then activate it under Library > Modules.

March 9th, 2016, 03:05
Perfect!!! Thank you.

March 15th, 2016, 03:00
I paide the $10 and I receive no key.. I tried to contact your support and no answer. What's going on?

March 15th, 2016, 03:05
Welcome Cenaethon. When did you do the transaction and when did you contact support?
The key will be issued once paypal notify SmiteWorks that the payment has been received. Sometimes that doesnt clear on paypals side straight away.
Its after business hours in the US now so you may not get a response today...

March 15th, 2016, 03:06
Hello Cenaethon, I don't currently see any unanswered support emails. Did you email it to [email protected] or to another address?

The license keys for subscriptions are generated and emailed instantly (or nearly so) to the Primary Email address as defined within your Paypal profile settings. If you don't see it on that email address or within your spam folder, please send an email to [email protected] and provide the email address as shown in Paypal. We can look it up and send it your way.



March 15th, 2016, 11:17
I did the payment on march 13th 2016. I'm a bit confused on why I didnt receive the key already. It's been more than 30 hours, the payment should be confirmed already.

March 15th, 2016, 11:40
Cenaethon, please see my thread just before your reply.

March 15th, 2016, 11:42
I saw Damned one before so I replied without reading yours. I sent an email to your support email. Let's hope someone will answer me asap cause I am tired to wait.

March 15th, 2016, 11:48
Seriously, I am getting mad over here. You sent me a message with the License Key. I am, using it BUT IT ****ING DOESNT WORK. WTF IS WRONG HERE?????????? I still cant do **** on your LOGICIEL

March 15th, 2016, 15:30
You sent me a message with the License Key. I am, using it BUT IT ... DOESNT WORK. WTF IS WRONG HERE??????????
Why don't you tell us what isn't working? Do you get any error messages? What steps are you following? What fails? A little more info please so we can try to help you.

Moon Wizard
March 15th, 2016, 17:26
Doug helped Cenaethon on the support email.

He had accidentally set up two subscriptions in PayPal, and cancelled one. Our system only handles one subscription per user, so any cancellation affects all subscriptions. (Per FAQ on subscription page)

Doug has fixed up the system, and it looks like Cenaethon was able to install without any other issues.


Ravnos de Flambeau
May 6th, 2016, 00:05
My ultimate license is not working. it went again to free. I tried to uninstall and install again, even to play from steam, but the problem is still there. The program didn't recognice my ultimate license and It keeps saying is free. I tried to activate my licence again and nothing happened. Can anyone help me?

May 6th, 2016, 00:09
Send an email to us at [email protected] with the license key and email address you use and we can look it up to tell you the status.

You can also log onto Steam to see if you still have a recurring payment set up. If Paypal was unable to process the charge when it went to update, then it would try a few times and then suspend the account. Due to the volume, we cancel the suspended subscriptions. If you still want to use FG, you can start a new subscription and then the system will recreate a Recurring Subscription and email you a new key. * Make sure you don't already show that you have a Recurring Subscription before you do that. Our system only supports 1 sub per Paypal account.

When you get your new key, simply replace it in your FG Settings window and then re-run a Check for Updates. It should remember all your past purchases and creations and you can continue where you left off.

If this happens multiple times, you might consider using an alternate payment option or contacting your financial institution to let them know that the subscriptions charges are okay to allow.