PDA

View Full Version : Automatically Hidden Effects - Disable?



dopefish
December 5th, 2014, 16:08
Hello,

First of all, I hope I posted this in the right subforum, feel free to move it where appropriate if it's in the wrong category.

I'm using the 4E ruleset.

Some time ago, I can't remember exactly when, but it was several months ago at least, FG2 started to automatically hide all effects that I applied as a GM. The players can't see them by default and I have to go into the combat tracker, find the effect and manually change it to "All" from "GM" in the visibility options.

This seems to happen no matter what I do, as long as the effect is being applied by the GM and not from a character sheet (but from the effect's tracker, NPC sheets, Items, from the hotbar etc). It's kind of bothersome to have to manually reveal the effects I put on monsters, because 95% of the time I want the effect visible, having the effect hidden is definitely the exception rather than the rule.

I was just wondering if there's a way to prevent this from happening? Some setting, hotkey or something like that I've overlooked?

ddavison
December 5th, 2014, 18:20
Go to your preferences for the campaign and you will see an entry for Show Effects for the combat tracker and a separate one for tokens.

dopefish
December 5th, 2014, 19:00
Do you mean these options:
http://i.gyazo.com/43f200cbf78a33384ac3a67e5ce5ca63.png

Or is there something I'm missing?

None of those prevent effects that I apply from being automatically hidden.

Here's a picture of what I mean:
http://i.imgur.com/L8U0ZKJ.png

It's not that bothersome for things that don't get applied too often, but for things that re-apply every round or things that happen often like Prone it's quite annoying. Players are almost always supposed to be aware of what effects are in play in 4E and in my campaign/playstyle.

Moon Wizard
December 5th, 2014, 19:32
What version of FG are you currently running? There is a 3.0.9 live version and a 3.0.10 beta version. You should be able to see the version in the upper right of the launcher screen.

JPG

Nickademus
December 6th, 2014, 00:12
Not a solution, but a possible work-around that I've used in 3.5/PF: Instead of using effects from the Effects Window, make a 'GM' npc and put the effect actions on it. When an NPC applies an effect to a PC it should always set it to show and put it in the players' chat.

I'm not as familiar with 4E, but the GM NPC can also hold things like generic die of damage/healing, links to important text/images/items (to free up some hotbar slots), and even generic speech bubbles that can be dragged to a player's portrait to create a whisper.

ddavison
December 6th, 2014, 00:26
I haven't been able to reproduce that issue. It works properly for me; however, your screenshot of the settings looks different than mine. Do you happen to have an extension loaded? Can you try it without the extension and see if you experience the same thing? You can test with players over localhost.

-Doug

Andraax
December 6th, 2014, 01:14
I'm seeing the same thing in Castles & Crusades.

dopefish
December 7th, 2014, 01:48
What version of FG are you currently running? There is a 3.0.9 live version and a 3.0.10 beta version. You should be able to see the version in the upper right of the launcher screen.
3.0.9, the live version. Should I try the beta version?


I haven't been able to reproduce that issue. It works properly for me;
Try setting the current turn in the combat tracker to an enemy (red) NPC.


however, your screenshot of the settings looks different than mine. Do you happen to have an extension loaded?
I had Wood Theme enabled. Disabling it didn't help, same result. I do have an extension loaded (a library module), unloading it didn't help, even after a restart.


make a 'GM' npc and put the effect actions on it
Dragging effects from an NPC sheet or an Item sheet produces the same result, unfortunately.