PDA

View Full Version : compatibility of extensions and fg3



tahl_liadon
February 3rd, 2014, 14:20
.
quick question:

so it seems many of the extensions developed for fg2 are not compatible with fg3 -- is this correct?

i downloaded most of them and only 2 seems to load: enhanced images and language chat.

Trenloe
February 3rd, 2014, 14:40
so it seems many of the extensions developed for fg2 are not compatible with fg3 -- is this correct?
It depends on exactly what the extension is designed to do. But, in general, a lot of FG 2 extensions will not be completely compatible with FG 3. The main reason for this is that extensions usually take their base code from the ruleset they are designed to work with - and then that base code is changed and overrides the base code when the extension is activated. As there has been quite a lot of code changes/reorganisation of ruleset code in FG 3.0 then there is a good chance that extensions based on FG 2.x code will have compatibility issues with FG 3.0 - as the code they are based on has changed.

Also, some commands in the FG API have changed in FG 3.0 which can cause incompatibility issues.


i downloaded most of them and only 2 seems to load: enhanced images and language chat.
That will be because those 2 extensions have been redesigned for FG 3.0. :) Some others have been made compatible with FG 3.0: http://www.fantasygrounds.com/forums/showthread.php?20320-FG-3-0-CoreRPG-Extensions

Some info is also provided in some of the extension list threads: http://www.fantasygrounds.com/forums/showthread.php?15925-List-of-Extensions