PDA

View Full Version : GURPS in F.G 3.0



yako2020
November 7th, 2013, 16:56
I updated the version to 3.0 and the Dice Tower stop of work.
A new version of GURPS will be launched?

Thanks.

Moon Wizard
November 7th, 2013, 19:33
I just downloaded the GURPS ruleset from the Library section of the web site, then opened a brand new campaign with it on the FG v3 beta. The dice box was visible and accepting dice I dropped on it.

* Are you running any extensions?
* When/where did you download the ruleset originally?

Regards,
JPG

saithan
November 8th, 2013, 03:17
he may have pulled it from my site which had some minor updates... nothing involving the tower. the only breakage looks to be the targeting(expected) and targeting links showing in the tracker.
the current targeting does not show between the client and the host.
the turn indication that lights the token also does not show between the host and clients.
but all in all it is still playable.
holding out for 3.0 reference library to go online.

seycyrus
November 13th, 2013, 00:07
Saithan,

I have a group of ~5 players who will be purchasing FG for the purpose of playing gurps. One of the players has already downloaded the free version, and he tells me he updated it to FG 3.0 Beta. I am still using FG 2.4.

Should I have the new players stay with 2.94 for the time being? Or should we all go to FG 3.0?

saithan
November 13th, 2013, 05:13
it is preference, personaly I prefer to remain 2.9 till i have to

damned
November 13th, 2013, 12:02
for any live games you really should wait till 3.0 becomes official.
although - running a live game is a great way to bug test :)

Gigermann
November 13th, 2013, 19:35
I've got a couple of highly-customized skins for the GURPS ruleset that I've been working on for a couple of years now; how is v3 going to affect the ruleset/skin situation?

Trenloe
November 13th, 2013, 19:42
I've got a couple of highly-customized skins for the GURPS ruleset that I've been working on for a couple of years now; how is v3 going to affect the ruleset/skin situation?
You should be able to run your rulesets and extensions in FG 3.0 - but there has been quite a few changes in the base client so you may have to change your ruleset code a bit to cater for the FG 3.0 base client changes.

With FG 3.0 the addition of the CoreRPG and layered rulesets gives you the option to re-code your rulesets to be layered on top of the base CoreRPG 3.0 ruleset and so take advantages of many core FG functions and also help to keep your ruleset abreast of future FG CoreRPG additions. But, I would imagine this would not be insignificant work to convert over to layering on top of the FG 3.0 CoreRPG ruleset.

Moon Wizard
November 14th, 2013, 00:47
My goal with v3 was to provide as much backward compatibility as possible with the current rulesets out there. The only major thing that is not backward compatible is the targeting system, which is not accessed directly by any rulesets not already being updated (that I know of).

As long as the GURPS ruleset doesn't change, your extensions should continue to work.

Regards,
JPG

yako2020
December 17th, 2013, 22:24
F.G 3.0 is official now, the GURPS Ruleset will be updated too?

saithan
December 17th, 2013, 23:41
i't is being worked on now so it may take some time