PDA

View Full Version : Which version of FG2 will FGcon run on?



bennis1980
July 17th, 2012, 13:24
I currently have version 2.91 (using the developer updater)

Here's my quick question. Will Fantasy Grounds work regardless of the version, should we all have a particular version number or will it be GM specific?

damned
July 17th, 2012, 15:07
everyone has to have the same version - games dont connect otherwise. there is only ever one official version and often there is a beta but i think this is only run in test mode. you *should* run in 2.9 or there will be all sorts of hassles getting started...
(of course i could be wrong about this...)

Ikael
July 17th, 2012, 15:07
No, it won't work for players who have different version number than GM. If you try to connect to game which is run with different FGII version number you will get connection error related to that.

Valarian
July 17th, 2012, 15:20
I would presume the latest live version (2.9). That's the one that the Unregistered folks will be using due to the installer on the downloads page.

bennis1980
July 17th, 2012, 16:25
Ok, looks like I'll have to back track

Trenloe
July 17th, 2012, 17:09
As mentioned above, there could be issues with different versions trying to connect.

Please make sure you are all on the current live release V2.9.0 for the con - this might be 2.9.1 if Moon_Wizard pushes a live update Wednesday/Thursday so please keep an eye on the threads for a new update and apply this before you start/join your game.

Valarian
July 17th, 2012, 18:24
I'd not push a release put this week. If a new update goes put, the instaaler on the website needs updating for the unregistered people. If they've already installed FG2 it could put them off to have to reinstall so soon.

Trenloe
July 17th, 2012, 18:26
I'd not push a release put this week. If a new update goes put, the instaaler on the website needs updating for the unregistered people. If they've already installed FG2 it could put them off to have to reinstall so soon.
Yeah, I've posted on the laboratory 2.9.1 thread mentioning my nervousness regarding the update and FGCon.

Moon Wizard
July 17th, 2012, 19:14
Some thoughts:

* v2.9.1 is primarily a bunch of minor bug fixes.
* v2.9 clients can connect to v2.9.1 host.
* The ruleset files from the host always override the client for the specific campaign.

That said, I have no problem waiting until after this weekend to update. I'll just move the update to Monday.

Cheers,
JPG

Trenloe
July 17th, 2012, 19:31
Some thoughts:

* v2.9.1 is primarily a bunch of minor bug fixes.
* v2.9 clients can connect to v2.9.1 host.
* The ruleset files from the host always override the client for the specific campaign.

That said, I have no problem waiting until after this weekend to update. I'll just move the update to Monday.

Cheers,
JPG
Thanks very much MW - I really appreciate the slight delay in release. To those not participating in the FGCon this weekend - sorry for causing the delay! :)

bennis1980
July 17th, 2012, 23:03
Thanks everyone for clearing that up. I'll downgrade to 2.9 just in case. What's 0.01 of a version!!! :)