PDA

View Full Version : Concentration check



kelth04
July 5th, 2012, 18:35
I have tried to do a Concentration Check and it has appeared the next message:


Script Error: [string "scripts/manager_gamesystem.lua"]:104: attempt to call field 'get' (a nil value)

How can I solve this problem?

Trenloe
July 6th, 2012, 02:35
Please give us a bit more information:

Is this for 3.5E or Pathfinder?
Were you rolling the concentration check as a GM using a PC or as a player connected to a GM?
If a PC, what caster class and class level (CL) do you have entered? Do you have any "Conc. Check" modifier?

Basically, it works for me, so please provide more information - steps to re-produce would be good. Thanks! :)

kelth04
July 6th, 2012, 12:40
- It is for Pathfinder.
-The message have appeared when I have made the check as GM.
I am a beginner and I tried to do some practice, perhaps I have mistake introducing any related data. I will prove it again and if the problem returns I will tell you.

Thank you.

Callum
July 6th, 2012, 13:20
One more thing that's always worth asking when troubleshooting:

Which extensions (if any) do you have enabled?

kelth04
July 6th, 2012, 14:45
The extension I use is 2.9.0.

Moon Wizard
July 8th, 2012, 01:04
Kelth,

I'm looking at the latest version of the 3.5E ruleset, and I'm not seeing any get() function. This makes me think that there is an extension being used for your campaign, since there used to be a get function used in a previous version of the ruleset.

When the campaign is selected on the launcher screen, check in the lower left panel of the launcher screen details to see which extensions are being loaded. There will be a red dot next to the ones that are running with that campaign. If you are not sure, you can post a screenshot of the launcher screen after the "Load Campaign" button is selected and the campaign in question is selected.

Thanks,
JPG

kelth04
July 8th, 2012, 12:55
I have found the problem. It was created by the Max NPC HP extension. I tried to do the concentration check without this extension and the problem disappeared.

Thanks for the help.

Ciao.

Trenloe
July 8th, 2012, 15:24
I have found the problem. It was created by the Max NPC HP extension.
FYI - the functionality of this extension has now been moved directly into the V2.9 ruleset.

kelth04
July 8th, 2012, 15:47
Which others extensions are also included in this extension?

Trenloe
July 8th, 2012, 15:51
Which others extensions are also included in this extension?
From the extension list thread: http://www.fantasygrounds.com/forums/showthread.php?t=15925

The functionality from the following extensions has been added:
- Adding spells to NPCs
- NPC/Trap/Vehicle Extension
- Maximum NPC hitpoints

Also quite a few of DrZeuss's 4E extensions functionality has been added - you wouldn't have been able to use these 4E extensions in 3.5E previously.

kelth04
July 8th, 2012, 16:07
Thank you.