PDA

View Full Version : V2.9 issues with older extensions



Trenloe
May 27th, 2012, 07:32
Please use this thread to post details of issues you many encounter when running extensions made for older versions of FG with V2.9 beta or release. This will keep the V2.9 threads clear of details regarding 3.5E/PF specific extensions not written by Smiteworks.

Please post extension and version being used and details of problem - the more information the better.

spacce1889
May 28th, 2012, 02:19
Only two extentions i am current using are the 3.5 enahance image and pf language. On the enhance image I could not scroll the image around.

Trenloe
May 28th, 2012, 07:42
On the enhance image I could not scroll the image around.
The scroll button doesn't appear - neither do the "X" close buttons on windows. This will be a case of updating some of the files in the extension - shouldn' t take too long, I'll look at it sometime soon (towards the end of 2.9 beta testing).

graphil
May 29th, 2012, 19:32
Killing at minus con
http://www.fantasygrounds.com/forums/showthread.php?t=15917
throws the following error:
As DM opening skills tab on the party sheet for the first time I get.
Script Error: [string "ps_skills:skilldropdown"]:1: attempt to call field 'getPSSkillList' (a nil value)
The skill check drop down doesn't populated with skills after that.

bnason
May 30th, 2012, 03:26
I get "Ruleset Error": No vertical anchor defined for 'tabs'" in the 3.5e theme that I use.

Also getting weird behavior with the tabs - see attached screenshot. For example, frames/windows with the horizontal tabs (items/NPCs) look odd when expanded to the right.

This is how I have the tabs defined in the theme - what did I screw up?

<framedef name="tabs">
<bitmap file="graphics/frames/tabs.png" />
<topleft rect="0,0,18,13" />
<left rect="0,13,18,455" />
<bottomleft rect="0,468,18,24" />
</framedef>

Trenloe
May 30th, 2012, 10:46
I get "Ruleset Error": No vertical anchor defined for 'tabs'" in the 3.5e theme that I use.

Also getting weird behavior with the tabs - see attached screenshot. For example, frames/windows with the horizontal tabs (items/NPCs) look odd when expanded to the right.

This is how I have the tabs defined in the theme - what did I screw up?

<framedef name="tabs">
<bitmap file="graphics/frames/tabs.png" />
<topleft rect="0,0,18,13" />
<left rect="0,13,18,455" />
<bottomleft rect="0,468,18,24" />
</framedef>
As Moon_Wizard has mentioned in your thread "Making tabs resize in 2.9?" http://www.fantasygrounds.com/forums/showthread.php?t=16607 you're best taking a 3.5 theme extension (dungeon for example) and working with that. Have you done that for this post or are you still trying to make a 4E based theme work with 3.5E?

The reason we say this is that if you look at the 4E and 3.5E rulesets they use quite different directories, scripts and xml definition files within the ruleset itself. Therefore trying to take a 4E theme and run it in 3.5E is going to require a lot more changes (and potential issues) than taking a 3.5E extension, making changes and running it in 3.5E - it's compatible to start with!

P.S. I don't mean to be a "thread nazi", but this thread is meant to track problems with existing 3.5E extensions written for older versions of FG in the new V2.9 FG - I'd really like to keep it that way so developers of those extensions can track issues and upgrade their extensions.

graphil
June 16th, 2012, 15:56
For those that didn't see v2.9 is now live.

Blackfoot
June 23rd, 2012, 03:57
There seems to be an issue with the language extension. Seems like when a player doesn't have the extension on their machine it doesn't work properly and gives an error about the fonts not being available. Since this is a host side item this is a bit strange. I've seen it in 2 different games now.

Trenloe
June 23rd, 2012, 04:55
There seems to be an issue with the language extension. Seems like when a player doesn't have the extension on their machine it doesn't work properly and gives an error about the fonts not being available. Since this is a host side item this is a bit strange. I've seen it in 2 different games now.
I've just checked and the fonts are being referenced in the extension XML by the extension based path (not a computer specific path) - so not sure why this would be the case.

Was it for any specific languages?

khersheyjr
June 23rd, 2012, 06:08
I too had an issue with the language extension. I believe I was attempting to use Dwarven. I don't have the exact error but it sounds like the same issue listed above.

Trenloe
June 23rd, 2012, 06:14
Blackfoot and khersheyjr can you remember if this error occurred in V2.8 of Fantasy Grounds as well, or only since going to V2.9?

khersheyjr
June 23rd, 2012, 07:05
I have only used this extension with 2.9

Blackfoot
June 25th, 2012, 18:56
I have only seen the Languages error since going to 2.9.
I didn't run this extension regularly in 2.8.1 but when I did this error never occurred... so I can't say conclusively that it wasn't there before.. but it doesn't seem like it was.

From what we can see... the error seems to clear if the player has the extension on their machine... I'm not quite sure that makes much sense... but it 'seems' to be the case.

Oh.. and when it fails it fails for all languages.

graphil
July 9th, 2012, 18:51
Hey Trenloe, do you think you will get a chance to update extensions for v2.9x soon?

Trenloe
July 10th, 2012, 19:27
Hey Trenloe, do you think you will get a chance to update extensions for v2.9x soon?
Soon... I'm flat out with FGCon organisation (and that little thing called "work") at the moment, so hoping to get onto updating some extensions and the creature parser soon - but probably not until after FGCon.

Trenloe
July 15th, 2012, 00:28
There seems to be an issue with the language extension. Seems like when a player doesn't have the extension on their machine it doesn't work properly and gives an error about the fonts not being available. Since this is a host side item this is a bit strange. I've seen it in 2 different games now.
The extensions wasn't being downloaded to the client because of a forward slash (/) in the extension name in extension.xml - weird!

Updated extension that works correctly with FG V2.9 now available in the original thread (post #1): http://www.fantasygrounds.com/forums/showthread.php?t=15561

Zeus
July 15th, 2012, 10:43
The extensions wasn't being downloaded to the client because of a forward slash (/) in the extension name in extension.xml - weird!

Updated extension that works correctly with FG V2.9 now available in the original thread (post #1): http://www.fantasygrounds.com/forums/showthread.php?t=15561

Trenloe - In pre 2.9, FGII required the / to be included in the registration of slash handlers. From 2.9 onwards this is no longer required as the FGII engine manages the /.

2.9 introduces several changes to the API. You may want to refer to the release notes to understand how the changes potentially impact existing rulesets. The Ruleset reference in the Library has also been updated to provide 2.9.1 API reference information.

Trenloe
July 15th, 2012, 16:10
Trenloe - In pre 2.9, FGII required the / to be included in the registration of slash handlers. From 2.9 onwards this is no longer required as the FGII engine manages the /.

2.9 introduces several changes to the API. You may want to refer to the release notes to understand how the changes potentially impact existing rulesets. The Ruleset reference in the Library has also been updated to provide 2.9.1 API reference information.
Thanks for the heads-up re slashhandlers and API changes DrZ.

The issue I was having with the 3.5E/PF language extension was the / in the <name> tag in extension.xml - the name was "3.5E/PF Languages" and the / resulted in the extension not being downloaded to the player side. If the player had the extension manually installed in their extensions folder it loaded and worked, players without it manually installed got errors during it's use by GMs and other players as it hadn't downloaded (and hence loaded) on their computer.

I simply changed the name to remove the / to "3.5E and Pathfinder RPG Languages" and it now downloads and starts fine on all players computers - with or without it being manually installed.

Something to watch out for when naming extensions (and I'm guessing modules).