PDA

View Full Version : Need help with slipstream showing on FG



Magnatude
May 22nd, 2011, 09:16
Hi there,

Ok. Am I doing something wrong here?

So in order to start creating an adventure using slipstream...

Open a new campaign choosing Savage Worlds... correct? its the only thing i see SW related (no slipstream exts mentioned on my list).

Open up the modules Slipstream players/GM's... right? They show up as books in my library. (BTW, some of my game-made modules are too overlapping in the selection window, cant open half the books)

Click on some links in the Players, notes indicate I need the Slipstream ext to activate???
Wait a second, cant open ships links, so there is something wrong.


Before I start barking that I payed good bucks for this tripe... can someone please tell me what I missed? do I need to bust open a pak file or something?
I thought I'd get at least a new look or Slipstream 30's style character sheets...???

Also High tech armor... BLANK
Seems to be absolutely no drag/drop functionality...

If I'm not missing something.... I'll have something not very nice to say about this $20 !!!! (very high price compared to other rule-sets) purchase. Face it, Slipstream at this price better do some fancy stuff.
So, before I start becoming "not-nice"... please tell me what is the problem here

phantomwhale
May 22nd, 2011, 10:34
I know nothing of Slipstream, but thought I'd chip in with what I know of the SW ruleset.



Open up the modules Slipstream players/GM's... right? They show up as books in my library. (BTW, some of my game-made modules are too overlapping in the selection window, cant open half the books)


Modules with too long names can break the functionality in the modules screen (preventing neighbouring book being opened). I've seen this with long adventure names. The current workaround is to create / adjust them to have shorter names.

The ruleset could be altered to auto-trim module names, or the interface could be adjusted to accommodate longer names too. If either of those sound like something you'd like to see in a later version of Savage Worlds, then the best thing to do would be to raise the idea over here - http://savagefgii.idea.informer.com/

This is the wishlist tracker for SW; there is a sticky post with more info on the forum.



Click on some links in the Players, notes indicate I need the Slipstream ext to activate???
Wait a second, cant open ships links, so there is something wrong.


There is the core of the problem - it sounds like you need an extension for Slipstream to correctly function - and the listing in the store says it comes with one. No idea why your not able to see it though.

Which version of the Savage Worlds ruleset are you using ? (if you aren't sure, type "/version" into the chat log and paste in the response).

If it's the latest version (3.1.0) then as a complete guess there might be a compatibility issue that needs to be patched. I believe Slipsteam is one of Kevin's (Doswelk) modules, so I'll let him confirm if this is the case or not.

I've played in Kevin's Hellfrost extension before, and it came with customised graphics and the full book in FGII form (along with drag and drop skills / edges / hindrances etc...) so I'd be surprised if Slipstream came with any less.

Doswelk
May 22nd, 2011, 13:58
Open a new campaign choosing Savage Worlds... correct? its the only thing i see SW related (no slipstream exts mentioned on my list).
There should be a Slipstream extension


Open up the modules Slipstream players/GM's... right? They show up as books in my library. (BTW, some of my game-made modules are too overlapping in the selection window, cant open half the books)
Are you running this on a Netbook?

I have never had an overlapping issue, maybe send a screen grab?


Click on some links in the Players, notes indicate I need the Slipstream ext to activate???

Wait a second, cant open ships links, so there is something wrong.
See above about the need to load the extension


I thought I'd get at least a new look or Slipstream 30's style character sheets...???
Slipstream was created before the ability to theme Fantasy Grounds had been developed back then it would have been a whole new ruleset.


Also High tech armor... BLANK
I do not understand what you mean here.


Seems to be absolutely no drag/drop functionality...
What drag and drop functionality do you mean?

Magnatude
May 23rd, 2011, 03:13
Even better, I've made a video showing my predicament

http://youtu.be/suXA5gj_VEk

Yes, the Slipstream.ext file is in the FG2 extensions folder.

As for Drag in drop, I was assuming there would be some kind of stuff able to drag onto the character sheets, like other lower cost rulesets.

But its apparent that there is some kind of problem I'm encountering, as you will see on the video. (private not open link, I'll delete it once you have viewed it.)

phantomwhale
May 23rd, 2011, 03:37
Great video - may I ask how you did that ? Would love to produce some videos like that to showcase new SW and DLR features. As well as teach my players how to do some basic tech. stuff now and then !

Anyway, from a Savage Worlds ruleset point of view, I can see a couple of things from your video:

Firstly, the version - it's version 2.0 - I believe. Since then, there was a v3.0.8 release, which has been around for at least 2 years, and then v3.1 this year, which is the version I authored.

Not knowing the extension, I can only guess that it requires version 3.x to be compatible ? I'd certainly recommend the upgrade, as the ruleset has come a long way recently and I've managed to plug up many bugs with the v3.1 release.

On top of that, your overlapping modules issue is probably going to still be in v3.1 - I don't think the format of that menu has ever changed. That said, if you push it onto the v3.2 wishlist (http://savagefgii.idea.informer.com/) as a "problem" / bug then I'm more than happy to work on it.

I prefer to fix bugs than add new features, so should manage to stomp that one for the next release.

Again, I'll hand back to Doswelk to work out why the extension isn't appearing, and make his final suggestions as the extension author.

Magnatude
May 23rd, 2011, 03:52
Damn so I bought the wrong version from Drivethru???

That ticks me off, "fumes" there's seemingly no way to tell whats current. (Edit: confirmed I've purchased V3 on my account there... but if this is only v2??? Drivethru sent me the wrong file?)

(Using Camtasia for the video stuff.)

phantomwhale
May 23rd, 2011, 04:10
Well, there's a whole heap of assumption built into my comments. So don't start fuming on account of my guesswork...

I presume when you say "the wrong version", you are referring to Slipstream ? Because the version of the Savage Worlds ruleset I think you have is pretty old (and not for sale on DriveThru any more). However, I'm 99% sure that the upgrade to v3.1 is free of charge. You might need to contact Smiteworks directly to sort out getting the new files - they bought DigitalAdventures (who wrote the older versions) a couple of years ago, and I'm not sure the handover of the list of ruleset owners was ever done perfectly. But like I say, upgrades were free, from memory - I think I had v2, but never used it, and I ended up getting the free upgrade before I started using it properly.

Again, I'll leave it to Kevin to confirm if Slipsteam requires the newer version. But that would seem more than likely, given what I've seen.

Not sure if the upgrade will disable any of the other extension I saw on your video in however, as most of them are unknown to me. But some of them look like patch-type extensions, which hopefully are no longer required.

Magnatude
May 23rd, 2011, 04:14
lol... well I thank you for your insight, I re-downloaded the ruleset and applied them and now I have v3 savageworlds showing and slipstream ext shows up.

But... still missing armor as in the video and the mods are still messed up on the Disposable heroes, so I'll see about changing those default names if I can. (Drag-drop works for the sheets)

Its weird because I just bough almost everything for FG2, and not long ago (a couple months ago or so)

phantomwhale
May 23rd, 2011, 04:17
Well, the name is simply a line in the definition.xml file inside the .mod file (which is just a zip file in disguise).

You still never told me how you did that video ;)

Magnatude
May 23rd, 2011, 04:52
Camtasia Studio... but you can also check out something like this:


Free- Manycam
and hook up to livestream.com (free too)

Use manycam to broadcast your desktop and livestream to capture the live footage, you can edit it after using livestream tools.

Camtasia costs a bit, I have a slightly older version but it works fine.

Doswelk
May 23rd, 2011, 10:27
Phantom is right you have the wrong rule set.

That's the old Revised Edition rule-set not the SWEX Edition which was Slipstream was designed for. That said (apart from Extensions) it should work.

The Overlapping menus was fixed a while back (but not in that ruleset)

I do not think I still have a copy of the Revised Ruleset any more to test.

That said the armor problem is a bug (given the age of the modules I'm surprised that your first to notice it - I've never got round to playing Slipstream yet hence I hadn't.)

I'll see if I can find my old copy of the Revised Ruleset somewhere.

Magnatude
May 23rd, 2011, 21:18
Awesome, thanks for the help.

I play a lot of Iron Heroes as well and I'm hoping some fixes come to that too.


I guess I'm one of "few" who dared to get Slipstream? I like the rules/concept, I'm a bit of fan of Daniel Torres (Rocco Vargas) a Spanish comic book artist that writes a lot of 30's 40's serial sci-fi. This just recently inspired me to create a Slipstream(ish) campaign.

ShadowGriffon
May 24th, 2011, 22:45
I just finished running a Slipstream campaign with FG. The high tech armor table under gear is empty. All other tables appeared to have data.

Doswelk
May 25th, 2011, 09:23
The bug in Slipstream Armour took me ages to find!

Basically xml is case sensitive and I had put an upper case 'A' in the link, I'll post the fixed version to Doug ASAP.

If anyone wants to hack it manually let me know and I'll post the fix here.

Magnatude
May 25th, 2011, 18:44
sure please post :) I'm not afraid of a little XML...

well...

as long as the nightlight is on.

Doswelk
May 25th, 2011, 22:57
Open the Slipstream Player module with Winzip/WinRar/etc

Edit common.xml (and client.xml) as follows:

Find the following line:

<link class="sw_table_wide_short" recordname="ss_gear.hightech._01_Armor">Armor</link>

It should be around line 304 change it to


<link class="sw_table_wide_short" recordname="ss_gear.hightech._01_armor">Armor</link>

(basically change the capital 'A' in the recordname entry)

Be careful not to change the lowtech entry (this should be in upper case)

Magnatude
May 26th, 2011, 01:41
ok...
I took the mod, renamed it as a zip, unzipped.
Changed the "A" to an "a" on the correct line and saved it.

Took the folder and zipped it.
then renamed it properly. "SlipStreamPlayer.mod"

It doesnt show up in the mod list or as a library entry anymore.
Could this be because I'm using an older version of WinRAR to zip?

Griogre
May 26th, 2011, 05:16
Make sure you use plain zip not 7-zip.

Magnatude
May 26th, 2011, 05:34
yep, just plain zip, weird...

Griogre
May 26th, 2011, 17:20
Hmm. A lot of zip utilities automatically put the zipped files together in a folder. The module won't work in this case. You want to double check that.

Magnatude
May 26th, 2011, 18:17
BINGO!
Awesome, yeah that was the problem. Haha...

Griogre
May 27th, 2011, 16:18
It's always those "helpful" software features that are killers. :p