PDA

View Full Version : Deadlands Reloaded adventure now available in the store



ddavison
May 21st, 2011, 20:50
Coffin Rock has been converted for play now by PhantomWhale. Check it out.

https://www.fantasygrounds.com/store/product.xcp?id=S2P10201FG2

CAPryde
June 28th, 2011, 18:47
What all does the module contain? Maps? Images? Stat blocks? Box text? I'm thinking about purchasing it to use with my current campaign, since we're already in Colorado.

phantomwhale
July 5th, 2011, 02:17
It contains everything from the book.

So in a nutshell, the images from the book (artwork and the map of Coffin Rock) and all the stat blocks, the full scenario broken into story elements, and box text. Should note that coffin rock as a module didn't come with much "box text" - it's quite an open adventure in nature, so doesn't lend itself well to drag and drop text.

It is a fun adventure though, and came as a breath of fresh air for my group after a couple of heavily rail-roaded (stylistically, and actually using railroads) adventures beforehand.

CAPryde
July 5th, 2011, 18:51
I got it and am really liking what I see. I think that it will contain enough sub-adventures to fill out most or all of the rest of the summer for my group. In my perfect world, I would have preferred some combat maps, but Pinnacle almost never prints them, so I wasn't that surprised. I can use Pyro's map tool to whip some stuff up pretty easily.

phantomwhale
July 5th, 2011, 23:35
I played through coffin rock without whipping up extra maps, I just used the letter tokens and what was provided. I think the only scene that needed a new map was probably the final one. But all said, my group has demanded more maps in later adventures, for greater immersion, so maybe that was a learning experience for us.

For later adventures I'm converting, I'm hoping I can share maps and tokens I've created via the forums. As these are normally made with whatever images I can find on the internet, I can't be sure on the copyright status of them, so therefore can't put them in the adventure. Hopefully they are OK to provide as free of charge fan-created downloads (IANAL).

RKBrumbelow
July 5th, 2011, 23:40
phantomwhale the general rule is unless it says free for commercial usage or is old enough to be in the public domain, it is NOT free for commercial usage. However if it is posted on the web you should be able to provide a link to it outside of the module.

NEPHiLiX
July 9th, 2011, 06:23
Just bought the Deadlands' ruleset and am loving the features, but my FG's been acting up since I've added the ruleset in. FG crashes for myself and my players (haven't had this problem at all since I got the new PC, but now the crashes are back). I literally got the second line of this error message a couple hundred times on the error log:

Runtime Error: Cache file write error
Ruleset Warning: Anchored control static height ignored for 'state'
Ruleset Warning: Anchored control static height ignored for 'state'
Ruleset Warning: Anchored control static height ignored for 'state'
Ruleset Warning: Anchored control static height ignored for 'state'
Ruleset Warning: Anchored control static height ignored for 'state'
Ruleset Warning: Anchored control static height ignored for 'state'
Network Notice: Host connection closed
Runtime Notice: Returning to launcher

Any ideas?
Thanks.

RKBrumbelow
July 9th, 2011, 06:28
Should we assume you have already reset/ emptied your cache and tried to reinstall, and that having failed you deleted FG2 and reinstalled it? If not You should start there and see if the symptoms remain.

NEPHiLiX
July 10th, 2011, 10:01
I wasn't aware that the cache would pose any problems. I've emptied it though, and everything seems to be running fine again.

Thanks!

Moon Wizard
July 10th, 2011, 10:10
There have been occasional reports of the cache file write error message. Deleting the cache has always solved the issue. I believe it is caused by file corruption or file access rights issues. I have not been able to reproduce during testing.

Regards,
JPG

CAPryde
July 13th, 2011, 06:02
Just wanted to drop a line here to say that we played our first session in Coffin Rock this week, and it was a lot of fun. I'm deviating quite a bit from the adventure itself, but the setting material, characters, hooks, etc. are absolutely fantastic.

tikyren
July 17th, 2011, 02:08
Since I changed over from Savage Worlds to Deadlands Reloaded I am running into issues such as: messages during play are not being displayed, parts or whole character sheet disappear, and sometimes reappear, huge delay in dice being displayed, this only happens to me when there are three people connected. I have tried to uninstall and re-install the program and ensure all updates are done.

By the way, great work on the rule set. I absolutely enjoy it.

phantomwhale
July 17th, 2011, 04:10
Worth reporting these types of errors, perhaps in the House of Healing forum.

Deadlands adds some functionality and cosmetic changes to the SWEX ruleset, and I've been developing long enough to never say never, but the problems your talking about appear to be networking issues between clients, so perhaps more tied to the core software or the network.

I've certainly had all the errors you've mentioned at some time using some rulesets. One session, a player had her dice delayed by about 2-3 mins ! But on a later session, it got better. This pointed at more transient networking issues - we never resolved them, but if it's happening more often it's probably worth looking into on the support forums.

But like I say, happy to investigate if things start to point at DL:R in someway !