PDA

View Full Version : Test Release 2.7.6



Moon Wizard
May 16th, 2011, 21:26
Please see the sticky thread on public testing if you want to be involved. Only the Test mode slot contains this version.

As always, please make a backup of your campaign before opening with a test release.

I will update this thread as I release new iterations of the test version. I'm hoping to make this one a quick turnaround to fix a single issue.

Thanks,
JPG

Moon Wizard
May 16th, 2011, 21:26
Common module loading works again. Too aggressive with network optimizations.

Moon Wizard
May 16th, 2011, 21:27
I need someone to test out this fix by loading a host and a client on separate machines, and verifying that common modules on the host (which are not installed on the clients) are visible.

Thanks,
JPG

Trenloe
May 17th, 2011, 01:21
I've tested this test release with the 2 campaigns that were giving me issues with the move to 2.7.5.

They look to be working OK now.

This was tested on a LITE licence.

Thanks for sorting out a fix so quickly.

Cheers,

Martin.

mfitzi
May 17th, 2011, 14:51
Hello,
If I were to upgrade to version 2.7.6, would I still be able to be a player in a game where the GM is still on version 2.7.5?

damned
May 17th, 2011, 15:43
i updated ok!

Sorcerer
May 17th, 2011, 16:07
However to answer mfitzi's original question - it is a very bad idea for a group to run a game where mutiple versions are running at the same time.

This can cause errors and data corruption [depends on what has been changed during the update]. Hang around the 'house of healing' long enough and you will see "is everyone running the same version" is asked time and again by dev's looking to solve issues.

best thing is to coordinate with your GM to make sure you are all on the same page.

Moon Wizard
May 17th, 2011, 20:28
As Sorcerer states, it's generally a good idea to all be on the same version.

In this case, the change from 2.7.5 to 2.7.6 was very specific, and shouldn't have an impact. It will only affect clients, not the host.

Regards,
JPG

Zeus
May 18th, 2011, 00:48
Question: Is there a way to interrogate the FGII version programatically through the API?

If there is, it probably makes sense for ruleset developers to poll all clients as they connect to the host to ensure the client is running the same version as the host, if not a warning message could be issued to the chatwindow.

Would probably eliminate all the support requests where the problems were down to version mismatch.

Moon Wizard
May 18th, 2011, 08:10
The major and minor versions are checked before allowing a connection to occur. (i.e. 2.6, 2.7) However, the dot releases do not.

No way to get the version for the application, only for the database. Good idea though.

JPG