PDA

View Full Version : Extension not registering



El Condoro
May 14th, 2011, 04:39
My '4E Criticals and Fumbles' extension (by DrZeuss), which has the Tables dependency, is not registering in campaigns (it has a red cross next to it). Is this something to do with the Launcher? I noticed in the 2.7.5 update that dependencies was a fix.

Zeus
May 14th, 2011, 09:55
The red X denotes that the dependencies have not been met. In this case the extension is dependant upon v1.4 of the 4E Tables extension.

Make sure 4E Tables v1.4 is installed and selected for the campaign.

Note: 2.7.5 seems to have been rolled back last night. The current release version is 2.7.4 again. Not sure why this has occurred though.

El Condoro
May 14th, 2011, 12:02
According to the registrations in the chat box I have Tables 1.5. I assume 1.5 is compatible with 1.4?

2.7.5 had a fix to extensions with dependencies not loading - it was rolled back due to an unrelated problem (can't remember what but it was on the forum).

BTW: What do you use to create your maps? - they look great.

Zeus
May 14th, 2011, 13:16
It's odd. If you have v1.5 and Tables is selected, you shouldn't be seeing the red cross symbol. At least I don't have it on my test and live release of 2.7.5. Weird.

Given its been rolled back for the time being, lets wait and see what changes JPG makes before I change anything further.

As for my maps I use Photoshop, see here (http://www.fantasygrounds.com/forums/showthread.php?t=14318) for more info.

El Condoro
May 14th, 2011, 16:41
I am able to get rid of the red cross if I manually edit the extensionsstate.xml file. I'm not sure if all works as it should yet but it's a start.

gmkieran
June 3rd, 2011, 04:12
Dr Z, I'm in the same boat with El Condoro. I've got FG 2.7.5, tables 1.5 and I've got it selected, I've made sure House Rules is un-selected, but I still get the 'dependencies not met' X when loading my campaigns. Any solutions other than the manual edit?

Thanks!

Zeus
June 3rd, 2011, 08:33
Dr Z, I'm in the same boat with El Condoro. I've got FG 2.7.5, tables 1.5 and I've got it selected, I've made sure House Rules is un-selected, but I still get the 'dependencies not met' X when loading my campaigns. Any solutions other than the manual edit?

Thanks!

I have set aside some time this weekend to test/make compatible all my extensions for v2.8.

I'll check the dependency settings for 4E Criticals & Fumbles and will get back to you soon.