View Full Version : Public is at Maximum Hand-size

May 1st, 2011, 03:49
I had two groups (one allied one enemy) and two PCs in the combat tracker, checked off the "Deal Card?" box for both groups and both PCs, and it would only let me deal 3 cards. Every time that I tried to deal another one, it would read: "Public is at maximum hand size".

Can anyone tell me what the heck is going on and what I'm doing wrong?

Thanks in advance.

May 1st, 2011, 05:15
Can I check which version you are running with (type "/version" at the chat log) ?

May 1st, 2011, 12:10
It's version 3.1.0 (build 16).

May 1st, 2011, 15:01
The "Public is at maximum hand size" element is normally only seen as part of the general (non-combat) card dealing mechanics which were untouched in the v3.1 update - and I acknowledge would benefit from a little polish.

Normally when there are "full hand" issues with the card dealing windows I'd recommend opening up the "tools" menu, right-clicking the card deck menu and select "reshuffle cards" which should reset the deck and allow fresh hands to be dealt to players and to the public hand (which is seen by all players and what your error message refers too).

However, you are also talking about the combat tracker, which has a separate and much better card dealing mechanic built into it (and uses a different deck to the general card dealing function, as far as I recall - can check if needed). So I wouldn't expect to see the "public hand at maximum" message from using the combat tracker tool ? (I certainly can't recreate it)

What I understand you are doing is you have unchecked the deal card option in the combat tracker (which prevents new cards being dealt to each combatant each round) ? And then you are trying to deal card to each group and PC ? Aside from the automatic dealing function in the combat tracker (which I think most people use), the other way I know of doing this is right-clicking the playing-card space on the combat tracker and selecting the West option of "Deal Card" ?

However, I just checked this in Savage Worlds v3.0.8 and v3.1.0 and in both cases it seems when you have the "Deal card ?" checkbox unticked, then the manual "Deal Card" option doesn't do anything ! Suspect this really SHOULD still deal a card, even if you have the tickbox unchecked, so will add that as a bug for v3.2. If you need to manually deal a card to someone with the checkbox unmarked, you can do it by ticking the checkbox first, then simply unticking it afterwards; this is quite a laborious workaround, I'll admit, although I must admit I am curious why you wouldn't go with the automatic dealing option in this situation ?

Hopefully what I say makes sense; please let me know if and where I've misunderstood what your doing and I'll try and see if there are any other problems here and help out where I can !


May 1st, 2011, 23:40
Thanks for the reply. To clarify, by checked off I mean adding the check mark in the "deal card" box. I was using the combat tracker's auto card dealing system during the combat, but wanted to use the manual method to start the combat, which is where I encountered the problem. I can just refrain from doing that, it just seemed a little more suspenseful to start that way (because you can drag out the dealing process a bit and PCs, who are aware of the dealing order, can see the cards come up one by one).

May 2nd, 2011, 00:44
Ah, OK.

Well my takeaway points are these:

(1) You should be able to use the radial menu "Deal" command when the "Deal Card ?" checkbox is unticked

(2) The manual card dealing is still somewhat unhelpful at times. But then I already knew this :)