PDA

View Full Version : Token Zoom not working in 2.7.4



Slipshod
April 18th, 2011, 00:10
Not sure if it worked before (newish user), but I just found the "Zoom 2x" option of the right-click menu, and all it does is expand the spacing in the token bag. It doesn't actually make any of the tokens larger.

Is this the correct place to report this as a bug?

gmkieran
April 18th, 2011, 18:50
Slipshod, this is the place, but it doesn't sound to me as if you're trying to zoom in the correct area. The token zoom in the bag is only for making them easier to see and select. I don't believe you can permanently affect the size of a token, or the apparent size of a token, in the bag. However, when you drag a token from the combat tracker onto a map (and only when you drag from the CT), you should be able to use the mouse wheel or hold CTRL and scale the individual token instance for that map by changing the scale inside the CT.

You can also change the apparent size of all tokens on a map by placing a token, zooming the map in 'til the toke is the relative size you want and then right-clicking on the token and locking token scale. All tokens will now have the same relative scale to that map. As long as they're all correctly sized relative to each other, you should be fine. If you have a mix of token sizes, as I do, you'll still have to scale some of the tokens individually during combat.

Other than those two options, the only way I know to change token size is to edit the individual .jpg/.png files outside of FG and re-save the correctly-sized tokens. There are tutorials on doing that in the Downloads section, iirc.

Hope some of that information is helpful, anyway! Cheers!

Slipshod
April 19th, 2011, 07:55
I wasn't trying to make them permanently larger, just easier to see. Based on the name of "Zoom" I was hoping it would actually zoom them, so I could make out detail better and pick the one I wanted. My monitor has a very fine dot pitch, so they're really small.

If all if does is spread out the tokens without actually zooming them, you should really change the label to something like "Seperate" or "Spread". Or get rid of it, because that's a pretty useless feature.

Leonal
April 19th, 2011, 08:19
For the ruleset built-in tokens (d20_JPG) I see it just increases the spacing, but for tokens manually placed in the tokens folder it does indeed zoom so you can view them more easily.

Slipshod
April 19th, 2011, 22:29
Leonal,

Thanks for the info, though that does get us back to there being a bug. All of the tokens I was looking at were added by me into the tokens folder. They are 50x50 images scraped and resized from the D&D Minis website, using a script one of the users here had posted.

If it matters, I'm using Window7 x64 (and had previously seen the same behavior on Vista x64).

Moon Wizard
April 20th, 2011, 18:28
I've put it on my list to check out.

Thanks,
JPG

Moon Wizard
April 21st, 2011, 00:09
I took a quick look today. Here is what is happening.

The token bag has a fixed grid in which all tokens are displayed. If the token is larger than the space allotted, then the token is scaled down to fit. If the token is smaller than the space allotted, it is not scaled.

When you choose the zoom option, you are essentially increasing the size of the grid in the token bag. That option was added as a way for GMs to review larger tokens, which tended to have more detail.

Regards,
JPG