View Full Version : Chat Log and Dice problems

January 24th, 2011, 00:38
I recently started up a new Fantasy Grounds game using the 4e ruleset. I patched my version up to 2.7.3. I am an Ultimate license user and my players are connecting using unregistered licenses.

One of my players connected to me via LAN, and created a character with no problems. I could see all of her rolls and chat normally.

Then, three other players connected to me from other locations, and there are many issues going on with them, including:

-When they roll dice, the result number graphic does not show up. Instead, it comes up in this format "(Unnamed) (d6=6:0):" That example is if they were to roll a d6.

-If they try to roll any skills, powers, or other rolls from the character sheet, I cannot see the results, but they can. My screen will just say "Name -> [Attack (M)] Falchion (vs. AC)" if they try to roll a falchion attack, for example.

-When they type in chat, sometimes random dice bubbles with 0 in them appear. When I add these 0 bubbles to the modifier stack, it reproduces what they just said in the chat window.

-When they type in chat, sometimes random vote boxes appear next to or in the middle of their speech.

I have no idea what is going on. The only idea I have had is that they all told me they are running version 2.7.2 because the unregistered version is not allowing them to update. They have tried doing full FG reinstalls with no luck.

The program is basically unusable at this point, which has unfortunately ruined tonight's game. Any help you can give would be greatly appreciated!

It might also be worth noting that we have all run the 4e ruleset in Fantasy Grounds 2 before with no problems, about 6 months ago.

January 27th, 2011, 02:47
One of my players did a full uninstall of FG2, including removing the application data folder and deleting the root folder of the program. I also did an uninstall, and removed everything related to the program- even the registry entries.

We both redownloaded and reinstalled. When he connected to me, he could roll his dice just fine! I had saved my portraits, tokens, images, db.xml, and campaign.xml files. I replaced these, and he could access the character he had made before (when the program was fritzing) and roll his dice just fine.

Then, I tried this with another friend and it only partially worked. I could see his dice rolls, but they all showed up in an "xy=z" format on the chat line and without the modifier graphic (very hard to read). No matter what we tried, he could not get his dice to roll normally.

It's perplexing because both friends run Windows 7 on similar laptops.

Also worth noting, I noticed that my router had changed my local IP address. I'm not sure when this happened, but I had to reopen port 1802. Is it possible that this unopened port could have been causing these issues? I have not had a chance to test again with my players.

The program is technically usable again at this point, but being completely unable to drag my player's modifiers and damage around is a real drag. I also noticed the complete lack of response on the boards. Has no one else had this problem?

Thanks for any info!

January 27th, 2011, 03:49
I am not a 4e player, so I don't feel qualified to answer this other than to say that I have not seen anything like it personally. I don't normally follow the 4e threads, so can't say what's happening there. Usually, by now Oberoten or Griogre or DrZeuss would have chimed in. I do know there have been issues reported with the mismatch of game versions on gm and client machines, but I am just not familiar with the problems they were causing, and I believe most of the issues were one or two minor updates ago.

It is probably a good time to ask again when the problem will get fixed about free licenses not being able to update will be fixed? Devs?

January 27th, 2011, 04:13
As Bidmaron mention its very possible that your problems come from the server and clients being at different versions. I would e-mail [email protected] and tell them your problem to make sure it is seen. I thought they had said they fixed the unregistered version to be updatable but maybe not or there is a bug.

Moon Wizard
January 29th, 2011, 22:17
My guess is that it is version incompatibility. There were 4E updates between 2.7.2 and 2.7.3.

I've sent a note to Doug to update the download for Unregistered versions.

In the mean time, you can also use the Test Mode Manager tool to set your FG client to "Dev" mode. I have co-opted that download slot to maintain the current download version until we get a chance to overhaul the updater. Look under Utilities in the Downloads section the web site. Once you run the utility, just start up FG, and select Update to down-rev.


January 30th, 2011, 04:55
Please have your unregistered players re-download the installer from the FG Downloads page and reinstall. This should bring them to 2.7.4 so they will match the current version you are using for the host. Update your copy to the latest as well (from the Update button) to make sure you move to 2.7.4 too.

January 31st, 2011, 13:36
Redownloading and reinstalling fixed the issue for all of my players. In the case of the one player still having problems, he was downloading an older version from an old link.

I wonder if this means that my players will have to reinstall FG every time there is an update? It seems much more inconvenient than allowing the "check for updates" button to function for unregistered users. But, I'm not a programmer and there might be something I'm missing here.

Regardless, thanks for the help!

Moon Wizard
January 31st, 2011, 22:53
We have plans to update the updater. Hopefully, soon after the v2.8 update for FG.