View Full Version : Could not load ruleset root file base.xml

January 21st, 2011, 15:12
Could not load ruleset root file base.xml

When I try to join my own campaign as a player with a new window on the same PC, I keep getting the above error. I don't understand why this started happening. I was doing this for an entire day when I first purchased the program, then while I was play-testing some stuff I was creating <BOOT> and now I can't sign back in.

I tried signing in under a different player name a few minutes ago and it says "licenses key conflict."

It may be worth noting that the GM campaign works just fine. I like having the ability to sign in with a character to test stuff out as I am very new to the system.

Thanks in advance!

January 21st, 2011, 23:18
To run two instances on the same machine the second instance needs to connect with a different log on id and you need to connect using the local IP address or on most widows machines you can use localhost instead of the local IP address. The license key conflict means you are either using the alias or external IP address.

January 22nd, 2011, 14:45
Thanks for responding.

If by "different log on id" you mean the username entry on the player sign in sheet, then they are indeed different - they have always been different. You are correct on the external IP, however. that was the one time I tried using that address rather than the local one.

It's still not working. Any other ideas?

Other info:
I am using the Dark Heresy Ruleset available on the FG wiki.
When I log on with a player, my GM's log actually reads " 'player name' connected"
The download bar fills all the way up before I receive the error message.

January 22nd, 2011, 17:31

I fixed it! I am not sure exactly what went wrong, but something in my original campaign folder was causing an error. I know this because when I downloaded a fresh version of the DH rule-set and slowly started to put things back and arduously signed in and out in a trial-and-error fashion, the folder containing my campaign was causing an issue. I made a new campaign folder and transferred over my maps and campaign information (the "db.xml" file.) Now everything seems to be ok. Hopefully this can help someone in the future.

January 22nd, 2011, 18:43
Glad you got it working. As you noticed, not being able to find the root file base.xml when you start a campaign typically means ruleset corruption or the server trying to run a ruleset that is not compatible with the version of FG on the server.

January 23rd, 2011, 03:55
Thanks, Griogre, but here we go again...

I have been using it all day making my first mod and getting really excited about playing on Tuesday. A minute ago, I was "masking" a map. I wanted to see what it would look like form a player's perspective, so I logged on and WHAM! Getting the error again. I turned off the mask and removed the map, but to no avail. Still can't get on as a player. The map I used has nothing unusual about it, which leads me to believe that it is not the culprit. Perhaps the masking tool is causing an issue? The folder is empty now, so I don't see how the problem would persist unless it broke something when I used it.

If anyone has any info, please post. This seems to be a bug issue and it certainly challenges my confidence in the product. It's been driving me crazy for two days and I have spent countless hours on it. Any help would be greatly appreciated.

Thanks in advance.

Moon Wizard
January 23rd, 2011, 19:15

I run two instances of FG all the time in order to perform development on FG and the 4E/3.5E rulesets.

The only reason that I can think that a second instance would not be able to load up is because of a corrupted cache. You can try deleting the campaign subfolder in the cache folder of the FG2 application data folder. It should "re-download" the ruleset files, including base.xml.

I've never used the Dark Heresy ruleset, since I don't play that game.

If you still see it, can you post some info:
* user names for host and client
* campaign name
* any steps you know that can recreate


January 26th, 2011, 22:31

Thank you very much. Clearing the cache seems to be a good, quick fix for problems like that. It is working ok now.

For the information of the community and anyone daring enough to explore the problem deeper , I would like to add that I believe the problem is caused when one uses the masking tool in the GMs map menu.

Anyone have a fix for this? The masking tool seems to be an integral part of GMing ANY system.....

Moon Wizard
January 29th, 2011, 04:52
I use masking in every game session I run without seeing that issue. It's either something unique to Dark Heresy, or a specific combination of actions that cause the issue. In either case, I'd like to hear if anyone can recreate consistently.