View Full Version : Purchased adventure, please help!

November 16th, 2010, 04:57
Ok, so I purchased the adventure One on one#3-The Forbidden Hills and have no idea how to use it. I did the auto-installer and it put a folder in my AppData folder named XPR One-on-one#3 The Forbidden Hills. Now, I did notice that it placed a MPEG file in my modules folder as well. But the thing is, I have no idea how to access this adventure. Please help me out here!!!
Thanks in advance for any help here

November 16th, 2010, 05:43
This adventure, and others in the store, installs as a module. Windows thinks these are movie files due to the extension, but they are actually compressed zip files that Fantasy Grounds recognizes when it runs. Load an existing campaign or create a new one and then click on the Module activation screen. You should see an entry for the Forbidden Hills modules. You *activate* it by opening the book icon. You do that by click dragging as if you are opening a book.

Once opened, it will create new tabs under your story, personalities, images and items screens. There is an intro story element and they typically have links to all the various game elements you need to run your game. You can use the same approach when you create your own modules or adventures as well.

* Note: If you don't see the tabs right away in a brand new campaign, you can create a new entry in each section and then close and reopen the module to get it show up. Closing out of FG and getting back in normally does the trick too.


November 17th, 2010, 01:41
I did all that and there is no module for me to open. The only thing I dont understand that you are saying is:

"Note: If you don't see the tabs right away in a brand new campaign, you can create a new entry in each section and then close and reopen the module to get it show up. Closing out of FG and getting back in normally does the trick too."

I dont understand what you mean by this.

November 17th, 2010, 08:52
Adventure modules create story, image, item and NPC entries in FGII. They don't appear in the library, like rules modules do. When you activate the module by opening the book in the modules area, you should see a new tab appear at the bottom of the story section (and the others) that contain the adventure module content.

November 17th, 2010, 09:23
I think Doug means that sometimes you double click the module name (or drag click the book icon) to activate it and nothing happens - the module appears to open, but no items appear in the story window etc. (this is a bug). The work around is to create a new tab in the story window/personalities windows etc, which forces FG to take a closer look at what it should be displaying and so the 'hidden' module entries suddenly appear. Personally if it happens I go for option 2. I close down and restart FG which seems to work well.

However, none of that is any help to you if there is no module in the activation window for you to activate.

I can really only think of two reasons for that to happen

1. module is not in the modules folder (you have already confirmed that it is)
2. You are trying to access the module from an incompatible ruleset. (only modules supported by that ruleset show up in the activation window)

The blurb in store says it is a 3.5E module, compatible with d20_JPG

I have to say this is not correct. This is a 3.5E module, whilst you can run 3.5E games on d20_JPG it is not set up by default to accept modules from 3.5E

if you are running d20_JPG then you can still use this module, but you need to edit one of the ruleset files.

in rulesets\d20_JPG you will find the file: base.xml

you can open this file with notepad.

at the bottom you will see the entry

<acceptfrom ruleset="d20" />
<acceptfrom ruleset="foundation" />

this tells the ruleset that as well as d20_JPG modules it should also list and use d20 and foundation modules.

you need to add a line to tell it that 3.5E modules are also OK. change it to read.

<acceptfrom ruleset="d20" />
<acceptfrom ruleset="foundation" />
<acceptfrom ruleset="3.5E" />

make sure you get all the punctuation and the case of the letters correct.

save the file and exit. make sure notepad has not added an extra .txt to the file name on saving. (if it has change it back to base.xml)

now you should be able to restart FG and the module should be listed in the activation window.

the other option would be to change the module's definition file to read d20_JPG instead of 3.5E (if this is the only 3.5E module you will ever use this would be the easier option), but altering the ruleset means you don't have to change all the indivdual modules if you have or obtain any more.

if you are actually using the 3.5E ruleset then I can't think of any other reasons for your problem at the moment.

November 18th, 2010, 01:24
Ok, opening it up in the 3.5 ruleset worked. Thank you very much for the help