PDA

View Full Version : My PC rolls init and it shows as an NPC in the log



adminwheel3
November 15th, 2010, 00:38
I should have taken a screen shot - and this isn't the first time it has happened so I doubt it will be the last.

I set up an encounter and then add the NPCs to the combat tracker using the handy dandy button.

Then when I ask the PCs to roll init, one of my PCs is rolling init for one of my NPCs, both in the log and on the tracker.

I delete that particular NPC, I delete all of the PCs from the tracker, I have everyone close the map, close the tracker, I open the tracker, add a replacement NPC, pull the PCs into the tracker from their portraits and POOF. Happens again. This time the same PC is rolling init for the new NPC I just added.

Do I just need to give up, delete the character sheet and start from scratch with him because he's got cross linked mumbojumbo somewhere in the whosits?

Oh and this is 4e.

PS: Oh I found it - not that this means much but this is in the chat log

Agressive Grey Wolf 9 -> Initiative [1d20+6 = 16]

Moon Wizard
November 21st, 2010, 22:03
That is bizarre.

The initiative code uses the CT node of the shortcut passed with the roll. The CT node is determined by going down the CT list and comparing the passed creature node with the links in the CT. The first match wins.

My guess is that the NPC is somehow set to a PC link.

First, make sure you are not dropping the PCs onto the NPC shortcut fields.
Next, you can try clicking on the NPC shortcut field to see what sheet opens.
Finally, perhaps the link got corrupted in the encounter or module. You might need to recheck the shortcuts and records for that creature.

In my games, I usually just have the PCs already all populated in the window, then I drop in NPCs by encounter or individually. I've never seen a cross-link problem, but I could understand it happening if the wrong link was dropped on a link field.

Regards,
JPG

adminwheel3
November 22nd, 2010, 01:53
Thanks for the feedback, that will be a good 'best practice' to follow going forward.

By the way I got some clairity on what triggers this - its the shortcut on the player's hot bar. Affects multiple players. Rolling init from their character sheet works fine.

In case it matters I do log on with their character (server character) as local host to make sure their links are updated correctly. Maybe me logging in as them is causing their hotbar links to fubar.

Moon Wizard
November 22nd, 2010, 02:00
Ah, that explains it. The problem is that the hotkey bar does not have a good working relationship with the ruleset. The shortcut link is apparently saving the CT node ID instead of the character node ID.

Fixing hot keys is something that I briefly looked at, but it's not a simple fix. I've been distracted by other projects but I need to go back and find a way to make this work at some point.

Hot keys have a similar problem with effects. (i.e. effects active at the time the hot key is set are taken into account (whether or not they are still in effect), and current effects are not.)

The challenge is that hot keys are originally designed just to be static dice/number rolls. I would need to build an entire hot key system within each ruleset to support the roll types for those rulesets.

Cheers,
JPG