PDA

View Full Version : Issues with 2.72



NEPHiLiX
November 14th, 2010, 23:50
I've been having a number of big issues with version 2.72. I loved the beta version of 2.71: no crashes, working functionality, etc. With 2.72, I have sporadic issues with token re-sizing, spell fumble tables not populating, players' (and my) instance of FG crashing *constantly* when I access their sheets or share a map or the combat tracker, etc. There are so many problems with it (for all of us) that I don't even know where to begin.

Should I just rollback to 2.71?

Any advice?

GunnarGreybeard
November 16th, 2010, 12:17
2.7.2 has actually been working great for me with the exception of a Visual Basic error I am getting. It happens 1 time every 2-3 hours into the game session and I have not been able to pin it down.

NEPHiLiX
November 21st, 2010, 04:12
Alright...it's still happening. Very frequent and extremely frustrating crashes (wiping out the combat lineup, not saving some critical effects mid-battle after a crash, etc) and very inconsistent functionality. I have five players, each of whom has bought this program and it's becoming useless to us! We need these crashing issues dealt with so that we can actually use this program!

Moon Wizard
November 21st, 2010, 22:12
Nephilix,

FG auto-saves every five minutes on the host machine. Any changes between auto-saves would be lost on a crash. In most games, not much is lost because five minutes is usually one player turn or so.

As for the crashing, I would need more information. The primary situation I have seen with the RM ruleset is memory usage with modules.

* Can you check the memory usage for Fantasy Grounds using Task Manager while in the campaign?
* Are there any modules you can disable while playing vs. building characters?
* Are all the machines crashing, or just the host machine (which resets the clients but they do not crash)?

Thanks,
JPG

NEPHiLiX
November 22nd, 2010, 01:52
Thanks for getting back:

The memory usage usually varies between 1 and 1.4 million--which is shocking because video games don't even use that much on my machine.

I can try disabling more of the sourcebooks, I really only need about three--and I don't allow any of my players to have access to any (not because I don't trust them, but rather because I'm hoping that that will minimize crashes).

Finally, my players' instances of FG usually crash a few times before mine comes down, usually when I share the combat tracker or when I access their character sheets (not change them, just access them) causes their instances to crash. And sometimes, they just crash entirely independently of that, so I'm at a loss to pinpoint the cause.

Moon Wizard
November 22nd, 2010, 03:13
The RMC ruleset creators implemented the RM tables with each entry having its own XML entry. In FG, each XML entry gets its own instance of an underlying script object. This combination causes high memory overhead.

My guess is that the memory overhead on your machines spikes at certain points during the game, which puts it over the 1.8G hard limit for applications.

I'll see if I can sneak something into the next release to help a bit on the memory usage.

If you can create any reproducible scenarios for me, it would go a LONG way towards cleaning up any issues.

Thanks,
JPG

NW_Salmon_Watcher
November 25th, 2010, 08:12
Greetings.

I am also noticing some unusual things since I updated to 2.7.2. Here is each problem/concern I have noted:

1.) During my last game session (11-21) our game was interrupted several times by: "video hardware errors". Several times the error caused FG to close, interrupting the game session. Later the errors didn't close FG but still disrupted us. (Additional info from "Windows 7 Action Center" listed 3 files as related to this error: WD-20101121-1712.dmp and sysdata.xml and WERinternalMetadata.xml).

This error ONLY occurred when FG was running and particularly, when I displayed maps. ANY THOUGHTS ON THIS?

2.) The /Help command seems to not be working any more.

3.) The CHATLOG no longer has a default color for player actions/dialogue that helps to differentiate it from DM or NPC dialogue. Why is that? This makes the Chatlogs harder to read; not easier.

4.) [Similar to 3] The CHATLOG now omits the colon between the name of the speaking/acting party and their dialogue or actions description. That too makes the chatlogs harder to read.

Any feedback would be very helpful, particularly if we can get some of these issues resolved.

Moon Wizard
November 25th, 2010, 22:28
Thanks for the feedback.

1) I've never heard of this happening before. FG uses DirectX for all graphics, and the graphics drawing code has not changed. Perhaps a driver or hardware issue that just cropped up?

2) The /help command built into versions of FG prior to 2.7.x was incorrect, and did not include any ruleset commands. Therefore, it was removed, and each ruleset can implement it's own. Eventually, all slash commands will be managed by the ruleset code for maximum flexibility in ruleset creation.

3) I looked at the log code, and the coloring has not changed. The color in the chatlog should match the color in the chat window. Are you talking about emotes, actions or normal chat? It might be tied to the colors used by the ruleset, not the chat log code.

4) Reported issue at top of my list for next version.

Thanks,
JPG

NW_Salmon_Watcher
November 28th, 2010, 19:15
I think you are correct about the graphics bug. I updated my graphics driver and we gamed last night for 5 or so hours with no further trouble on that front.

Regarding the colors in the chatlog... I think now I might have simply been mistaken about this or confused by the fact that the coloring in the chat windows are not the same as the log. For example, when one of my players used a /act command last night, it showed in red in the window, but when I reviewed the log this morning, I see it as blue. That's no big deal, but the colon omissions are a real pain so I am very happy to hear you are adding it to the bug list.:D

I can live without the /help but eventually as need commands are added, it would be nice to have one hot key that fixes everything. For the record, I am using the d20_JPG_3.0.5 ruleset.

One last question, and I'm not sure if this is a problem from the 2.7.2 update or not... sorry.

During last night's game we had a LOT of Effects going during one big battle, so for the first time I tried to use the Effects option in the CT. Adding multiple effects was easy enough, but when we advanced round by round I did not see the number of rounds still in effect change. I also tried to individually click them with the double-arrow buttons and they still didn't move. I haven't really used Effects before, so I don't know what the explanation is.

Is this something that just doesn't fuction correctly in d20_JPG_3.0.5 or am I doing it wrong, or what? :confused: THANK YOU, again!

Sorcerer
November 28th, 2010, 20:17
@ Salmon _Watcher

If you want the rounds to decrease in d20_JPG effects then you need to set the first box to the number of rounds and the second box to -1. the rounds will then count down by 1 every round and then expire automatically.

NEPHiLiX
November 28th, 2010, 22:25
I can't seem to reproduce the crashes...it just crashes out randomly. Sometimes it happens before anyone is connected, and other times after a few hours of play.

And I still can't figure out the sporadic functionality: token and map/picture re-sizing, for example. I used to be able to do this all the time. Now I can't re-size my tokens at all, and sometimes I can re-size the map during gameplay and other times I can't...also, the spell fumbles, while the table shows up, doesn't populate the entries (with text)...meaning that I have to go find my old Spell Law book and figure it out manually. It's extremely frustrating... What's causing this?

Moon Wizard
November 29th, 2010, 00:49
I didn't change the color code, but I noticed that the order of the color codes varies in different languages. I bet the graphical color codes used by DirectX have a different format than HTML, which is why you are seeing different colors.

Thanks for the update. That was helpful.

Cheers,
JPG

NW_Salmon_Watcher
November 29th, 2010, 16:26
I will give that a shot, although I must admit to being hazy about what you mean by "first box" and "second box". Maybe it's because of the early hour and being only on my second cup of coffee??? But I'll play with this before my next game session and see if I can make that work!

Again, with appreciation!

NEPHiLiX
November 30th, 2010, 18:08
Sooooo...any help with the sporadic functionality?

(1) token and map/picture re-sizing: token re-sizing doesn't work for me at all anymore (using the mousewheel on or near the token in the combat tracker).
(2) while I can re-size the map during game prep, I can't resize anything during gameplay.
(3) the spell fumble table shows up but the entries don't populate with text.

Programmers?

PS: can you guys please enable drag-and-drop effects from the LA and SL tables to the combat tracker in the next update?

NEPHiLiX
December 2nd, 2010, 02:05
Are all the Developers on holidays or what? Can I get some help here?!

NEPHiLiX
December 3rd, 2010, 03:12
Listen, I and my players, like so many others I'm sure, have spent combined over $200 on this program and in spite of the fact that we love it (when it works!), we're running into some serious issues that make our use of this program more trouble than it's seeming to be worth.

So if this is the only available venue for asking for help on issues that we're having, then how about some devoted help? My players and I play every week and these issues are increasingly grinding us to a standstill.

Where is the support for this program?!

Griogre
December 3rd, 2010, 05:53
You would probably get a better response if you e-mailed tech support: [email protected]

NEPHiLiX
December 3rd, 2010, 12:12
Thanks, I'll do that!

ddavison
December 4th, 2010, 09:24
NEPHiLiX,

Moon_Wizard recently identified a reduction in memory usage across all rulesets and it is currently in developer testing. This will probably help Rolemaster quite a bit since it seems to be one of the more hefty rulesets when it comes to memory usage.

For #3, I think this has to do with the default window size not allowing enough space for the text to render graphically. I can reproduce this locally and fix it by CTRL-dragging the window larger.

On your other issues #1 and #2, we are unable to reproduce reproduce these. Can you provide more information on the tokens you are using? I tested locally with a Disposable Heroes Fantasy set token attached to an NPC from the Creatures and Treasures module and was able to drag it from the Combat Tracker to the map and then re-size without issue. The map I used was from the Riverside Inn module with a 50 pixel grid set.

On another note, do you have more than one network address active at once on your host? When I host from my laptop, I usually connect directly via Ethernet instead of using my wireless connection. In this case, it is best to turn off the wireless entirely prior to hosting your game from FG2.

I *am* using an updated version of the ruleset that Lee Rice provided, but the updates were mostly surrounding drag and drop of weapons, spells, etc.

-Doug


Sooooo...any help with the sporadic functionality?

(1) token and map/picture re-sizing: token re-sizing doesn't work for me at all anymore (using the mousewheel on or near the token in the combat tracker).
(2) while I can re-size the map during game prep, I can't resize anything during gameplay.
(3) the spell fumble table shows up but the entries don't populate with text.

Programmers?

PS: can you guys please enable drag-and-drop effects from the LA and SL tables to the combat tracker in the next update?

NEPHiLiX
December 4th, 2010, 15:38
Thanks for the tip on the phantom spell failure text! Works beautifully now! I also received a Rolemaster Classic patch from support and it worked like a charm for the token and map re-sizing!

I'll try hard-linking to my internet next week. I'm not sure if I have another network address active, I host FG using Hamachi.

NW_Salmon_Watcher
January 1st, 2011, 01:30
I just wanted to give a shout-out to Moon Wizard (and anyone else involved) who worked on the chatlog colon/color issue I posted about last month. When the 2.7.3 patch came down I was thrilled to see those 2 issues addressed and I have been meaning to express my gratitude every since, but have been busy. Nevertheless THANKS SO MUCH!

UPDATE: (I actually tested the 2.7.3 patch and found there is still some strangeness to the coloration).

When I view the chatlogs now (after the 2.7.3 patch) I am seeing some very different colors from what FG displays. Now everything is varying sheds of reds & pinks; hard on the eyes.

I looked at my chatlog with the XML (or are they HTML?) codes and noticed that they now all have begin with "ff". Example:

(Code before 2.7.2 - circa Sept 5) = <font color="#660066">Campaign saved.</font><br />

(Code after 2.7.3 - tonight) = <font color="#ff660066">Campaign saved.</font><br />

I started experimenting with the chatlog file and I noticed that by removing the "ff" prefix, the colors returned to what they used to be. So was this "ff" supposed to get in there with the 2.7.3 patch or was that some glitch? Any chance of going back to original color coding, before 2.7.2?

THANKS, again! Sorry to be a nag about this, but my players and I rely on the chatlogs a lot to keep our game consistent and the harder it is to edit & read, the less useful it is to us.

Moon Wizard
January 6th, 2011, 00:16
Thanks for the detailed info on the issue. Looks like only part of my changes made it into the 2.7.3 release. I'll look into putting out another patch.

Thanks,
JPG