View Full Version : Mac drawing issue

Moon Wizard
July 16th, 2010, 04:51
This is the thread to talk specifically about Mac issues with the test release.

I just set up Test Release 10. The only change is that I reverted to the original DirectX libraries from 4 years ago.

Let me know what happens.


Moon Wizard
July 16th, 2010, 04:53
Also, I just set up VMWare with an Ubuntu virtual machine and installed Wine. I just need to figure out how to configure Wine to run FG, and hopefully I'll have a local test for emulator changes.

I'm looking into getting Mac OS X set up as a test as well, but that looks to be a bit more complicated.


July 16th, 2010, 09:02

TR10 exhibits the same problems for me as per the previous TRs. At this moment I am not 100% sure whether this is being impacted by my setup as whilst I have been unable to identify differences (aside from graphics cards and drivers), Vudo has been able to get TR9 successfully running under CrossOver 9.0.1/Wine 1.1.34 with the -r flag.

For me neither using the -r flag or omitting it makes any difference, I still get black and flickering backgrounds.

I think it might be best to wait for someone else who's running on Mac/CrossOver/Wine to give it a go before you expend anymore effort.

Can someone else with a Mac give this a go please.

OBSERVATION: If I configure Wine Config to override the d3dx9_31 and d3dx9_42 DLLs with the versions bundled/builtin with Wine 1.1.34, I get the following error when launching FGII.

wine: Call from 0x7b82dc47 to unimplemented function d3dx9_36.dll.D3DXCreateTexture, aborting

Using the versions bundled with FGII, allows FGII to start without an error or exception being raised but I have the background issues as described above. Curiously I note d3dx9_36.DLL is not included with the FGII distribution suggesting its not being used. However in the Wine bundled versions it appears to be needed as the resulting call to it is failing as its not implemented in the CrossOver bundled version. This is starting to give me a headache.

Someone please put me out of my misery and confirm 2.7.0 TR10 is not working for them either? If its just me, I may have to go and lie down :(

July 16th, 2010, 13:14
Sorry to say, it's not just you. Still having the same issues with TR10.

July 16th, 2010, 13:35
Oh thank god for that, I was beginning to think I was alone on this one. Its odd how for Vudo, all appears to be working.

Can you add the spec of your system to the thread, along with versions of CrossOver/Wine your using and the Bottle config. The more information we can share with J, the easier time he's going to have locating the issue.

July 17th, 2010, 18:12
Okay, I managed to play around with it some today, and installed the latest release candidate for Wine (1.2-rc7) and it appears to have eliminated most of the issues. When the application first starts background behind the main window is black until you move the mouse over the Fantasygrounds window. The background then refreshes and everything appears to function as normal.

For reference, I've tried it on my iMac and mbp and had identical results for all testing.

2.93 GHz Intel Core 2 Duo
4 Gig Ram
NVidia GeForce GT 120 with 256 Meg Ram
Snow Leopard 10.6.4

2.26 GHz Intel Core 2 Duo
2 Gig Ram
NVIDIA GeForce 9400M
Snow Leopard 10.6.3

Tested using Wine 1.1.43, 1.1.44 and now 1.2-rc7 on both machines, with identical results each time. I'm not using Crossover on either machine.

Things are looking up! Time to go see what else I can break.

July 17th, 2010, 20:00
I have been testing some dev builds for JPG this afternoon and whilst the root cause is not 100% yet identified, JPG is narrowing it down as he has had a build of 2.7.0 working today :)

Interesting how you have managed to get some success with the latest version of Wine, but if the Launcher is starting without a background until you click the window, the problem is not resolved merely masked. You might find odd rendering when the campaign starts up.

I'd wait for the next test release from JPG, I'm sure it will fix the problem so you can go back to using a stable release of Wine.

July 17th, 2010, 22:57
Just a heads up, rather it makes any difference or not, Wine 1.2 is officially released today.

Moon Wizard
July 18th, 2010, 03:16
I'm working with DrZ to narrow down the issue. We identified several chunks of code which appear to contain the culprit, but I'm continuing to have him try out releases as I try to nail the specific code that is causing issues.